mattie112

Members
  • Posts

    295
  • Joined

  • Last visited

  • Days Won

    1

mattie112 last won the day on July 18 2021

mattie112 had the most liked content!

1 Follower

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

mattie112's Achievements

Contributor

Contributor (5/14)

45

Reputation

  1. And what if you access your IP directly http(s)://your.external.ip ? What do you see? If you get a not found served by NPM at least that part is working. Or do you think the not found is send to you by nextcloud? Check the nextcloud container for example do you see your connection attempt there? (also: it seems kinda strange that you forward it to https://192.168.0.2:444 usually you forward to a http endpoint because that is where you use NPM for; ssl termination).
  2. Open a shell into your NPM docker container and verify the result of your action (the nginx config file). I don't use this feature but perhaps it is already put into a location block?
  3. I would post this in a more generic forum. While it could be NPM (are you running the latest version?) it might also be something else. I would suggest to leave NPM offline to see if that solves your problem
  4. Sorry, I don't use SWAG so yeah I would ask it there.
  5. Your server B is on the same internal network as server A right? Then you don't need to forward any ports. In your example just add a host in NPM for sonarr.domain -> ip.of.server.B:8989
  6. I don't really see why you want them to be in the same docker network/interface. If you just want to be able to reverse proxy them then just expose the ports. For example Server A with NPM IP 1.1.1.1 Sonarrr is on server B with IP 2.2.2.2 (map sonar port to host port 12345) Then just add a host sonarr.domain -> 2.2.2.2:12345 And if you run them on a different IP you can use that IP instead of 2.2.2.2 But: you can't really use the same range as that is (by default) only handled internally. You can go to network settings and set a range (or an IP) to go through a different interface but then your router also needs to know where to forward it to as that range will not be 'known' by your local network. (and yes you can either direct attach or do some IPtables solution but I can't really help you with that) Perhaps it will work by adding a range and setting the gateway IP of your server B but I'm not sure.
  7. What exactly do you want? containers on B to be able to access containers on A (behind the proxy) -> then why not access them through the proxy? NPM on A to be able to forward traffic to containers on B -> then why not expose a port (and/or IP) on B? But with some iptables magic you should be able to "bridge" networks I think but I can't really help you with that config.
  8. Are you sure the port forwarding is correct? A 'start' and 'ends would indicate you are forwarding (allowing) that range to go to your server (or container). I do not see a 443 to 18443 forward for example. You could try NPM on 80/443 (if it has its own IP) to verify this. Or try to access port 18443 remotely then you can be sure.
  9. Is it not listed in the UI? Perhaps manually delete `/etc/letsencrypt/renewal/npm-2.conf`
  10. I don't use CF myself. But in general: The .well-known directory MUST be reachable through unsecured HTTP on port 80. As letsencrypt must be able to verify the challenge even before the encryption has been set-up.
  11. A HTTP 522 error is a CloudFlare connection timeout it seems: https://support.cloudflare.com/hc/en-us/articles/115003011431-Troubleshooting-Cloudflare-5XX-errors#522error https://www.ionos.com/digitalguide/hosting/technical-matters/error-522-explanation-and-solutions/ I don't use CF myself buy I would double-check the settings there.
  12. You can still have multiple servers, however as you just have 1 port 80 available (externally) you can only have 1 NPM running (on that port). Either: run other NPM on other port or Have just 1 NPM and have that also proxy the traffic for the other servers
  13. Or (if you just have 2 Unraid servers) run NPM on 1 and add your hosts for unraid #2 in there so: service hosted on unraid 1 example.com -> localhost:1234 service hosted on unraid 2 otherexample.com -> ip.of.other.unraid:2345
  14. So it seems like certbot is already running (or stuck) and cannot start a 2nd time. I would try to restart your container and see what happens then.