Z490 (Vision G) Fan Sensors


10 posts in this topic Last Reply

Recommended Posts

To get the fan sensors working (with system temp plugin) on the Vision G (and possibly other boards),

sensors-detect

Answer Yes to everything.  With luck you'll see in the middle of all this, 

Trying family `ITE'...                                      Yes
Found unknown chip with ID 0x8688

Add to your go file (/config/go on the flash drive).  This forces the 8688 to be recognized as an 8628

modprobe it87 force_id=0x8628

Reboot.  You should have fan speeds showing once you detect the sensors in System Temp.  If you don't, then try adding the following to the append line in syslinux.cfg

acpi_enforce_resources=lax

 

  • Like 1
  • Thanks 1
Link to post

sadly that doesnt seem to work for my H470 motherboard.

 

is there any ways to check what is going wrong and maybe try something else?

This is in my go file now


#!/bin/bash
# Start the Management Utility
/usr/local/sbin/emhttp &
modprobe it87 force_id=0x8628
modprobe i915
chmod 777 /dev/dri/*
 

And this is my syslinux file.

include /syslinux/syslinux.cfg
append acpi_enforce_resources=lax

 

System temp is still only detecting coretemp as the driver.

Link to post
1 minute ago, Pixel5 said:

And this is my syslinux file.

include /syslinux/syslinux.cfg
append acpi_enforce_resources=lax

Post the file.  Based upon what you've typed, it's wrong unless you really abbreviated things.

Link to post
1 minute ago, Squid said:

Post the file.  Based upon what you've typed, it's wrong unless you really abbreviated things.

syslinux.cfg

this is the file i only added the one line the other was in there like that.

The file is taken from thee flash drive /EFI/boot/ folder but i just found theres another one in another folder i guess you mean this one here?

 

default menu.c32
menu title Lime Technology, Inc.
prompt 0
timeout 50
label Unraid OS
  menu default
  kernel /bzimage
  append initrd=/bzroot i915.alpha_support=1
label Unraid OS GUI Mode
  kernel /bzimage
  append initrd=/bzroot,/bzroot-gui
label Unraid OS Safe Mode (no plugins, no GUI)
  kernel /bzimage
  append initrd=/bzroot unraidsafemode
label Unraid OS GUI Safe Mode (no plugins)
  kernel /bzimage
  append initrd=/bzroot,/bzroot-gui unraidsafemode
label Memtest86+
  kernel /memtest
 

Link to post
1 hour ago, Squid said:

Post the file.  Based upon what you've typed, it's wrong unless you really abbreviated things.

i have added it to the correct file now and im getting an error message on boot 

modprobe: ERROR : could not insert "it87" device or ressource busy

 

Unraid boots fine but still nothing detected.

 

Edit: 

also found somewhere else where someone had the problem they added ignore_resource_conflict=1 to the line but that also doesnt change anything for me sadly.

Edited by Pixel5
Link to post

@Pixel5

 

Install Config Editor through Apps.

 

Open file /boot/syslinux/syslinux.cfg

 

search for:

label Unraid OS
  menu default
  kernel /bzimage
  append initrd=/bzroot i915.alpha_support=1

 

change it:

label Unraid OS
  menu default
  kernel /bzimage
  append initrd=/bzroot i915.alpha_support=1 acpi_enforce_resources=lax

Open File /boot/config/go

 

Add as a new line

modprobe it87 force_id=0x8628

Reboot.

Link to post

@mgutt that did the trick, i already had all this in these files but i had the acpi_enforce_resources=lax in another line which somehow made it not work.

Now i just gotta work out which PWM controller corresponds to which of my fans and im golden.

 

@mgutt guess i was a little too fast to think im done here.

i used pwmcontrol to find out which pwm output controls which fan and now i know PWM1 is FAN1 which is my CPU can and PWM2 is FAN2 which are all my case fans connected to a splitter.

Now the problem is the fan speed plugin does a good job controlling the case fans but even when i disable control for PWM 1 it keeps the CPU fan pegged at 100% regardless of any temperatures.

 

I was configured PWM1 with pwmconfig and as long as i have the terminal open and run fancontrol there everything is fine but when i close the window the CPU fan is pegged at 100% again.

Is there any way to keep fan control running by itself?

 

Edited by Pixel5
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.