[SOLVED] After 10 years I got my first red X (ball) - need assistance on SMART etc


7 posts in this topic Last Reply

Recommended Posts

Hi there community,

 

I've had my server since 2011, pro user. It's been working great ever since. I have had nearly zero problems since the beginning, and my latest reboot is 318 days ago.

 

I ran into some issues with me being greedy and thought I could run too many VM's and Dockers. I simply ran out of memory. And some of my VM's simply went down. When I tried to rectify the problem I got som write errors on of the discs. And eventually it got disabled.

 

Now. Was the problem caused because of my greed or is the disc a goner?

 

Please advise if you have the time and knowledge.

 

PS. I have a lady friend coming over this weekend and I promised her we'd watch some movies... so I hope you understand that I need this taken care of asap.

 

Thanks in advance fellow unraid user.

 

WDC_WD40EFRX-68WT0N0_WD-WCC4E6ZPE8H2-20210217-2013 disk13 (sdt) - DISK_DSBL.txt syslog.txt

Edited by coupas
Can be closed
Link to post
25 minutes ago, ijuarez said:

Minority report....... you should watch that.

 

 

 

red ball means unraid thinks the disc failed.   I would remove it use another pc and verify that the disc is good.

 

Yes, I understand that Unraid thinks that. I was hoping the disc might be ok, and that someone could interpret SMART and/or syslog to tell me if they can see that the disc has a chance of glorius return. Or scrap.

 

But thanks for the reply! Still undecided on the movie.

Link to post

I am not the most experienced user, although i also have a 2011 vintage server.  Looking at your disk smart report, the only potential issue I see is the raw read error rate.  your reallocated sector count and pending sector count are fine.  It may well be ok.  

 

But your problem is that unraid has red-balled it.  Your easiest solution is to replace that drive and allow the array to rebuilt it.  After that you can attempt to preclear this drive and see if it will work in your array.  Personally i would preclear it to make sure it is working and then retire it to a windows box where i am not concerned about a drive failure.  It isnt that old, but old enough that it's pretty likely got a good life ahead of it.

 

Maybe others would suggest another path.  

Link to post

Your major concern areas seem fine, but you do have an uptime of roughly 4.5 years, which while still in the expected lifetime of a NAS drive like a Red, does mean that where there is an issue I would consider replacement a lot more than I would with a younger drive (I am about to replace 4 Reds myself, all close to 6 years uptime, as they're starting to throw too many random read errors and two have red exed out in the past six months).

 

Honestly though? Looking at that SMART report I'd say just do the rebuild process and see if you have further problems with it. And maybe swap out the SATA cable if it's an internal drive; it may not be necessary but it's pretty cheap, and old cables can cause a ton of read errors.

 

(also you can watch movies just using the emulated drive, but you should have time to rebuild it before the weekend)

Link to post
  • coupas changed the title to [SOLVED] After 10 years I got my first red X (ball) - need assistance on SMART etc

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.