Jump to content

Share permissions

Recommended Posts

When ever a new file or folder gets added to appdata or my array, when I try to access it via samba share I get this:
I then have to go to tools, run and run "New Permissions" to fix it.

This happens no matter what docker creates the files or folder.  I don't even know where to begin tracking down what is going on.  

Link to comment

For appdata, this is quite normal and expected depending upon the app.  Each app has certain permission requirements that may or may not be compatible with SMB shares and how unraid handles them.  Many containers support PUID / PGID entries which rectify it.  For those that don't, you're usually stuck with manipulating files via the command line.

Link to comment

I dunno if this is related, but I'm having other issues that seem to tie into permissions.  
Plex for instance is throwing this error cause it can't replace the codec files with the new ones.
I have to stop the docker, run new permissions, then start it back up again so it can properly replace the files.

Also, this goes with all my files, not just some.  Literally any new file on my array or appdata.

Edited by FrostyWolf
Link to comment

You shouldn't do New Permissions on appdata or you may break the permissions required by the application.


For files being created in other shares, you need to identify which application is writing them and see if there is a setting within the application that affects permissions. For example, NZBGet and Transmission both have umask settings.

Link to comment

I understand where you are coming from, but my server hasn't had a issue running for a couple of years, and recently it now does this for all files, from 15 different dockers.  I have to run New Permissions twice a week to fix things.  I feel like this is something wrong deeper then a misconfigured docker container.  I've never messed with permissions in any container before.  They are all pretty much stock installs.

If everything is causing it wouldn't the common factor be the account trying to access it, not whats writing the files?  This is in the array, on both cache arrays.  It's all appdata files.  It's everything.  I can not delete/edit files that have been written since the last time I have run New Permissions.  Everything I try to do gives me the "You Require Permission from Unix User\nobody" error.

Is it possible my guest account or whatever account gets used for Samba shares has been corrupted?

Edited by FrostyWolf
Link to comment
10 minutes ago, trurl said:

I don't have these problems with my Transmission downloads.

Maybe I'm not explaining this correctly.

Any file that gets written to any share on the server, by anything, I can not access till I run New Permissions.  After I run New Permissions, I can not access any file written after the last time I have run it.

It does not matter what creates/writes the file.  It happens in all my shares. SWAG updates and gets new conf files? I can't edit them. Deluge/nzbget download a file? I can't touch it.  Sonarr/Radarr move that file to the array and rename it? I still can't touch it there.

All of my shares are public.  My guest account in unraid is showing Read/Write for all of them.


Edited by FrostyWolf
Link to comment
  • 3 weeks later...

I'm still having this issue.  I messed around a bit today and I still can't figure this out...

Die Hard (1988).mkv - When I connected to my server via samba share, I can edit, delete, etc this file
Nobody (2021).mp4 - When I connected to my server via samba share, I get the you need permission error

If I run Fix Permissions, I can then access both.

I'm not linux vet...but don't they have the same permissions? What is fix permissions doing that lets me then access it?

EDIT: After some more digging, the issue seems to be with the directory permissions:

And just to show:image.png.96c5d0b1b4449845297860c79d86d9fe.png
I am not doing anything with permissions with radarr (or any container) and this happens on all files, not just movies.

Umask is off in nzbget, which is where the files came from.

When I run the umask command in terminal in unraid, it is set to 0000 for /mnt/, /mnt/user, and /mnt/user/Movies

I do not understand where and why these permissions are getting set from on new directories.

You can see the same thing is happening in /mnt/user/downloads/image.png.9afd801f7648b8ffde8ee70c9ad22bc6.png

March 30th was the last day I ran fix permissions, everything after that doesn't have write access.

A Band-Aid fix is I can tell radarr/sonarr/etc and go through every single one of my containers that has the option and set them all, but I want to understand why this is suddenly happening for everything.


Edited by FrostyWolf
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...