Jump to content

[Solved] Wireguard - no handshake (only in tunneled access mode)

Recommended Posts


I have been trying to access my unraid externally through Wireguard VPN. 

Remote tunneled access connects and creates a handshake. 

Remote access to server/LAN doesn't do any handshake or data transfers. 


I have a public IP. 

Manual port forwarding on my router. 



But I cannot figure out why I cannot create the tunnel to access the server. 

Would there be a kind soul that would help me with this struggle I have been trying to solve in the past week? 


Link to comment

I was only able to access the tunnel endpoint (the UNRAID server) at 10.253.x.x when using

the "Remote Tunneled Access" mode.  That showed allowed IP as    Nothing else

seemed reachable.


Changing to "Remote Access to LAN" mode I was able to access the server and the local LAN,

but not the internet attached to the local LAN.


-- Tom



Link to comment

Hi guys, 

after some troubleshooting, I found the problem. Rather a misunderstanding. 

I assumed that once both, the client and Unraid, are running and active, there would be a handshake (a notion of being connected). 

It was explained to me that unless I have a request from either side, there is not going to be any communication and thus no handshake. 


VPN is working as it should now. 


Thanks for the tips though. 

  • Like 1
Link to comment
  • ChatNoir changed the title to [Solved] Wireguard - no handshake (only in tunneled access mode)
  • 3 months later...

I seem to be having a similar no handshake problem seen on the client side logs of my Wireguard configuration. The caveat to my issue is that I have a tested method to both have it work, and break the functionality of my Wireguard instance. Meaning I can replicate my issue but I cannot understand why it is occurring.


My server has two networking connections, br0 and br1. br0 being a 10GbE NIC while the br1 is the MB 1Gig connection. The ip scheme is identical apart from the last octect being .14 (br1) and .15 (br0). My Wireguard is setup in a 'Remote access to LAN' setup.


When adding a default route to use br0 (post-array start since Unraid defaults to using br1 as the default route [separate issue currently solved with a boot script]), Wiregaurd can no longer create the handshake with my phone and unraid server. When typing in console 'ip route delete default dev br0' and restarting the VPN connection from my client, it connects and I can sign in to see my Unraid's dashboard, no handshake issues.


Any ideas why this may be occurring? Perhaps this is a bad configuration of networking and Wiregaurd exacerbates my problem? My other dockers and DDNS setups all continue to work as intended, pre 10GbE addition.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...