Error response from daemon: Address already in use: Docker Container Start-Reihenfolge festlegen?


Recommended Posts

Mein Plex Container weigerte sich zu starten:

/usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='Plex-Media-Server' --net='npm' --ip='172.19.0.2' -e TZ="Europe/Berlin" -e HOST_OS="Unraid" -e 'PLEX_CLAIM'='claim-abc' -e 'PLEX_UID'='99' -e 'PLEX_GID'='100' -e 'ADVERTISE_IP'='http://192.168.178.9:32400/' -p '1900:1900/udp' -p '3005:3005/tcp' -p '32400:32400/tcp' -p '32410:32410/udp' -p '32412:32412/udp' -p '32413:32413/udp' -p '32414:32414/udp' -p '32469:32469/tcp' -p '8324:8324/tcp' -v '/mnt/user/Movie/':'/Movie':'ro' -v '/mnt/user/TV/':'/TV':'ro' -v '/mnt/user/Video/Favorite/':'/Video':'ro' -v '/mnt/user/plex':'/optimize':'rw' -v '/mnt/cache/Music':'/Music':'ro' -v '/mnt/cache/appdata/Plex-Media-Server':'/config':'rw' --device='/dev/dri' --no-healthcheck --mount type=tmpfs,destination=/tmp,tmpfs-size=4294967296 --memory=8G 'plexinc/pms-docker:latest'
a75692d692c4412d44633171499c1ba3a60dba6ee14781ede8ea6d43c05f8b79
docker: Error response from daemon: Address already in use.

 

Daraufhin stoppte ich meinen Nginx Proxy Manager (NPM) Container. Dann konnte ich Plex starten und danach auch wieder NPM.

 

"Address already in use" bezieht sich doch auf einen bereits verwendeten Port oder?

 

Wären alle in Bridge, sähe das in Ordnung aus:

1700533526_2021-06-2011_53_00.png.c28793a7627c70951a9c6d2418c77647.png

 

Allerdings läuft NPM in br0 und wird nachträglich mit npm verbunden:

1308393340_2021-06-2011_56_03.thumb.png.edec0682aecc8c3ff5c1f2967beb4a58.png

 

Meine Vermutung war nun, dass einer der NPM Ports von Plex verwendet wird. Das ist aber nicht der Fall. Nur zB 32400 kann ich von NPM aus erreichen:

437472071_2021-06-2011_59_38.png.6bd2e2a49bc3ba04cd8b45fa6f5d7eb2.png

 

Aber dann ist mir eingefallen, dass ich in NPM einen Stream Host auf Port 32400 hinzugefügt habe:

image.png.8f11a66dbe72695305f1aa421b5ef50b.png

 

NPM empfängt also auf 32400 eingehenden Traffic von außen und leitet ihn 1:1 an Plex weiter.

 

Ich hätte es gerne verifiziert, aber der NPM Container kennt kein ifconfig Kommando, daher weiß ich nicht welche 172.19.0.x IP der NPM besitzt:

image.png.6f317690fea4fd18347fde3d73dad57b.png

 

EDIT: Ok, von Plex aus die 172.19.0.1:32400 geladen und Plex selbst antwortet, daher gehe ich davon aus, dass das die IP von NPM ist:

image.png.8a49feff806f3ab74202d50f8198d24d.png

 

Kann ich irgendwie die Autostart-Reihenfolge bei Docker-Containern festlegen?

 

 

Link to comment
32 minutes ago, mgutt said:

Kann ich irgendwie die Autostart-Reihenfolge bei Docker-Containern festlegen?

Jein, du kannst eine Verzögerung des starts einstellen sprich starte container x erst nach n sekunden, die Reihenfolge in der du sie auf der Docker Seite hast sollte übrigens auch ausschlaggebend sein.

 

32 minutes ago, mgutt said:

Ich hätte es gerne verifiziert, aber der NPM Container kennt kein ifconfig Kommando, daher weiß ich nicht welche 172.19.0.x IP der NPM besitzt:

Was ist das für ein baseimage? Kannst dir unter umständen doch ifconfig installieren.

 

 

Ist aber dennoch ein seltsames Problem das ich ao noch nie gesehen hab...

 

EDIT: kann es sein das es was mit dem start parameter zu tuhen hat:

Quote

--ip='172.19.0.2'

sieht zumindest so aus als gibst du den manuell mit.

Link to comment
1 hour ago, ich777 said:

Jein, du kannst eine Verzögerung des starts einstellen sprich starte container x erst nach n sekunden, die Reihenfolge in der du sie auf der Docker Seite hast sollte übrigens auch ausschlaggebend sein.

Wo?

 

Ich habe jetzt erst mal nur per Drag & Drop die Reihenfolge geändert:

image.thumb.png.48782c77933b21c4cacdc7aa9bc0e2f3.png

 

Mal sehen ob das geht...

 

Link to comment
  • 1 month later...

Ich habe diesen Fehler erneut, aber in einem etwas anderen Kontext. Ich habe die IP-Adressen vom Server geändert, dann den Docker Dienst gestartet und festgestellt, das mein NPM Container nicht mehr startet. Nach einigem Herumprobieren stelle ich fest, dass er auf den folgenden IP-Adressen nicht mehr geht:

192.168.178.8 (eth0, Unraid = logisch)

192.168.178.9 (eth1, Unraid = logisch)

192.168.178.10 (durch nichts in Verwendung, unlogisch)

192.168.178.11 (durch nichts in Verwendung, unlogisch)

192.168.178.12 (durch nichts in Verwendung, unlogisch)

 

Erst auf 192.168.178.13 funktioniert der Container.

 

Hier ein Beispiel-Fehler:

623604480_2021-07-2714_33_02.thumb.png.23c233f89d082dfb296c0f858d088f47.png

 

Andere Container verwenden keine festen IP-Adressen, sondern nur Bridge:

image.png.8b290cc8d39ef82c320cd6cffca0f404.png

 

 

Von außen ist auch alles logisch (also 8, 9 und 13 sind erreichbar, Rest nicht):

image.thumb.png.3732069cd6e17175177dd7c333aedda2.png

 

Ich muss dazu sagen, dass ich die 10, 11 und 12 beim Ändern der Netzwerk-Einstellungen und beim Starten des NPM immer wieder mal ausprobiert hatte und auch zeitweise erfolgreich verwenden konnte. Daraus schließe ich also, dass irgendwo diese IPs nun "geblockt" sind. Aber wo und wie bekomme ich sie wieder "frei"?

 

EDIT: Ich habe nun den Autostart bei NPM entfernt. Dann den Docker-Dienst gestoppt. Dann den Docker-Dienst gestartet. Dann NPM bearbeitet und die .10 vergeben. Danach konnte ich den Container starten und habe Autostart auch wieder aktiviert. Ich weiß jetzt nicht ob es daran lag oder ob die IP durch was anderes wieder freigeworden ist?!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.