Jump to content

Time Server


Recommended Posts

  • 8 months later...
On 9/15/2021 at 5:00 PM, JonathanM said:

Unraid has a built in NTP server by default. Just point your devices at Unraid's IP.

Hi @JonathanM can you please specify?

I have a security cam that has the possibility to setup a custm NTP server but it asks me Server adress and port. I tried to change adress to my unraid server local address and let default port (123) but it doesn't work.


Any hint?


Link to comment
8 hours ago, JonathanM said:

Can you verify that the server and camera are on the same subnet with no firewall rules that would restrict traffic? I just verified again and it "just works" for me.

yes Cam has a rule that should be restrict to lan only. But both camera and server are in the same subnet: 192.168.2.xxx

Link to comment
  • 6 months later...
  • 5 months later...
On 5/4/2023 at 12:54 PM, apandey said:

That seems like a layer 2 only switch, so while it will allow VLANs, it won't be able to route through them

What are you using as a router? That's where you need to allow routing between the networks


I'm just using my ISP modem-router. I have no 3rd party router. 

Edited by HHUBS
Link to comment
2 hours ago, HHUBS said:

I'm just using my ISP modem-router. I have no 3rd party router

Do you have access to that routers interface? You have to route between VLANs if the router or switch allows it, else the default behaviour is to keep them separate


Routing across VLANs need one of the following:

1. A layer 3 switch

2. Router with one physical interface per VLAN

3. Router with VLAN trunking enabled


You may be out of luck. Inter-VLAN routing is an advanced topics because VLAN traffic is tagged at layer 2 while routing happens at layer 3. Connecting these two is why you need a device which can see separate vlan interfaces in some way (physical or logical). Your switch does not deal with layer 3 at all, your router may not see VLAN interfaces at all

Link to comment
  • 2 months later...

@JonathanMI'm trying to do the same as Jokerigno--set my network cameras (restricted to LAN only) to use Unraid's NTP server. I tested the command you provided in Windows, but got this result:

C:\Users\[username]>net time \\ /set /yes
Current time at \\ is 7/25/2023 21:33:49

System error 1314 has occurred.

A required privilege is not held by the client.

I don't see settings in either Unraid or the camera for authentication or privileges.




Edit: This is because I wasn't using an elevated command prompt... when I run this with an elevated command prompt, the time is set successfully.


Any ideas why my camera can't set itself from my server? They're both on the same subnet and I'm not aware of firewall rules that would block the connection. The camera already provides video to the server.

Edited by Batman
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...