multiple problems with my server (mostly docker) 9.6.2

Recommended Posts

Hello, unfortunately I am writing because I am having several problems with my unraid server. About a week ago, I was checking the GUI and noted that the cpu was pinned at %100. I waited for a day and checked again. It was still at %100.

I tried rebooting and noticed that the cpu wasnt pinned when the docker service wasnt running. So I concluded there was maybe a problem with a docker. I updated some dockers that needed updating but the problem still persisted. In addition I was now not able to access some of my dockers such as sonarr, radarr, prowlarr. But some of my other dockers like audiobookshelf and mealie worked fine.

Continuing on, I decided to update unraid to 6.11.5 from 6.9.2. Once I updated the OS nothing different happened. I normally use unraid with a static IP but I noticed that somehow unraid was reporting a mac address to my router (unifi) that the mac address was different but it was still using the same IP ( So it seemed that unraid was somehow using two different mac addresses and they were both trying to use So I switched to automatic DHCP un unraid and assigned the origional first mac address that I know is the mac for the adapter as That seemed to work and I'm not having the address problem.

However, I still could not access the dockers that I needed. So I figured I would delete one and try to reinstall it with unraid backup/restore. That didn't work so i resorted to deleting the vdisk. After deleting the vdisk I restarted the server. After a restart i got an error that the docker service couldnt be started. I looked for other solutions and some said they get this error when the vdisk is too full, so increased the size to 100gb (was 50gb). That didnt work either. I deleted the vdisk (btrfs) several times and cycled the server to no avail. I also tried switching to xfs, which didnt work either.

In a final hail mary I rolled the server back to 6.9.2 via the GUI and I am still stuck. I also tried deleting the vdisk and switching to xfs and that didnt work.

So I guess the first issue is figuring out why the docker service wont start. Once I figure that out, I can see what was pinning my CPU if even it is docker.

Here is a link to the diagnostics:

Edited by PrisonMike
Link to comment
  • PrisonMike changed the title to multiple problems with my server (mostly docker) 9.6.2

Your system share has files on the array. Ideally, appdata, domains, system shares should be on fast pool (cache) and set to stay there so Docker/VM performance isn't impacted by slower parity, and so array disks can spin down since these files are always open.


You can worry about that later though.


You have completely filled logspace, so nothing has been logged in a few days.


But what logs you do have is showing problems communicating with cache.


Do you not see Errors in Main - Pool Devices?


Shutdown, check all connections, SATA and power, both ends, including splitters. Reboot will clear logs.




Link to comment
On 2/2/2023 at 8:26 PM, trurl said:
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
# 1  Extended offline    Completed: read failure       00%      8922         830987072




Hello, thanks for the help! Since I have a pool of two cache drives, can I remove the bad one and run the server off of a single cache drive until I can get a new drive?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.