Jump to content

Issues with Windows VM crashing


Go to solution Solved by JackSafari,

Recommended Posts

My Windows 10 VM has recently started crashing after anywhere from 15 minutes to hours after having started up. I remember having to reboot unRAID in safe-mode once to remove a plugin that was causing issues after a restart. The VM is an always-on Windows 11 gaming VM with a GTX 1650 passed through and a dedicated drive mounted for games.

 

I cannot figure out why and before I go on and make a fresh VM, I wanted to ask for someone to look over the config and log.

 

-device '{"driver":"ide-cd","bus":"ide.0","unit":1,"drive":"libvirt-1-format","id":"ide0-0-1"}' \
-netdev tap,fd=37,id=hostnet0 \
-device '{"driver":"virtio-net","netdev":"hostnet0","id":"net0","mac":"52:54:00:1c:5e:6b","bus":"pci.0","addr":"0x2"}' \
-chardev pty,id=charserial0 \
-device '{"driver":"isa-serial","chardev":"charserial0","id":"serial0","index":0}' \
-chardev socket,id=charchannel0,fd=35,server=on,wait=off \
-device '{"driver":"virtserialport","bus":"virtio-serial0.0","nr":1,"chardev":"charchannel0","id":"channel0","name":"org.qemu.guest_agent.0"}' \
-chardev socket,id=chrtpm,path=/run/libvirt/qemu/swtpm/11-SpieleVM-W11-swtpm.sock \
-tpmdev emulator,id=tpm-tpm0,chardev=chrtpm \
-device '{"driver":"tpm-tis","tpmdev":"tpm-tpm0","id":"tpm0"}' \
-device '{"driver":"usb-tablet","id":"input0","bus":"usb.0","port":"1"}' \
-audiodev '{"id":"audio1","driver":"none"}' \
-device '{"driver":"vfio-pci","host":"0000:01:00.0","id":"hostdev0","bus":"pci.0","addr":"0x6","romfile":"/mnt/user/isos/vbios/Palit.GTX1650.4096.190221.rom"}' \
-device '{"driver":"vfio-pci","host":"0000:01:00.1","id":"hostdev1","bus":"pci.0","addr":"0x8"}' \
-device '{"driver":"vfio-pci","host":"0000:01:00.2","id":"hostdev2","bus":"pci.0","addr":"0x9"}' \
-device '{"driver":"vfio-pci","host":"0000:01:00.3","id":"hostdev3","bus":"pci.0","addr":"0xa"}' \
-sandbox on,obsolete=deny,elevateprivileges=deny,spawn=deny,resourcecontrol=deny \
-msg timestamp=on
char device redirected to /dev/pts/0 (label charserial0)
2023-05-11 15:53:23.091+0000: shutting down, reason=failed
2023-05-11 18:18:44.601+0000: Starting external device: TPM Emulator
/usr/bin/swtpm socket --ctrl type=unixio,path=/run/libvirt/qemu/swtpm/12-SpieleVM-W11-swtpm.sock,mode=0600 --tpmstate dir=/var/lib/libvirt/swtpm/534aba57-a06b-a252-9c61-1200865b94ce/tpm2,mode=0600 --log file=/var/log/swtpm/libvirt/qemu/SpieleVM-W11-swtpm.log --terminate --tpm2
2023-05-11 18:18:44.630+0000: starting up libvirt version: 8.7.0, qemu version: 7.1.0, kernel: 5.19.17-Unraid, hostname: Tower
LC_ALL=C \
PATH=/bin:/sbin:/usr/bin:/usr/sbin \
HOME=/var/lib/libvirt/qemu/domain-12-SpieleVM-W11 \
XDG_DATA_HOME=/var/lib/libvirt/qemu/domain-12-SpieleVM-W11/.local/share \
XDG_CACHE_HOME=/var/lib/libvirt/qemu/domain-12-SpieleVM-W11/.cache \
XDG_CONFIG_HOME=/var/lib/libvirt/qemu/domain-12-SpieleVM-W11/.config \
/usr/local/sbin/qemu \
-name guest=SpieleVM-W11,debug-threads=on \
-S \
-object '{"qom-type":"secret","id":"masterKey0","format":"raw","file":"/var/lib/libvirt/qemu/domain-12-SpieleVM-W11/master-key.aes"}' \
-blockdev '{"driver":"file","filename":"/usr/share/qemu/ovmf-x64/OVMF_CODE-pure-efi-tpm.fd","node-name":"libvirt-pflash0-storage","auto-read-only":true,"discard":"unmap"}' \
-blockdev '{"node-name":"libvirt-pflash0-format","read-only":true,"driver":"raw","file":"libvirt-pflash0-storage"}' \
-blockdev '{"driver":"file","filename":"/etc/libvirt/qemu/nvram/534aba57-a06b-a252-9c61-1200865b94ce_VARS-pure-efi-tpm.fd","node-name":"libvirt-pflash1-storage","auto-read-only":true,"discard":"unmap"}' \
-blockdev '{"node-name":"libvirt-pflash1-format","read-only":false,"driver":"raw","file":"libvirt-pflash1-storage"}' \
-machine pc-i440fx-6.2,usb=off,dump-guest-core=off,mem-merge=off,memory-backend=pc.ram,pflash0=libvirt-pflash0-format,pflash1=libvirt-pflash1-format \
-accel kvm \
-cpu host,migratable=on,hv-time=on,hv-relaxed=on,hv-vapic=on,hv-spinlocks=0x1fff,hv-vendor-id=none,host-cache-info=on,l3-cache=off \
-m 12288 \
-object '{"qom-type":"memory-backend-ram","id":"pc.ram","size":12884901888}' \
-overcommit mem-lock=off \
-smp 8,sockets=1,dies=1,cores=4,threads=2 \
-uuid 534aba57-a06b-a252-9c61-1200865b94ce \
-display none \
-no-user-config \
-nodefaults \
-chardev socket,id=charmonitor,fd=36,server=on,wait=off \
-mon chardev=charmonitor,id=monitor,mode=control \
-rtc base=localtime \
-no-hpet \
-no-shutdown \
-boot strict=on \
-device '{"driver":"ich9-usb-ehci1","id":"usb","bus":"pci.0","addr":"0x7.0x7"}' \
-device '{"driver":"ich9-usb-uhci1","masterbus":"usb.0","firstport":0,"bus":"pci.0","multifunction":true,"addr":"0x7"}' \
-device '{"driver":"ich9-usb-uhci2","masterbus":"usb.0","firstport":2,"bus":"pci.0","addr":"0x7.0x1"}' \
-device '{"driver":"ich9-usb-uhci3","masterbus":"usb.0","firstport":4,"bus":"pci.0","addr":"0x7.0x2"}' \
-device '{"driver":"virtio-serial-pci","id":"virtio-serial0","bus":"pci.0","addr":"0x3"}' \
-blockdev '{"driver":"file","filename":"/mnt/user/domains/SpieleVM-W11/vdisk1.img","node-name":"libvirt-4-storage","cache":{"direct":false,"no-flush":false},"auto-read-only":true,"discard":"unmap"}' \
-blockdev '{"node-name":"libvirt-4-format","read-only":false,"cache":{"direct":false,"no-flush":false},"driver":"raw","file":"libvirt-4-storage"}' \
-device '{"driver":"virtio-blk-pci","bus":"pci.0","addr":"0x4","drive":"libvirt-4-format","id":"virtio-disk2","bootindex":1,"write-cache":"on"}' \
-blockdev '{"driver":"file","filename":"/mnt/disks/Spiele/SpieleVM22/vdisk2.img","node-name":"libvirt-3-storage","cache":{"direct":false,"no-flush":false},"auto-read-only":true,"discard":"unmap"}' \
-blockdev '{"node-name":"libvirt-3-format","read-only":false,"cache":{"direct":false,"no-flush":false},"driver":"raw","file":"libvirt-3-storage"}' \
-device '{"driver":"virtio-blk-pci","bus":"pci.0","addr":"0x5","drive":"libvirt-3-format","id":"virtio-disk3","write-cache":"on"}' \
-blockdev '{"driver":"file","filename":"/mnt/user/isos/Win11_German_x64v1.iso","node-name":"libvirt-2-storage","auto-read-only":true,"discard":"unmap"}' \
-blockdev '{"node-name":"libvirt-2-format","read-only":true,"driver":"raw","file":"libvirt-2-storage"}' \
-device '{"driver":"ide-cd","bus":"ide.0","unit":0,"drive":"libvirt-2-format","id":"ide0-0-0","bootindex":2}' \
-blockdev '{"driver":"file","filename":"/mnt/user/isos/virtio-win-0.1.221-1.iso","node-name":"libvirt-1-storage","auto-read-only":true,"discard":"unmap"}' \
-blockdev '{"node-name":"libvirt-1-format","read-only":true,"driver":"raw","file":"libvirt-1-storage"}' \
-device '{"driver":"ide-cd","bus":"ide.0","unit":1,"drive":"libvirt-1-format","id":"ide0-0-1"}' \
-netdev tap,fd=37,id=hostnet0 \
-device '{"driver":"virtio-net","netdev":"hostnet0","id":"net0","mac":"52:54:00:1c:5e:6b","bus":"pci.0","addr":"0x2"}' \
-chardev pty,id=charserial0 \
-device '{"driver":"isa-serial","chardev":"charserial0","id":"serial0","index":0}' \
-chardev socket,id=charchannel0,fd=35,server=on,wait=off \
-device '{"driver":"virtserialport","bus":"virtio-serial0.0","nr":1,"chardev":"charchannel0","id":"channel0","name":"org.qemu.guest_agent.0"}' \
-chardev socket,id=chrtpm,path=/run/libvirt/qemu/swtpm/12-SpieleVM-W11-swtpm.sock \
-tpmdev emulator,id=tpm-tpm0,chardev=chrtpm \
-device '{"driver":"tpm-tis","tpmdev":"tpm-tpm0","id":"tpm0"}' \
-device '{"driver":"usb-tablet","id":"input0","bus":"usb.0","port":"1"}' \
-audiodev '{"id":"audio1","driver":"none"}' \
-device '{"driver":"vfio-pci","host":"0000:01:00.0","id":"hostdev0","bus":"pci.0","addr":"0x6","romfile":"/mnt/user/isos/vbios/Palit.GTX1650.4096.190221.rom"}' \
-device '{"driver":"vfio-pci","host":"0000:01:00.1","id":"hostdev1","bus":"pci.0","addr":"0x8"}' \
-device '{"driver":"vfio-pci","host":"0000:01:00.2","id":"hostdev2","bus":"pci.0","addr":"0x9"}' \
-device '{"driver":"vfio-pci","host":"0000:01:00.3","id":"hostdev3","bus":"pci.0","addr":"0xa"}' \
-sandbox on,obsolete=deny,elevateprivileges=deny,spawn=deny,resourcecontrol=deny \
-msg timestamp=on
char device redirected to /dev/pts/3 (label charserial0)
2023-05-11 18:28:18.822+0000: shutting down, reason=crashed

 

<?xml version='1.0' encoding='UTF-8'?>
<domain type='kvm'>
  <name>SpieleVM-W11</name>
  <uuid>534aba57-a06b-a252-9c61-1200865b94ce</uuid>
  <metadata>
    <vmtemplate xmlns="unraid" name="Windows 11" icon="windows11.png" os="windowstpm"/>
  </metadata>
  <memory unit='KiB'>12582912</memory>
  <currentMemory unit='KiB'>8388608</currentMemory>
  <memoryBacking>
    <nosharepages/>
  </memoryBacking>
  <vcpu placement='static'>8</vcpu>
  <cputune>
    <vcpupin vcpu='0' cpuset='2'/>
    <vcpupin vcpu='1' cpuset='8'/>
    <vcpupin vcpu='2' cpuset='3'/>
    <vcpupin vcpu='3' cpuset='9'/>
    <vcpupin vcpu='4' cpuset='4'/>
    <vcpupin vcpu='5' cpuset='10'/>
    <vcpupin vcpu='6' cpuset='5'/>
    <vcpupin vcpu='7' cpuset='11'/>
  </cputune>
  <os>
    <type arch='x86_64' machine='pc-i440fx-6.2'>hvm</type>
    <loader readonly='yes' type='pflash'>/usr/share/qemu/ovmf-x64/OVMF_CODE-pure-efi-tpm.fd</loader>
    <nvram>/etc/libvirt/qemu/nvram/534aba57-a06b-a252-9c61-1200865b94ce_VARS-pure-efi-tpm.fd</nvram>
  </os>
  <features>
    <acpi/>
    <apic/>
    <hyperv mode='custom'>
      <relaxed state='on'/>
      <vapic state='on'/>
      <spinlocks state='on' retries='8191'/>
      <vendor_id state='on' value='none'/>
    </hyperv>
  </features>
  <cpu mode='host-passthrough' check='none' migratable='on'>
    <topology sockets='1' dies='1' cores='4' threads='2'/>
    <cache mode='passthrough'/>
  </cpu>
  <clock offset='localtime'>
    <timer name='hypervclock' present='yes'/>
    <timer name='hpet' present='no'/>
  </clock>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <devices>
    <emulator>/usr/local/sbin/qemu</emulator>
    <disk type='file' device='disk'>
      <driver name='qemu' type='raw' cache='writeback'/>
      <source file='/mnt/user/domains/SpieleVM-W11/vdisk1.img'/>
      <target dev='hdc' bus='virtio'/>
      <boot order='1'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
    </disk>
    <disk type='file' device='disk'>
      <driver name='qemu' type='raw' cache='writeback'/>
      <source file='/mnt/disks/Spiele/SpieleVM22/vdisk2.img'/>
      <target dev='hdd' bus='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
    </disk>
    <disk type='file' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <source file='/mnt/user/isos/Win11_German_x64v1.iso'/>
      <target dev='hda' bus='ide'/>
      <readonly/>
      <boot order='2'/>
      <address type='drive' controller='0' bus='0' target='0' unit='0'/>
    </disk>
    <disk type='file' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <source file='/mnt/user/isos/virtio-win-0.1.221-1.iso'/>
      <target dev='hdb' bus='ide'/>
      <readonly/>
      <address type='drive' controller='0' bus='0' target='0' unit='1'/>
    </disk>
    <controller type='pci' index='0' model='pci-root'/>
    <controller type='ide' index='0'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
    </controller>
    <controller type='virtio-serial' index='0'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
    </controller>
    <controller type='usb' index='0' model='ich9-ehci1'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x7'/>
    </controller>
    <controller type='usb' index='0' model='ich9-uhci1'>
      <master startport='0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x0' multifunction='on'/>
    </controller>
    <controller type='usb' index='0' model='ich9-uhci2'>
      <master startport='2'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x1'/>
    </controller>
    <controller type='usb' index='0' model='ich9-uhci3'>
      <master startport='4'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x2'/>
    </controller>
    <interface type='bridge'>
      <mac address='52:54:00:1c:5e:6b'/>
      <source bridge='br0'/>
      <model type='virtio-net'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </interface>
    <serial type='pty'>
      <target type='isa-serial' port='0'>
        <model name='isa-serial'/>
      </target>
    </serial>
    <console type='pty'>
      <target type='serial' port='0'/>
    </console>
    <channel type='unix'>
      <target type='virtio' name='org.qemu.guest_agent.0'/>
      <address type='virtio-serial' controller='0' bus='0' port='1'/>
    </channel>
    <input type='tablet' bus='usb'>
      <address type='usb' bus='0' port='1'/>
    </input>
    <input type='mouse' bus='ps2'/>
    <input type='keyboard' bus='ps2'/>
    <tpm model='tpm-tis'>
      <backend type='emulator' version='2.0' persistent_state='yes'/>
    </tpm>
    <audio id='1' type='none'/>
    <hostdev mode='subsystem' type='pci' managed='yes'>
      <driver name='vfio'/>
      <source>
        <address domain='0x0000' bus='0x01' slot='0x00' function='0x0'/>
      </source>
      <rom file='/mnt/user/isos/vbios/Palit.GTX1650.4096.190221.rom'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x0'/>
    </hostdev>
    <hostdev mode='subsystem' type='pci' managed='yes'>
      <driver name='vfio'/>
      <source>
        <address domain='0x0000' bus='0x01' slot='0x00' function='0x1'/>
      </source>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x08' function='0x0'/>
    </hostdev>
    <hostdev mode='subsystem' type='pci' managed='yes'>
      <driver name='vfio'/>
      <source>
        <address domain='0x0000' bus='0x01' slot='0x00' function='0x2'/>
      </source>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x09' function='0x0'/>
    </hostdev>
    <hostdev mode='subsystem' type='pci' managed='yes'>
      <driver name='vfio'/>
      <source>
        <address domain='0x0000' bus='0x01' slot='0x00' function='0x3'/>
      </source>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x0a' function='0x0'/>
    </hostdev>
    <memballoon model='none'/>
  </devices>
</domain>

 

Link to comment
  • 2 weeks later...

I am have the exact same issue. My Windows 10 (version 22H2, build 19045.3086) system ends exactly as the log posted above. The problem recently started for reasons unknown. I also have GPU pass through.  The VM has been very stable for over a year. This is the first time I have experienced a fatal VM problem on unraid.

 

Observations: Unraid "pauses" the vm, not stops it. "Resume" does not resume the vm. "Force Stop" kills the vm, but starting the vm causes the vm to be highly unstable and quickly unraid pauses the vm within 1-2 minutes. The only way I am able to clear the problem temporarily is to restart unraid.  After start, I can run the VM again and it will be stable for a limited period of time; sometimes many hours. The problem with the VM is more likely to occur during video streaming, such as watching YT videos. 

 

This is where the problem appears to be happening. Unraid's Windows 10 vm log:

 

-device '{"driver":"vfio-pci","host":"0000:2d:00.0","id":"hostdev0","bus":"pci.0","addr":"0x8","romfile":"/mnt/user/isos/vbios/GTX1060.rom"}' \
-device '{"driver":"vfio-pci","host":"0000:2d:00.1","id":"hostdev1","bus":"pci.0","addr":"0x9"}' \
-device '{"driver":"usb-host","hostdevice":"/dev/bus/usb/001/005","id":"hostdev2","bus":"usb.0","port":"3"}' \
-device '{"driver":"usb-host","hostdevice":"/dev/bus/usb/001/006","id":"hostdev3","bus":"usb.0","port":"4"}' \
-device '{"driver":"usb-host","hostdevice":"/dev/bus/usb/003/002","id":"hostdev4","bus":"usb.0","port":"5"}' \
-device '{"driver":"usb-host","hostdevice":"/dev/bus/usb/001/004","id":"hostdev5","bus":"usb.0","port":"6"}' \
-sandbox on,obsolete=deny,elevateprivileges=deny,spawn=deny,resourcecontrol=deny \
-msg timestamp=on
char device redirected to /dev/pts/0 (label charserial0)
2023-06-19T08:10:19.827059Z qemu-system-x86_64: libusb_set_interface_alt_setting: -5 [NOT_FOUND]

 

.... This is how the log ends every time the unraid forces the WIndows 10 to pause.

 

 

 

tower-diagnostics-20230619-0137.zip tower-syslog-20230619-0825.zip WindowsLog.txt

Edited by JackSafari
Link to comment
7 hours ago, JackSafari said:

I am have the exact same issue. My Windows 10 (version 22H2, build 19045.3086) system ends exactly as the log posted above. The problem recently started for reasons unknown. I also have GPU pass through.  The VM has been very stable for over a year. This is the first time I have experienced a fatal VM problem on unraid.

 

Observations: Unraid "pauses" the vm, not stops it. "Resume" does not resume the vm. "Force Stop" kills the vm, but starting the vm causes the vm to be highly unstable and quickly unraid pauses the vm within 1-2 minutes. The only way I am able to clear the problem temporarily is to restart unraid.  After start, I can run the VM again and it will be stable for a limited period of time; sometimes many hours. The problem with the VM is more likely to occur during video streaming, such as watching YT videos. 

 

This is where the problem appears to be happening. Unraid's Windows 10 vm log:

 

-device '{"driver":"vfio-pci","host":"0000:2d:00.0","id":"hostdev0","bus":"pci.0","addr":"0x8","romfile":"/mnt/user/isos/vbios/GTX1060.rom"}' \
-device '{"driver":"vfio-pci","host":"0000:2d:00.1","id":"hostdev1","bus":"pci.0","addr":"0x9"}' \
-device '{"driver":"usb-host","hostdevice":"/dev/bus/usb/001/005","id":"hostdev2","bus":"usb.0","port":"3"}' \
-device '{"driver":"usb-host","hostdevice":"/dev/bus/usb/001/006","id":"hostdev3","bus":"usb.0","port":"4"}' \
-device '{"driver":"usb-host","hostdevice":"/dev/bus/usb/003/002","id":"hostdev4","bus":"usb.0","port":"5"}' \
-device '{"driver":"usb-host","hostdevice":"/dev/bus/usb/001/004","id":"hostdev5","bus":"usb.0","port":"6"}' \
-sandbox on,obsolete=deny,elevateprivileges=deny,spawn=deny,resourcecontrol=deny \
-msg timestamp=on
char device redirected to /dev/pts/0 (label charserial0)
2023-06-19T08:10:19.827059Z qemu-system-x86_64: libusb_set_interface_alt_setting: -5 [NOT_FOUND]

 

.... This is how the log ends every time the unraid forces the WIndows 10 to pause.

 

 

 

tower-diagnostics-20230619-0137.zip 137.29 kB · 0 downloads tower-syslog-20230619-0825.zip 29.73 kB · 0 downloads WindowsLog.txt 5.83 kB · 0 downloads

Have you enabled virtiofs before do you need it? It is known to cause vms to lockup. You may need to remove virtio mappings also.

 

Change this

-<memoryBacking>

<source type="memfd"/>

<access mode="shared"/>

</memoryBacking>

 

to

  <memoryBacking>
    <nosharepages/>
  </memoryBacking>

Link to comment
4 hours ago, SimonF said:

Have you enabled virtiofs before do you need it? It is known to cause vms to lockup. You may need to remove virtio mappings also.

 

Change this

-<memoryBacking>

<source type="memfd"/>

<access mode="shared"/>

</memoryBacking>

 

to

  <memoryBacking>
    <nosharepages/>
  </memoryBacking>

 

Yes, it is likely that is the cause the problem because it was the only change to the VM's config that I have made recently.

 

I needed to do an extra step to get unraid to accept the <memoryBacking> change back to nosharepages, I needed to remove:

 

    <filesystem type='mount' accessmode='passthrough'>
....
    </filesystem> 

 

Otherwise, unraid rejects the change as a configuration error.

 

is it possible to config virtiofs to work with a windows 10\11 VM that has various other hardware passthroughs? (ie GPU).

 

 

Edited by JackSafari
Link to comment
4 minutes ago, JackSafari said:

 

Yes, it is likely that is the cause the problem because it was the only change to the VM's config that I have made recently.

 

I needed to do an extra step to get unraid to accept the <memoryBacking> change back to nosharepages, I needed to remove:

 

    <filesystem type='mount' accessmode='passthrough'>
....
    </filesystem> 

 

Otherwise, unraid rejected the change as configuration error.

 

It is possible to config virtiofs to work with a windows 10\11 VM that has various other hardware passthroughs? (ie GPU).

 

 

Yes the memory backing is requierd for virtiofs. I think it wil be fixed when we update qemu > 7.1

 

You can delete the virtio mappings in xml or gui. but memory backing has to be removed via xml

Link to comment
22 hours ago, SimonF said:

Yes the memory backing is requierd for virtiofs. I think it wil be fixed when we update qemu > 7.1

 

You can delete the virtio mappings in xml or gui. but memory backing has to be removed via xml

 

Unfortunately making the suggested changes did not resolve the problem. Overnight while sitting idle the vm locked up again while it was not actively being used; the desktop clock froze at 8:06am. At that point the VM had been running OK for over 12 hours and idle for about 6 hours.

 

Any further suggestion to try?

Edited by JackSafari
Link to comment
2 hours ago, JackSafari said:

 

Unfortunately making the suggested changes did not resolve the problem. Overnight while sitting idle the vm locked up again while it was not actively being used; the desktop clock froze at 8:06am. At that point the VM had been running OK for over 12 hours and idle for about 6 hours.

 

Any further suggestion to try?

Can you post new diagnostics

Link to comment
  • Solution

Here is most recent diagnostic.

tower-diagnostics-20230620-1402.zip


Edit-1: In effort to solve the problem, today I reinstalled the Virtio drivers and switched from i440fx-7.1 to Q35-7.1.

 

Edit-2: It has been a couple of hours, the Windows 10 vm remains stable. I have done some moderate stress testing that has previously triggered the lockup (screen is frozen, vm is 'paused' by unraid and cannot be unpaused). I am going to let the Windows 10 vm run for at least 24 hours without any further config changes or reboots.  

Edited by JackSafari
Link to comment
  • 2 weeks later...
  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...