Docker containers fail to update

Go to solution Solved by Squid,

Recommended Posts

I have a dozen or so Docker containers installed from the Apps section. Updates are frequently published and the "Action Centre" always shows up which lets me easily update them. However, every time I do so, Unraid doesn't seem to delete the old container before trying to create the new one, so I get a message like this:



Error response from daemon: Conflict. The container name "/grafana" is already in use by container ....



Strangely it seems to _stop_ the old container, but not _delete_ it, which I think is why creating the new one fails. This happens with all my containers.


Has anyone seen this before? I've tried deleting my docker.img & recreating all my containers but it's still happening.

Link to comment

Awesome!! This is exactly what I wanted to hear. It did seem like my containers have been updating, I just wasn’t sure how that was possible with the commands & output I was seeing (I use Docker a lot professionally, but I’m newer to Unraid).


Anyway, glad it’s a known thing and I’ll keep an eye out for the next release. Thanks!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.