Jump to content
sparklyballs

Sparklyballs' Beta Repo

165 posts in this topic Last Reply

Recommended Posts

I wonder if we should drop the pip install of comictagger itself in favour of a git source checkout of the new fork since its had some fixes in the last year.

 

Once decided on this I will try to replicate the issues in a vm as well.

Share this post


Link to post

I wonder if we should drop the pip install of comictagger itself in favour of a git source checkout of the new fork since its had some fixes in the last year.

 

Once decided on this I will try to replicate the issues in a vm as well.

 

the git source has it's own issues, it throws up  errors about unrar, the fix is to pass the location of libunrar.so as a variable.

 

only problem is, that file doesn't exist, with either the version that gets installed when you run the comictagger installation or unrar proper.

Share this post


Link to post

this app is fighting me, lol.

 

i've solved the rar issue, now the damn thing won't start because it can't find pyqt4 despite it being installed.

Share this post


Link to post

this app is fighting me, lol.

 

i've solved the rar issue, now the damn thing won't start because it can't find pyqt4 despite it being installed.

 

arg

 

i run the slightly older version in debian and it was a breeze to install but i havent touched it in ages. I wonder if this is the problem, dependencies have move don whilst the app hasnt as much.

 

I will try a throw away VM with the git source to test some things out ASAP and see if i can assist.

 

Sorry I honestly thought this would be a no brainer. On a plus point your already #1 in google for docker + comictagger for me at least so some fame kudos there.

Share this post


Link to post

this app is fighting me, lol.

 

i've solved the rar issue, now the damn thing won't start because it can't find pyqt4 despite it being installed.

 

arg

 

i run the slightly older version in debian and it was a breeze to install but i havent touched it in ages. I wonder if this is the problem, dependencies have move don whilst the app hasnt as much.

 

I will try a throw away VM with the git source to test some things out ASAP and see if i can assist.

 

Sorry I honestly thought this would be a no brainer. On a plus point your already #1 in google for docker + comictagger for me at least so some fame kudos there.

 

 

 

 

i now have something i have never seen before, it builds on my docker server, the same dockerfile doesn't build on dockerhub , some versioning issue with a dependency

Share this post


Link to post

Interesting. At the very least this is a good learning case (lemons vs. lemonade)

Share this post


Link to post

dockerhub is fackered basically.

 

taking nearly an hour to go from pending to building,

 

and bloody dependencies , libtiff5-dev is failing because the version of libtiff-5 is too new on dockerhub, falling back to libtiff4-dev makes no bloody difference as that calls libtiff5-dev as a dependency and right back to the same problem.

 

trying to pin the version of libtiff-5 and dockerhub tells me that version is not available.

Share this post


Link to post

but the thing builds on my docker server VM with the same dockerfile.

 

i've never seen that before.

Share this post


Link to post

it's totally gone screwy again with the dates and build times.

 

last build was earlier today, docker showing last updated time

 

1 day 2 hours ago

 

 

last time that happened, nobody could update dockers.

Share this post


Link to post

Well at least that might explain a lot of the weirdness. Lets put a pin in it until we can work again without these oddball issues.

Share this post


Link to post

Well at least that might explain a lot of the weirdness. Lets put a pin in it until we can work again without these oddball issues.

 

check the latest version..

Share this post


Link to post

Well at least that might explain a lot of the weirdness. Lets put a pin in it until we can work again without these oddball issues.

 

check the latest version..

 

And we have a winner !

 

Punishing it with a large list as we speak to see if it can survive hundreds in one go.

 

Update: it just works. Feeding it multi-hundred lists to convert to cbz and then tag and the only slow down is CVine API. Nice work a geniunly useful container.

Share this post


Link to post

Hey Sparklyballs,

 

I am trying to get the graylog docker working and i cant get it to start.  the errors i see in the log are

 

2015-06-09_21:45:41.93350 INFO [indexerSetupService] Checking Elasticsearch HTTP API at http://127.0.0.1:9200/
2015-06-09_21:45:41.94152 ERROR [indexerSetupService] Could not connect to Elasticsearch.
2015-06-09_21:45:41.94155 java.net.ConnectException: Connection refused
2015-06-09_21:45:41.94156 at java.net.PlainSocketImpl.socketConnect(Native Method)
2015-06-09_21:45:41.94157 at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:345)
2015-06-09_21:45:41.94157 at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
2015-06-09_21:45:41.94158 at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
2015-06-09_21:45:41.94159 at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
2015-06-09_21:45:41.94160 at java.net.Socket.connect(Socket.java:589)
2015-06-09_21:45:41.94162 at com.squareup.okhttp.internal.Platform.connectSocket(Platform.java:100)
2015-06-09_21:45:41.94163 at com.squareup.okhttp.internal.http.SocketConnector.connectRawSocket(SocketConnector.java:160)
2015-06-09_21:45:41.94163 at com.squareup.okhttp.internal.http.SocketConnector.connectCleartext(SocketConnector.java:67)
2015-06-09_21:45:41.94164 at com.squareup.okhttp.Connection.connect(Connection.java:152)
2015-06-09_21:45:41.94165 at com.squareup.okhttp.Connection.connectAndSetOwner(Connection.java:185)
2015-06-09_21:45:41.94165 at com.squareup.okhttp.OkHttpClient$1.connectAndSetOwner(OkHttpClient.java:128)
2015-06-09_21:45:41.94166 at com.squareup.okhttp.internal.http.HttpEngine.nextConnection(HttpEngine.java:341)
2015-06-09_21:45:41.94168 at com.squareup.okhttp.internal.http.HttpEngine.connect(HttpEngine.java:330)
2015-06-09_21:45:41.94169 at com.squareup.okhttp.internal.http.HttpEngine.sendRequest(HttpEngine.java:248)
2015-06-09_21:45:41.94169 at com.squareup.okhttp.Call.getResponse(Call.java:273)
2015-06-09_21:45:41.94170 at com.squareup.okhttp.Call$ApplicationInterceptorChain.proceed(Call.java:230)
2015-06-09_21:45:41.94171 at com.squareup.okhttp.Call.getResponseWithInterceptorChain(Call.java:201)
2015-06-09_21:45:41.94172 at com.squareup.okhttp.Call.execute(Call.java:81)
2015-06-09_21:45:41.94173 at org.graylog2.initializers.IndexerSetupService.startUp(IndexerSetupService.java:158)
2015-06-09_21:45:41.94173 at com.google.common.util.concurrent.AbstractIdleService$2$1.run(AbstractIdleService.java:54)
2015-06-09_21:45:41.94174 at com.google.common.util.concurrent.Callables$3.run(Callables.java:95)
2015-06-09_21:45:41.94175 at java.lang.Thread.run(Thread.java:745)
2015-06-09_21:45:41.94237 ERROR [uI]
2015-06-09_21:45:41.94239
2015-06-09_21:45:41.94240 ################################################################################
2015-06-09_21:45:41.94241
2015-06-09_21:45:41.94242 ERROR: Could not successfully connect to Elasticsearch, if you use multicast check that it is working in your network and that Elasticsearch is running properly and is reachable. Also check that the cluster.name setting is correct.
2015-06-09_21:45:41.94243
2015-06-09_21:45:41.94244 Need help?
2015-06-09_21:45:41.94245
2015-06-09_21:45:41.94246 * Official documentation: http://docs.graylog.org/
2015-06-09_21:45:41.94246 * Community support: https://www.graylog.org/community-support/
2015-06-09_21:45:41.94247 * Commercial support: https://www.graylog.com/support/
2015-06-09_21:45:41.94248
2015-06-09_21:45:41.94249 But we also got some specific help pages that might help you in this case:
2015-06-09_21:45:41.94250
2015-06-09_21:45:41.94250 * http://docs.graylog.org/en/1.0/pages/configuring_es.html
2015-06-09_21:45:41.94251
2015-06-09_21:45:41.94252 Terminating. 
2015-06-09_21:45:41.94253
2015-06-09_21:45:41.94253 ################################################################################
2015-06-09_21:45:41.94254
2015-06-09_21:45:41.94555 ERROR [serviceManager] Service IndexerSetupService [FAILED] has failed in the STARTING state.

 

 

Any thoughts what it could be

Share this post


Link to post

Hey Sparklyballs,

 

I am trying to get the graylog docker working and i cant get it to start.  the errors i see in the log are

 

2015-06-09_21:45:41.93350 INFO [indexerSetupService] Checking Elasticsearch HTTP API at http://127.0.0.1:9200/
2015-06-09_21:45:41.94152 ERROR [indexerSetupService] Could not connect to Elasticsearch.
2015-06-09_21:45:41.94155 java.net.ConnectException: Connection refused
2015-06-09_21:45:41.94156 at java.net.PlainSocketImpl.socketConnect(Native Method)
2015-06-09_21:45:41.94157 at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:345)
2015-06-09_21:45:41.94157 at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
2015-06-09_21:45:41.94158 at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
2015-06-09_21:45:41.94159 at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
2015-06-09_21:45:41.94160 at java.net.Socket.connect(Socket.java:589)
2015-06-09_21:45:41.94162 at com.squareup.okhttp.internal.Platform.connectSocket(Platform.java:100)
2015-06-09_21:45:41.94163 at com.squareup.okhttp.internal.http.SocketConnector.connectRawSocket(SocketConnector.java:160)
2015-06-09_21:45:41.94163 at com.squareup.okhttp.internal.http.SocketConnector.connectCleartext(SocketConnector.java:67)
2015-06-09_21:45:41.94164 at com.squareup.okhttp.Connection.connect(Connection.java:152)
2015-06-09_21:45:41.94165 at com.squareup.okhttp.Connection.connectAndSetOwner(Connection.java:185)
2015-06-09_21:45:41.94165 at com.squareup.okhttp.OkHttpClient$1.connectAndSetOwner(OkHttpClient.java:128)
2015-06-09_21:45:41.94166 at com.squareup.okhttp.internal.http.HttpEngine.nextConnection(HttpEngine.java:341)
2015-06-09_21:45:41.94168 at com.squareup.okhttp.internal.http.HttpEngine.connect(HttpEngine.java:330)
2015-06-09_21:45:41.94169 at com.squareup.okhttp.internal.http.HttpEngine.sendRequest(HttpEngine.java:248)
2015-06-09_21:45:41.94169 at com.squareup.okhttp.Call.getResponse(Call.java:273)
2015-06-09_21:45:41.94170 at com.squareup.okhttp.Call$ApplicationInterceptorChain.proceed(Call.java:230)
2015-06-09_21:45:41.94171 at com.squareup.okhttp.Call.getResponseWithInterceptorChain(Call.java:201)
2015-06-09_21:45:41.94172 at com.squareup.okhttp.Call.execute(Call.java:81)
2015-06-09_21:45:41.94173 at org.graylog2.initializers.IndexerSetupService.startUp(IndexerSetupService.java:158)
2015-06-09_21:45:41.94173 at com.google.common.util.concurrent.AbstractIdleService$2$1.run(AbstractIdleService.java:54)
2015-06-09_21:45:41.94174 at com.google.common.util.concurrent.Callables$3.run(Callables.java:95)
2015-06-09_21:45:41.94175 at java.lang.Thread.run(Thread.java:745)
2015-06-09_21:45:41.94237 ERROR [uI]
2015-06-09_21:45:41.94239
2015-06-09_21:45:41.94240 ################################################################################
2015-06-09_21:45:41.94241
2015-06-09_21:45:41.94242 ERROR: Could not successfully connect to Elasticsearch, if you use multicast check that it is working in your network and that Elasticsearch is running properly and is reachable. Also check that the cluster.name setting is correct.
2015-06-09_21:45:41.94243
2015-06-09_21:45:41.94244 Need help?
2015-06-09_21:45:41.94245
2015-06-09_21:45:41.94246 * Official documentation: http://docs.graylog.org/
2015-06-09_21:45:41.94246 * Community support: https://www.graylog.org/community-support/
2015-06-09_21:45:41.94247 * Commercial support: https://www.graylog.com/support/
2015-06-09_21:45:41.94248
2015-06-09_21:45:41.94249 But we also got some specific help pages that might help you in this case:
2015-06-09_21:45:41.94250
2015-06-09_21:45:41.94250 * http://docs.graylog.org/en/1.0/pages/configuring_es.html
2015-06-09_21:45:41.94251
2015-06-09_21:45:41.94252 Terminating. 
2015-06-09_21:45:41.94253
2015-06-09_21:45:41.94253 ################################################################################
2015-06-09_21:45:41.94254
2015-06-09_21:45:41.94555 ERROR [serviceManager] Service IndexerSetupService [FAILED] has failed in the STARTING state.

 

 

Any thoughts what it could be

 

it works fine here, but there seems to be some issue in general to dockers about using user shares over disk shares.

 

i map to /mnt/cache/appdata rather than /mnt/user/appdata for my config files etc....

Share this post


Link to post

i'll look later to see if graylog have changed their setup again.

 

since this docker is just a copy of theirs, i am going to remove it from my dockerhub and just use the template to link to their docker image instead.

 

 

Share this post


Link to post

Hey Sparklyballs,

 

I am trying to get the graylog docker working and i cant get it to start.  the errors i see in the log are

 

2015-06-09_21:45:41.93350 INFO [indexerSetupService] Checking Elasticsearch HTTP API at http://127.0.0.1:9200/
2015-06-09_21:45:41.94152 ERROR [indexerSetupService] Could not connect to Elasticsearch.
2015-06-09_21:45:41.94155 java.net.ConnectException: Connection refused
2015-06-09_21:45:41.94156 at java.net.PlainSocketImpl.socketConnect(Native Method)
2015-06-09_21:45:41.94157 at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:345)
2015-06-09_21:45:41.94157 at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
2015-06-09_21:45:41.94158 at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
2015-06-09_21:45:41.94159 at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
2015-06-09_21:45:41.94160 at java.net.Socket.connect(Socket.java:589)
2015-06-09_21:45:41.94162 at com.squareup.okhttp.internal.Platform.connectSocket(Platform.java:100)
2015-06-09_21:45:41.94163 at com.squareup.okhttp.internal.http.SocketConnector.connectRawSocket(SocketConnector.java:160)
2015-06-09_21:45:41.94163 at com.squareup.okhttp.internal.http.SocketConnector.connectCleartext(SocketConnector.java:67)
2015-06-09_21:45:41.94164 at com.squareup.okhttp.Connection.connect(Connection.java:152)
2015-06-09_21:45:41.94165 at com.squareup.okhttp.Connection.connectAndSetOwner(Connection.java:185)
2015-06-09_21:45:41.94165 at com.squareup.okhttp.OkHttpClient$1.connectAndSetOwner(OkHttpClient.java:128)
2015-06-09_21:45:41.94166 at com.squareup.okhttp.internal.http.HttpEngine.nextConnection(HttpEngine.java:341)
2015-06-09_21:45:41.94168 at com.squareup.okhttp.internal.http.HttpEngine.connect(HttpEngine.java:330)
2015-06-09_21:45:41.94169 at com.squareup.okhttp.internal.http.HttpEngine.sendRequest(HttpEngine.java:248)
2015-06-09_21:45:41.94169 at com.squareup.okhttp.Call.getResponse(Call.java:273)
2015-06-09_21:45:41.94170 at com.squareup.okhttp.Call$ApplicationInterceptorChain.proceed(Call.java:230)
2015-06-09_21:45:41.94171 at com.squareup.okhttp.Call.getResponseWithInterceptorChain(Call.java:201)
2015-06-09_21:45:41.94172 at com.squareup.okhttp.Call.execute(Call.java:81)
2015-06-09_21:45:41.94173 at org.graylog2.initializers.IndexerSetupService.startUp(IndexerSetupService.java:158)
2015-06-09_21:45:41.94173 at com.google.common.util.concurrent.AbstractIdleService$2$1.run(AbstractIdleService.java:54)
2015-06-09_21:45:41.94174 at com.google.common.util.concurrent.Callables$3.run(Callables.java:95)
2015-06-09_21:45:41.94175 at java.lang.Thread.run(Thread.java:745)
2015-06-09_21:45:41.94237 ERROR [uI]
2015-06-09_21:45:41.94239
2015-06-09_21:45:41.94240 ################################################################################
2015-06-09_21:45:41.94241
2015-06-09_21:45:41.94242 ERROR: Could not successfully connect to Elasticsearch, if you use multicast check that it is working in your network and that Elasticsearch is running properly and is reachable. Also check that the cluster.name setting is correct.
2015-06-09_21:45:41.94243
2015-06-09_21:45:41.94244 Need help?
2015-06-09_21:45:41.94245
2015-06-09_21:45:41.94246 * Official documentation: http://docs.graylog.org/
2015-06-09_21:45:41.94246 * Community support: https://www.graylog.org/community-support/
2015-06-09_21:45:41.94247 * Commercial support: https://www.graylog.com/support/
2015-06-09_21:45:41.94248
2015-06-09_21:45:41.94249 But we also got some specific help pages that might help you in this case:
2015-06-09_21:45:41.94250
2015-06-09_21:45:41.94250 * http://docs.graylog.org/en/1.0/pages/configuring_es.html
2015-06-09_21:45:41.94251
2015-06-09_21:45:41.94252 Terminating. 
2015-06-09_21:45:41.94253
2015-06-09_21:45:41.94253 ################################################################################
2015-06-09_21:45:41.94254
2015-06-09_21:45:41.94555 ERROR [serviceManager] Service IndexerSetupService [FAILED] has failed in the STARTING state.

 

 

Any thoughts what it could be

 

 

it's all working here. just did a fresh from start install and no problems.

Share this post


Link to post

Hey Sparklyballs,

 

I am trying to get the graylog docker working and i cant get it to start.  the errors i see in the log are

 

2015-06-09_21:45:41.93350 INFO [indexerSetupService] Checking Elasticsearch HTTP API at http://127.0.0.1:9200/
2015-06-09_21:45:41.94152 ERROR [indexerSetupService] Could not connect to Elasticsearch.
2015-06-09_21:45:41.94155 java.net.ConnectException: Connection refused
2015-06-09_21:45:41.94156 at java.net.PlainSocketImpl.socketConnect(Native Method)
2015-06-09_21:45:41.94157 at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:345)
2015-06-09_21:45:41.94157 at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
2015-06-09_21:45:41.94158 at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
2015-06-09_21:45:41.94159 at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
2015-06-09_21:45:41.94160 at java.net.Socket.connect(Socket.java:589)
2015-06-09_21:45:41.94162 at com.squareup.okhttp.internal.Platform.connectSocket(Platform.java:100)
2015-06-09_21:45:41.94163 at com.squareup.okhttp.internal.http.SocketConnector.connectRawSocket(SocketConnector.java:160)
2015-06-09_21:45:41.94163 at com.squareup.okhttp.internal.http.SocketConnector.connectCleartext(SocketConnector.java:67)
2015-06-09_21:45:41.94164 at com.squareup.okhttp.Connection.connect(Connection.java:152)
2015-06-09_21:45:41.94165 at com.squareup.okhttp.Connection.connectAndSetOwner(Connection.java:185)
2015-06-09_21:45:41.94165 at com.squareup.okhttp.OkHttpClient$1.connectAndSetOwner(OkHttpClient.java:128)
2015-06-09_21:45:41.94166 at com.squareup.okhttp.internal.http.HttpEngine.nextConnection(HttpEngine.java:341)
2015-06-09_21:45:41.94168 at com.squareup.okhttp.internal.http.HttpEngine.connect(HttpEngine.java:330)
2015-06-09_21:45:41.94169 at com.squareup.okhttp.internal.http.HttpEngine.sendRequest(HttpEngine.java:248)
2015-06-09_21:45:41.94169 at com.squareup.okhttp.Call.getResponse(Call.java:273)
2015-06-09_21:45:41.94170 at com.squareup.okhttp.Call$ApplicationInterceptorChain.proceed(Call.java:230)
2015-06-09_21:45:41.94171 at com.squareup.okhttp.Call.getResponseWithInterceptorChain(Call.java:201)
2015-06-09_21:45:41.94172 at com.squareup.okhttp.Call.execute(Call.java:81)
2015-06-09_21:45:41.94173 at org.graylog2.initializers.IndexerSetupService.startUp(IndexerSetupService.java:158)
2015-06-09_21:45:41.94173 at com.google.common.util.concurrent.AbstractIdleService$2$1.run(AbstractIdleService.java:54)
2015-06-09_21:45:41.94174 at com.google.common.util.concurrent.Callables$3.run(Callables.java:95)
2015-06-09_21:45:41.94175 at java.lang.Thread.run(Thread.java:745)
2015-06-09_21:45:41.94237 ERROR [uI]
2015-06-09_21:45:41.94239
2015-06-09_21:45:41.94240 ################################################################################
2015-06-09_21:45:41.94241
2015-06-09_21:45:41.94242 ERROR: Could not successfully connect to Elasticsearch, if you use multicast check that it is working in your network and that Elasticsearch is running properly and is reachable. Also check that the cluster.name setting is correct.
2015-06-09_21:45:41.94243
2015-06-09_21:45:41.94244 Need help?
2015-06-09_21:45:41.94245
2015-06-09_21:45:41.94246 * Official documentation: http://docs.graylog.org/
2015-06-09_21:45:41.94246 * Community support: https://www.graylog.org/community-support/
2015-06-09_21:45:41.94247 * Commercial support: https://www.graylog.com/support/
2015-06-09_21:45:41.94248
2015-06-09_21:45:41.94249 But we also got some specific help pages that might help you in this case:
2015-06-09_21:45:41.94250
2015-06-09_21:45:41.94250 * http://docs.graylog.org/en/1.0/pages/configuring_es.html
2015-06-09_21:45:41.94251
2015-06-09_21:45:41.94252 Terminating. 
2015-06-09_21:45:41.94253
2015-06-09_21:45:41.94253 ################################################################################
2015-06-09_21:45:41.94254
2015-06-09_21:45:41.94555 ERROR [serviceManager] Service IndexerSetupService [FAILED] has failed in the STARTING state.

 

 

Any thoughts what it could be

 

 

it's all working here. just did a fresh from start install and no problems.

 

Let me try with a fresh setup and see what i get

Share this post


Link to post

Nope,  i still get the same issue,  can not connect to Elasticsearch.  Not sure what is different

Share this post


Link to post

Nope,  i still get the same issue,  can not connect to Elasticsearch.  Not sure what is different

 

no idea, the docker itself gets a small .deb from graylog and that installs and runs a chef recipe to call everything else and install it.

 

 

Share this post


Link to post

Instead of rebuilding the graylog container everytime they update, i have changed the link in my template to pull their image from dockerhub.

 

this was a very early docker of mine and was essentially just a copy of their git repo anyways... so now it's coming straight from them.

Share this post


Link to post

Instead of rebuilding the graylog container everytime they update, i have changed the link in my template to pull their image from dockerhub.

 

this was a very early docker of mine and was essentially just a copy of their git repo anyways... so now it's coming straight from them.

 

Never did get that working, might try in the next couple of days, expect some PMs  ;D

Share this post


Link to post

I installed the Maria-WebSQL Docker and I have to say it is very nice.  The WebSQL is a nice thing to have to manage databases.  I can create a backup database very easily.  One suggestion is to map the /var/www/mywebsql/backups to a mnt/cache/appdata/.../backups folder so the backups generated by MyWebSQL don't get lost when refreshing or updating the Docker.

 

A nice addition to Maria-WebSQL would be a daily/weekly/monthly database backup to the same directory with date and time stamps in the file name.

Share this post


Link to post

whats the username/password for mariadb web interface?  :o

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.