Jump to content

4.7 TO 6.0 Upgrade- Permission Problem


reggie14

Recommended Posts

I just upgraded my unRAID server from 4.7 to 6.0.  I followed the 4.7-5.0 and 5.0-6.0 instructions carefully.  I remembered to run the permission utility after the 5.0 upgrade, and I reformatted my drive to do the 6.0 upgrade.  I did, however, copy back over my config and config/share folders.

 

It seemed to go fine, but I'm having problems with permissions.  Some of my shares are not accessible on my machines.  And oddly, it varies by machine.  I have two Windows machines with the same username/password accessing my unRAID server.  I can get to one set of folders from my workstation, and a different set from my media server.

 

For example, I can get to \Movies and \Television from my workstation, but not \flash.  I can get to \flash from my server, but not \Movies or \Television.

 

It's been a while since I set up my old 4.7 box, so I'm not completely sure what I did to get things working before.  While I don't remember doing this, I did find the anonymous.sh script on my flash drive, so I assume I ran it at one point to get anonymous shares working.

 

As of right now, (almost) all of the shares are marked security level "Public."  I tried making one of them "secure" and giving my unRAID username read/write access (the same username as my Windows login, except all lowercase), but it didn't change anything.

 

My goals are to make sure \Television and \Movies (and probably \flash) are accessible from every machine on my network, including media streamers where I'm not going to want to enter a password.  Sage and Plex (and associated clients) need to be able to access these folders.

 

I have another set of shares, like \Backups, that I would like password protected- at least for writes, and probably for read.

 

I have a final set of shares, like \Pictures, that I would like to give everything on my network read access to, but preferably not write.

 

Suggestions?  It seems like it should be a natural use of public vs. secure vs. private shares, but nothing I do seems to change the behavior at all.  And I have no idea what I need to do to make \flash accessible from my workstation (and am rather confused why its somehow accessible from my server using the same username).

Link to comment

I should clarify a couple things:

 

1) When I say I can't access a share, what I mean is I get a message in Windows saying the share is unavailable.  I never get a message saying my password is wrong.

 

2) If I go to a third machine that I literally just set up, things seem to work as I would expect.  I can get read access to any share that isn't private, and if I try to access a private share I get asked for a different username/password.

 

So, something odd is going on between my primary computers where I'm using a Windows account that matches the username/password for my unRAID server.

Link to comment

Indeed.  Thanks for your help.  Restarting the machines was enough to fix things.

 

Out of curiosity, what's the different between marking a share "public" and running the script to allow anonymous access?  I'm trying to remember why I used that script years ago.

 

Thanks again.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...