[Support] Linuxserver.io - The-Lounge


Recommended Posts

linuxserver_medium.png

 

Application Name: The-Lounge

Application Site: https://thelounge.github.io/

Docker Hub: https://hub.docker.com/r/linuxserver/thelounge/

Github: https://github.com/linuxserver/docker-thelounge

 

Please post any questions/issues relating to this docker you have in this thread.

 

If you are not using Unraid (and you should be!) then please do not post here, instead head to linuxserver.io to see how to get support.

Edited by linuxserver.io
Link to comment
  • 2 months later...

Is there an easy way to password protect either shout or the lounge web page so the random people from india that are spamming me after buying a URL arent using it to connect through my server and wreak havoc?

 

The short version is to not expose your server to the internet.

Link to comment

True, but defeats the purpose of the web irc.  I have not tested this yet in shout, maybe it will work...  but in thelounge I have not gotten it to work.

 

 

docker exec -it thelounge node /app/node_modules/thelounge/index.js --home /config add <user>

 

Enter a password when prompted, refresh your browser.

 

You should now be prompted for a password on the webinterface.

Link to comment
  • 1 year later...

Hola.

 

Can someone give me a hand in getting this to work? I've installed the docker but I want to make a single user, connect it to an IRC channel and then basically make the user idle forever.

 

I've gained access to the docker by running:

docker exec -it the-lounge bash

It seems I only  have vim/vi as a text editor. I tried opening the "users" file but it says that it's not a regular file.

 

What's next?

 

Never-mind. Got it sorted with:

 

docker exec -it thelounge node /app/node_modules/thelounge/index.js --home /config add <user>

I thought that above command was for something else. So running both these commands allows you to connect to the docker and quickly add a user and give that user a password.

Edited by NewKrewLinux
Link to comment

Is it me, using the docker wrong, or do I just misunderstand the features of the lounge?

 

I installed the docker, opened the WebInterface and connected to three IRC Servers. 

Now I can chat and idle. Everything is fine.

When I close the browser-window and then reopen the window, everything is lost. The client is empty and I have to reconnect to the servers.

Isn't that the intention of this tool? To stay connected even with a closed browser window and then reopen the browser from any machine to keep going where you left off?

 

Edited by AcidReign
Link to comment
On 9/18/2018 at 3:46 PM, AcidReign said:

Is it me, using the docker wrong, or do I just misunderstand the features of the lounge?

 

I installed the docker, opened the WebInterface and connected to three IRC Servers. 

Now I can chat and idle. Everything is fine.

When I close the browser-window and then reopen the window, everything is lost. The client is empty and I have to reconnect to the servers.

Isn't that the intention of this tool? To stay connected even with a closed browser window and then reopen the browser from any machine to keep going where you left off?

 

I don't think so, I think this is intended as an IRC client.  What you're looking for is an IRC bouncer like ZNC.  You may (I don't know as I use Quassel) be able to connect this to your ZNC bouncer.

  • Like 1
Link to comment
On 9/17/2018 at 3:44 PM, FireFtw said:

Trying to set up something like NewKrewLinux did, however the command 


docker exec -it thelounge node /app/node_modules/thelounge/index.js --home /config add <user>

No longer works and just throws an error

 

err.PNG

 

Any ideas?

https://github.com/linuxserver/docker-thelounge#setting-up-the-application

 

Tried the process in the readme?

 

And if you're not using Unraid then please use our Discord channel for support. 

Edited by CHBMB
Link to comment
  • 3 months later...

I've been trying to figure this out for two days... Can I get Linuxserver.io - The-Lounge to connect through a proxy server.  Most notably, I have binhex - DelugeVPN running along with his Privoxy.  How do I configure The-Lounge to send traffic through my proxy server?  I'm pulling what's left of my hair out!!!

 

Thanks to anyone who can help.

 

Kind regards,

craigr

Link to comment
  • 2 months later...

I know that this is not supposed to act as a bouncer, but is there a way to save server configurations between sessions? Each time I connect to the web interface I have to re-add any servers I want to use.

The client I am trying to move away from (Hexchat) preserves server configurations between uses.

 

Do I have something configured incorrectly?

Edited by Ruthalas
small wording change for clarity
Link to comment
4 minutes ago, Ruthalas said:

I know that this is not supposed to act as a bouncer, but is there a way to save server configurations between sessions? Each time I connect to the web interface I have to re-add any servers I want to use.

The client I am trying to move away from (Hexchat) preserves server configurations between uses.

 

Do I have something configured incorrectly? 

Have you tried looking at the config file as described in the readme?

 

https://github.com/linuxserver/docker-thelounge#application-setup

 

and more info here

 

https://thelounge.chat/docs/configuration

Edited by CHBMB
Link to comment

Thanks for the reply @CHBMB.

 

Looking through the config file I see options to configure users, and an option to set the default content for the network configuration wizard, but not a way to set up a list of servers to connect to when the client is accessed.

 

Is there another portion of the documentation that addresses this, or did I miss a section in the config file?

Link to comment
18 minutes ago, Ruthalas said:

Thanks for the reply @CHBMB.

 

Looking through the config file I see options to configure users, and an option to set the default content for the network configuration wizard, but not a way to set up a list of servers to connect to when the client is accessed.

 

Is there another portion of the documentation that addresses this, or did I miss a section in the config file?

https://thelounge.chat/docs/configuration#default-network

Link to comment

@CHBMB
 

"Specifies default network information that will be used as placeholder values in the Connect window."


If I have read this correctly, it would allow one server to be set as the autofill, but if I frequent 2-3 servers, I'd still have to manually type all the connection information for the second and third server each time I opened the webpage.

 

Is that the best I can do?

Link to comment
1 hour ago, Ruthalas said:

@CHBMB
 

"Specifies default network information that will be used as placeholder values in the Connect window."


If I have read this correctly, it would allow one server to be set as the autofill, but if I frequent 2-3 servers, I'd still have to manually type all the connection information for the second and third server each time I opened the webpage.

 

Is that the best I can do?

 

Read here and make sure you add a user.   Then configure that user via the webui, when you next login as that user, your networks are preserved

Link to comment
  • 1 month later...

Everytime I try to add a user I get this error:

[WARN] Config file owner does not match the user you are currently running The Lounge as.
[WARN] To avoid issues, you should execute The Lounge commands under the same user.

 

How do I fix this? I click on the Docker select Console, type "thelounge add username" and I get that error.

 

Edited by nxtiak
Link to comment
18 hours ago, nxtiak said:

Everytime I try to add a user I get this error:

[WARN] Config file owner does not match the user you are currently running The Lounge as.
[WARN] To avoid issues, you should execute The Lounge commands under the same user.

 

How do I fix this? I click on the Docker select Console, type "thelounge add username" and I get that error.

 

So you are using the console link in the menu for the container on the unraid docker page?

Then you are root inside the container and not the abc user, that runs thelounge.

Instead go to the unraid console and type docker exec -it -u abc thelounge bash

Replace thelounge with the actual name for the container. After this you can type in the add user command. When finished, type exit.

Link to comment
55 minutes ago, saarg said:

So you are using the console link in the menu for the container on the unraid docker page?

Then you are root inside the container and not the abc user, that runs thelounge.

Instead go to the unraid console and type docker exec -it -u abc thelounge bash

Replace thelounge with the actual name for the container. After this you can type in the add user command. When finished, type exit.

Awesome, thank you that worked!

Link to comment
  • 1 month later...

I'm trying to access the web UI through a reverse proxy, but when I go to https://mydomain.com/thelounge it just responds with a page that says "Cannot GET /thelounge/".

 

I'm using update 15.05.19, the latest image as of posting this, and I made no changes to the default template except set the network to my public Docker network (where containers can resolve each other's hostnames).

 

I made no changes to /config/config.js except set "reverseProxy: true,".

 

I use jselage/nginxproxymanager container, here is my location block:

  location /thelounge {
    proxy_set_header Host $host;
    proxy_set_header X-Forwarded-Scheme $scheme;
    proxy_set_header X-Forwarded-Proto  $scheme;
    proxy_set_header X-Forwarded-For    $remote_addr;
    proxy_pass       http://thelounge:9000;
    auth_request /auth-0;
  }

It's a bit different from the block in https://thelounge.chat/docs/guides/reverse-proxies#nginx but I also tried adding the suggested lines and they made no difference.

 

I also tried using this block from the linuxserver config even though I don't use the linuxserver/letsencrypt container, same thing.

 

# thelounge does not require a base url setting

location /thelounge {
    return 301 $scheme://$host/thelounge/;
}
location ^~ /thelounge/ {
    # enable the next two lines for http auth
    #auth_basic "Restricted";
    #auth_basic_user_file /config/nginx/.htpasswd;

    # enable the next two lines for ldap auth, also customize and enable ldap.conf in the default conf
    #auth_request /auth;
    #error_page 401 =200 /login;

    include /config/nginx/proxy.conf;
    resolver 127.0.0.11 valid=30s;
    set $upstream_thelounge thelounge;
    rewrite /thelounge(.*) $1 break;
    proxy_pass http://$upstream_thelounge:9000;
}

Any other ideas?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.