AMD GPU Reset Bug?


131 posts in this topic Last Reply

Recommended Posts

  • Replies 130
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Thanks to ich777 and his Kernel Helper container I was able to build an Unraid kernel with the navi reset patch super easily! I have an RX 5600XT and everything seems to be working. The container also

You can now switch to the new 'feature/audio-reset' of the vendor-reset. Just use @ich777's docker to compile your custom build as you need it.   I can boot between Windows 10 20H2, Ubuntu 2

The vendor reset does not work with Navi cards right now. The sound card gets a Code 10 error after 2nd Boot of the vm. The quoted issue also shows that Vega cards don't work atm, too.  

Posted Images

21 hours ago, mSedek said:

NO, I havent sold my 5700XT yet. my issues are none related to the cards or macOS, my 5700XT works perfect in Catalina and BIG SUR, the problem is that at the moment BIG SUR has no support for JAVA 8 and IF i sell my 5700XT to get a 6800 (which is highly available here in my country) just to have a RESET BUG free experience, then I lose my ability to develop in macOS as 6000 series ONLY works in BIG SUR.. either way im screwed lol..

 

 

Is there already driver support for big navi 6000 series in MacOS? Thought there are still no 6800, 6800XT, 6900 XT drivers available for MacOS?

Link to post
28 minutes ago, derpuma said:

Is there already driver support for big navi 6000 series in MacOS? Thought there are still no 6800, 6800XT, 6900 XT drivers available for MacOS?

No, there isn't.

Java 8 is working for me.

Edited by ghost82
Link to post
  • 1 month later...

Has anyone had any luck getting the vendor-reset patch to work with a 5500 XT? I have a brand new Asus ROG Strix Radeon RX 5500 XT 8GB card that is failing to reset on a patched kernel. I've hijacked someone's GitHub issue here but just wondering if anyone has managed to get it going.

 

I'm on 6.9.1, kernel built using ich777's kernel builder that has the vendor-reset patch applied, works perfectly with my RX 580. Luckily it doesn't crash the whole system like it does on the stock kernel, but I do need to restart my entire server between troubleshooting attempts because while I can start VMs etc. the card is still getting stuck. 

Link to post
  • 1 month later...
On 1/16/2020 at 6:03 PM, Skitals said:

What board are you using? The navi reset patch stability seems completely dependent on your hardware. It works flawlessly for many. Other hardware, not so much. If you have a x570 board I would give the reset patch a shot, it works great on this platform.

 

@Skitals so far you are one of the few I find who have got it working. Would you be able to help the rest of us out somehow? Iv'e tried MANY permutations over last week

 

Mainboard X570 Taichi - what have U got and BIOS version (might be AGESA related)

BIOS - not UEFI (but tried that too) - AER, IOMMU, ACS settings

Stubbings - tried NOT stubbing GPUs (as per SIO latest video) and stubbing, stub 2 USB controllers and related AMD device, plus NVME for passthrough

GPUs - Primary RX5700 with Rom (tried appx 20 diff roms now), Secondary Nvidia GT740 (not used but will be once RX5700 works)

VM settings - Wind10, Q35-5.1, OVMF, HyperV on (tried off), RX5700 GPU&Sound& Rom entered

Passed devices: AMD Starship/Matisse Reserved SPP | Non-Essential Instrumentation (0a:00.0)
 AMD Matisse USB 3.0 Host Controller | USB controller (0a:00.1),  AMD Matisse USB 3.0 Host Controller | USB controller (0a:00.3)
 Phison Electronics E12 NVMe Controller | Non-Volatile memory controller (0d:00.0)

 

Tried with sound portion and without, with one or two USB controllers, with/without the AMD device.

 

I am thinking would be nice to know what you stubbed, what you have in config (ACS patch(, BIOS settings, VM XML?

 

I even after some googling switched the PCIE from Gen4 to Gen2 as someone somewhere claimed that fixed for them. And raised issue at Gnif's Github too.

 

Stumped. NEED help! PLEASE!

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.