X399 and Threadripper


94 posts in this topic Last Reply

Recommended Posts

Anyone had any luck with a threadripper build yet? I am thinking about jumping over to team red and curious what types of issues folks are having. I saw you need to run a release candidate right now. Just curious what other problems are out there?

 

 

Link to post
  • 3 weeks later...
  • Replies 93
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

@Jcloud I'm not sure if you are still struggling with this, but maybe this might be helpful?   Follow up on this mainly to keep my notes all together for anyone else who runs across this iss

<SOLVED>  vfio-pci 0000:0a:00.0: BAR 3: can't reserve [mem 0xe0000000-0xe1ffffff 64bit pref]  vfio-pci 0000:42:00.0: BAR 3: can't reserve [mem 0xc0000000-0xc1ffffff 64bit pref]  

For anyone lurking here. If you're on, 6.4.0 and want to give "Ugly Patch" a shot I've compiled it, see this post  My system has only been running it for about eight hours now.   Edited

Posted Images

  • 5 weeks later...

There are several threads on Ryzen / TR builds. Long and short of it is that there were several significant issues, one related to C states, and one related to NPT, that have been overcome, but there continue to be challenged that are Linux related. Do some searching on Ryzen and you will early find the large thread on the topic. Limetech user also recently posted some links to external threads, as well as a protective provocative tweet he sent to the AMD president about an apparent lack off interest in supporting Linux.

Link to post
4 hours ago, skunky99 said:

I guess investing in that platform is a bad idea for this purpose is a bad idea. Thanks for responding!

 

Since the major issues are resolved, I am a little more optimistic that the smaller issues will be worked out over time. In the long run it might be a great choice. But if turnkey is your goal, and you want to use some of unRAIDs more power features like VMs and passthrough now, it may not be for you.

Link to post

I've had a 1950x, mobo, RAM, and water cooling equipment sitting in the carts on Amazon, NewEgg, and EKWB all day today, hovering over the respective buy buttons and reading through the forum posts to see if all the issues have been resolved yet.

 

It looks like the latest Linux kernel fixes more Ryzen stuff but I think it's one newer than what's even in the current release candidate. It's also a little unclear if all of the Ryzen issues occur with Threadripper or if it has its own separate set of issues.

 

I was excited for ECC support as well, but it turns out that nobody makes "fast" ECC RAM, and since Threadripper performance is highly dependent on the RAM clock speed, I was looking at getting a 3600MHz 64 GB (4x16 GB) non-ECC kit for mine:

 

https://m.newegg.com/products/N82E16820232576

 

It's now out of stock, which seems to be a trend with the high speed kits.

 

I really didn't want to wait any longer, but I do have a Windows 10 VM and a Titan X (Pascal) for gaming and I'd hate to spend all that money to upgrade to something that wouldn't run it correctly.

 

The 16 core Intel is a crapton more money, but I might be able to get away with a cheaper motherboard (haven't looked yet) and maybe a little cheaper RAM to make up some of the difference.

 

I've never bought AMD before, and I thought Threadripper changed my mind but I'm really not sure now. :-/

Link to post

EKWB has a 25% off coupon for Black Friday (I think for orders over $500), so that saved me ~$260.
Amazon has the Asus ROG Zenith Extreme for $375, saving me ~$125.

 

And since I didn't jump on that RAM deal before they ran out of stock I can't find anything comparable for less than ~$1k. Go figure.

 

I guess I'm waiting for Cyber Monday now and hoping some good RAM kits go on sale.

 

So now I'm committed with Threadripper. Wish me luck. :-P

Link to post
On 11/24/2017 at 1:14 PM, skunky99 said:

That's an awesome deal! Good luck! If you remember please keep us updated.

 

Haven't forgotten. Got the RAM yesterday and CPU and mobo today. EKWB hasn't shipped the water cooling stuff yet, order still says "processing". I have a Corsair H80i GT closed loop cooler on my current CPU, but even if the bracket included in the Threadripper box would allow it to be attached, I don't think it'd be sufficient to cool that chip.

 

I still need to upgrade my unRAID install to the latest pre-release and track down my tiny little tube of Thermal Grizzly Kryonaut. I also need to see if my power supply has the right connectors for the new mobo or if I need to buy an adapter (there are two spots for 8 pin power connectors).

 

If there's anything specific anyone wants me to test once it's up and running, please let me know. If I remember/have time I figured I'd run some benchmarks before and after in the Windows 10 VM.

image-20171130_192221.jpg

Link to post
13 minutes ago, deaerator said:

Are you having success with Threadripper and Unraid?

EKWB still hasn't shipped my order and hasn't responded to my email asking for an ETA, despite their claim that they respond to all tickers within one working day.

 

I'm tempted to get an air cooler just so I can get the new stuff installed and running while I wait for the water cooling equipment to arrive.

 

Edit: AMD's website says it requires water cooling, but my little H80i GT all-in-one is listed as one of the compatible options, so I may give that a whirl.

Edited by gilahacker
Link to post

Finally heard back from EKWB:
 

Quote

Sadly I must inform you that your order is unfortunately "stuck in processing" because it is missing the 2x EK-CoolStream CE 560 (Quad)(EAN: 3831109860397) which will be restocked on 8th of December 2017

 

Thankfully not too much longer to wait. Still might give the H80i GT a try tomorrow night. Amazon stocks the Noctua NH-U14S TR4-SP3 mentioned in the review @skunky99 linked, but it's also not in stock until December 8th, and by the time they ship it to me I think it'd probably only get a few days of use.

Link to post

Got the Threadripper booted with the all-in-one cooler, and *one* stick of RAM. I had all four in there but pulled them when it wouldn't boot. I'm not awake enough at this point to be 100% sure I had them in the correct slots when they were all installed. It would power on, flash a few random error codes about the memory, and power off again. The little LCD screen that shows the error codes is directly behind the fans/radiator for the cooler so I could barely see it and it flashed the codes very quickly.

 

The memory is running at 2300 or 2600 or something. It's rated for 3600, but I'll be lucky to get it to run at that. Will definitely need to update the bios first. Running at default settings for now.

 

UnRAID works. Plex works, but CPU usage seems really high when transcoding a single video to my phone at 720p (source is 1080p x264). I had Plex restricted to 4 cores and their 4 corresponding hyperthreads and it was maxing them out. I tried encoding a video with handbrake and it's *slower* than my old 4 core, so something is definitely wrong here. I watched the CPU usage in the unRAID dashboard during the encoding and it was definitely using all the CPUs (I've set no CPU restrictions on Handbrake).

 

Unfortunately, the Dynamix System Temp plugin can't detect the sensors for this CPU/mobo so I have no idea what the temps are. The fans on the all-in-one sound a little louder than they were before, but they're definitely  not running at full blast.

 

I forgot I'm going to need another video card for this system just for unRAID since there's no on-board/on-chip video, so I can't use my Windows VM right now. UnRAID says HVM/IOMMU is disabled, so I'll need to find that setting in the bios anyways.

 

One thing I've noticed is that, unless I zoom out in the browser, the dashboard (booted up in GUI mode) hangs off the right side of the screen. I can see the Logout, Feedback, Help, and Info buttons but have to scroll to the right to see the Log button. This is likely due to the fact that I just updated to the RC before swapping the hardware. It's annoying, in any case.

 

While the Dashboard page appears to correctly show the cores, the VM settings page is a complete mess (I'll try to attach a picture here).

 

I'm falling asleep at the moment and have to work in the morning, so I probably won't be messing around with this again until the weekend.

Screenshot_20171207-230943.png

Link to post

I updated my motherboard BIOS to the latest version on the downloads page (0804) and shoved another stick of RAM in there. Everything runs *noticeably* faster. I got the RAM up to 3333, IIRC (rated for 3600). Wouldn't boot if set any higher. Encoding a 1080p Blu-ray to HEVC x265 was about twice as fast as it was with my old quad core 4 GHz Intel chip, but the all-in-one cooler on the CPU was maxing out its fans, so there may have been some thermal throttling going on). My water cooling kit finally arrived today so I'm looking forward to getting that all set up and overclocking the CPU.

 

Someone just posted a beta BIOS (0901) on a forum and it's got AGESA 1.0.0.4, which is probably worth a try.

 

I found the virtualization settings in the BIOS and enabled them and unRAID says it's all good. I can even see my Nvidia Titan X and was able to assign it back to my VM. I booted the VM and my monitor went from the unRAID GUI to a blank screen and just sat there. Not sure if that's pass-through not working or just because I don't have a separate video card for unRAID itself. I *was* able to log into the VM via RDP and it saw the processor and all its cores (I'd assigned them all to the VM for funzies). I fired up a benchmark app and lost my RDC session before even actually running the benchmark. I'm guessing this is due to the current bug in the latest release candidate (15e) as several people are reporting that their Windows VMs are crashing/locking up on shutdown, etc. In any case, I had to hard power off the server as I couldn't even kill -9 the VM process.

 

I'm going to jump to the beta BIOS and see if I can get the other two sticks of RAM in there (one bank is directly behind the all-in-one cooler, I barely got the 2nd stick installed) and will report back if I learn anything new of consequence.

Link to post
8 hours ago, willnnotdan said:

Has any one tried: 

...

to fix the GPU passthrough issue? Or does anyone know how you would apply a fix like this to unraid? 

 

That's all way above my head. If I had to guess, I think they're editing kernel stuff and recompiling (but I'm really not sure). I doubt the required stuff is installed by default in unRAID to compile your own kernel. Might be something to point out to the guys actually building unRAID though.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.