(Still NOT Solved) current pending sector is 1on new SSD Cache


Recommended Posts

I have a new SSD as a cache drive, and just started to get alerts (had them for 2 days so far)

 

First alert is:

 

Event: unRAID Cache disk SMART health [197]
Subject: Warning [NAS] - current pending sector is 1
Description: CT250MX500SSD1_1803E10AC5FE (sdf)
Importance: warning

 

then - 20 mins later, a 'clear' alert

 

Event: unRAID Cache disk SMART message [197]
Subject: Notice [NAS] - current pending sector returned to normal value
Description: CT250MX500SSD1_1803E10AC5FE (sdf)
Importance: normal

My Trim is schedules to run daily at 04:55

 

Should i be worried, the SSD parameters are not fully populated in the smartdb -its a brand new Crucial MX500 drive, so assuming that smart needs to be updated. 

 

 

Edited by trurl
make RichardU happy
Link to comment
52 minutes ago, johnnie.black said:

Not likely, Crucial usually releases a a bootable update, so you should still be able to do it on the server.

 

I have done this once. Downloaded an iso image file from Crucial and created a bootable DOS disk (USB) using Rufus.

Link to comment

great stuff thanks - i saw another model of Crucial SSD on their site, and there is an app you can install in your PC too, run the app, detects the drive, and downloads the firmware, so looks like there are options, 

 

My box is a bit hidden  where its located, so i have stuff to move to get to it, would have been great to do it via the CLI, but if i have to pull the drive or similar, no hardship. 

 

Link to comment
  • 1 month later...
  • 2 months later...

http://www.crucial.com/usa/en/support-ssd?cm_re=us-support-_-main-_-firmware-update-link

 

Firmware M3CR022 has been tested and qualified for immediate release in the Crucial factory, including 2.5-inch and M.2 models of the MX500 SSD. The update from M3CR010 to M3CR022 is an optional update for SSDs in the field, but is recommended if the MX500 is experiencing any of the following issues:

  • Improved ready time from DEVSLP low-power state.
  • Improved TRIM and Wear Leveling performance.
  • Improved SATA error handing.
  • Improved compatibility with some TCG Opal 2.0 third-party encryption utilities (this change does not affect MS BitLocker).
Link to comment
23 hours ago, sourCream said:

http://www.crucial.com/usa/en/support-ssd?cm_re=us-support-_-main-_-firmware-update-link

 

Firmware M3CR022 has been tested and qualified for immediate release in the Crucial factory, including 2.5-inch and M.2 models of the MX500 SSD. The update from M3CR010 to M3CR022 is an optional update for SSDs in the field, but is recommended if the MX500 is experiencing any of the following issues:

  • Improved ready time from DEVSLP low-power state.
  • Improved TRIM and Wear Leveling performance.
  • Improved SATA error handing.
  • Improved compatibility with some TCG Opal 2.0 third-party encryption utilities (this change does not affect MS BitLocker).

I have had this issue for months.  Just installed this FW, I will report back if I have issues.

 

Link to comment

I just did the firmware update. I have two cache drives, so I thought I'd be clever and remove them one at a time. If I ever do this again, I will just shut down the server instead and take them both out at once. The update only takes a few minutes and doesn't affect the data on the drive.

Link to comment
  • 1 month later...

I think i marked it as solved when jonnie black said its not an unraid issue, its a firmware problem, and to wait for new firmware. 

 

Happy to unmark as solved, but not sure anyone may be able to help apart from Crucial with correct firmware. 

 

Wonder if its worth a few of us emailing crucial, perhaps they are not aware of the issue!?

Link to comment
1 minute ago, rorton said:

Wonder if its worth a few of us emailing crucial, perhaps they are not aware of the issue!?

 

That could help, as I've used some of these with Windows and this issue never manifested itself, so it might be limited to Linux and FreeBSD, as the same happens when they are used with FreeNAS.

Link to comment

read a few posts on reddit about this too, few ppl on there with the same problem. 

 

the new firmware just released was supposed to fix it but hasn't - people have got onto Crucial support and they say its with engineering.

 

I was waiting on an online chat, but dropped the connection after i read this - will wait for next firmware release

Link to comment
  • 3 months later...
  • 2 weeks later...

Have an MX500 500GB, and also 2TB that I recently switched in as a cache.. yep, both plagued by pending sector count notifications. Quite annoying, hopefully we'll see a fix.

 

In the meantime, is there a way to turn off notifications for just the one drive?

Edited by Virtike
Link to comment
  • 3 months later...

So there is a new FW update: https://assets.crucial.com/wcsstore/CrucialSAS/firmware/mx500/M3CR023/MX500_M3CR023_update.zip

BUT for me it only fixed the error for a few days. Now they sporadically come back again.

 

(This issue truly is not an error specific to Unraid. I have this error with 3 systems running proxmox with ceph. Somebody else I know has the problem with Freenas)

 

Let's wait for version 24 I guess...

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.