Jump to content

Mover not overwriting partial files (solved)


Recommended Posts

I googled this situation and didn't see anything, my apologies if I am posting wrong.  I noticed a couple of days ago that mover was full and wouldn't empty, then found xfs errors which I cant find right now to quote.  Ran a parity check, then mover, which didn't work, but my log file filled up.  Today, I rebooted, log file looks pretty good, no errors, not full, it looks like I am just getting this type of message when trying to run mover:


Jun 4 17:09:36 Tower move: move_object: /mnt/cache/3D-Movies/x/x.mkv File exists 


Does mover not overwrite partial files?  I think there were a couple of days where files were half moved and now mover wont overwrite the full versions from the cache drive to the partial versions on the array.  I recently replaced sdf with a new drive after the old one may have been going bad, mover issues occurred after.  I tried to find a test file to delete on the drive using krusader to see if mover would work on the file, but I can't find individual drives in krusader.


What should I do?  Thanks.


Link to comment

mnt looks empty in krusader.  I tried tools->root mode krusader, and the first time it took my password but still didn't show any contents.  After restarting krusader, It wont accept my root password.  I guess I can offload the files and then add them back, but it would be nice to have a gui method on the unraid server to accomplish this.

Link to comment
31 minutes ago, johnnie.black said:


/mnt/diskX or /mnt/user0



Which may mean adding or modifying an entry in the krusader docker config.


Be careful, and don't move, copy, or delete files until you understand how user shares work. The default of only mounting /mnt/user mostly protects you from accidentally nuking stuff, changing that introduces risk if you don't know what you are doing.

Link to comment
1 minute ago, bobobeastie said:

mnt looks empty in krusader.


That's because it is. By default /mnt inside of krusader isn't mapped to unraid, it only exists inside the krusader container.


You need to educate yourself on docker mappings and user shares before you start modifying things, otherwise you stand a good chance of deleting something you didn't mean to.

Link to comment
3 minutes ago, bobobeastie said:

I'm open to alternate solutions, this must happen at times to others.  I just tried to find the dir from the unraid web gui terminal and can't find my way around.  I'm sure that's just as dangerous.


13 hours ago, bobobeastie said:

I can't find individual drives in krusader.

You can temporarily enable disk shares, and poke around the individual disks over the network. Just be sure to keep all activity segregated, don't copy stuff from your normal shares to the disk shares or vice versa.

Link to comment

Thank you jonathanm, I was able to figure out how to use midnight commander after some googling.  I tested first on a file I didn't mind re-creating, and after deleting that on the disk, mover was able to move from cache to my share.  Then I did everything else.  It's good to have different options though.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...