EdgarWallace

Members
  • Content Count

    861
  • Joined

  • Last visited

Everything posted by EdgarWallace

  1. root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='openHAB' --net='br0' --ip='192.168.178.22' --cpuset-cpus='5' --privileged=true -e TZ="Europe/Berlin" -e HOST_OS="Unraid" -v '/etc/localtime':'/etc/localtime':'ro' -v '/mnt/user/system/appdata/openhab/conf/':'/openhab/conf':'rw' -v '/mnt/user/system/appdata/openhab/userdata/':'/openhab/userdata':'rw' --device=/dev/ttyACM0 --shm-size 2g 'openhab/openhab:latest-debian' /bin/chmod o+rw /dev/ttyACM0 && /entrypoint.sh 55c064827917c2b56ce5dbc5983f7d635623dec20f4aca7477e2b0fad4ef2e7c sh: /entrypoint
  2. What does that mean please? Should I enter this into the Post Arguments box? /bin/chmod o+rw /dev/ttyACM0 && /entrypoint.sh
  3. If you are using openhab/openhab:latest-debian as openHAB Repository you are getting that update automatically.
  4. Unfortunately openHAB doesn‘t start when I am adding /bin/chmod o+rw /dev/ttyACM0 into the Post Arguments box....
  5. There is on comment on Troubleshooting of OH3: docker exec \ -d \ openhab \ /bin/chmod o+rw /dev/ttyACM0 Is there any way to and that into the Docker template, or how to add ist myself? Maybe adding ist into the Post Arguments?
  6. I was trying to get Collabora running as seperate Docker: I installed the container with default name (collabora), renamed the sample proxy conf, added the subdomain in SWAG and as CNAME at my DNS provider. SWAG log is showing: [cont-init.d] done. [services.d] starting services nginx: [emerg] "server" directive is not allowed here in /config/nginx/proxy-confs/collabora.subdomain.conf:3 Server ready nginx: [emerg] "server" directive is not allowed here in /config/nginx/proxy-confs/collabora.subdomain.conf:3 nginx: [emerg] "server" directive is not allowed here in /config/nginx/proxy-confs/
  7. Thanks @saarg because I would need to set up a subdomain which is much more complex than using the build in Collabora (or Onlyoffice) app. I might be better off migrating to knex666 Nextcloud docker with full Onlyoffice integration based on Apache.
  8. Thanks @BRiT that is working great!!!
  9. Sorry to bother again....is it realistic waiting for a fix of the integrated Collabora App? Thanks a lot.
  10. Thanks a lot @saarg I just need one of these apps Collabora would be perfectly fine. I got the link from Collabora. AppImages does not run on Alpine which is the root cause that integrated Collabora app isn‘t running on Alpine Dockers....at least how I understood it.
  11. I would kindly ask for advise: I was never successful in having the Collabora or Onlyoffice Docker running with my Nextcloud install and having read @saarg post is not giving big hope. The Collabora support replied on my question that I am getting an error message by accessing the build-in Collabora app: linuxserver.io Nextcloud docker is based on Alpine which uses musl libc instead of glibc - and AppImages do not work with musl libc: https://github.com/AppImage/AppImageKit/issues/1015 I would like to stick to my linuxserver.io Nextcloud install that is runni
  12. A question to that command if I want to just "immutable" certain files. I was trying e.g.: find /mnt/disk2/Kino/*.m4v -type f -exec chattr +i "{}" \; That is working well except with sub-directories. I was trying to use the -R (recursively changes attributes of directories and their contents) flag but this is not working. HAs anyone tried this? Thanks a lot.
  13. Thanks a lot @ich777 Yes I indeed forwarded TCP and UDP and made the test. Results are attached, I do believe that this is looking fine? However, it takes ages, until someone is accepted to enter a TALK meeting. Did you made the same experience?
  14. Hi, great work on the STUN-TURN-Server. Just asking for confirmation if I understood correct that I haver to open port 5349 in my router? And then adding myownnetwork.com:5349 into the STUN & TURN settings of Nextcloud/Settings/Talk? Thanks a lot.
  15. @Menthalo I don't see that variable in my Docker settings. HAve you defined it yourself?
  16. Thanks @aptalca. I am using a FritzBox as router and was searching that what you suggested and added myurl.com into the DNS-Rebind-Protection exception field and reebooted my router. Still no luck. Question remains, why it the error is coming up now. The only change I made a couple of weeks ago is the file default. default
  17. Anyone else having an issue with the renewal of the certs? I am leaving the server switched on during the night and having looked at the "Troubleshooting Letsencrypt Image Port Mapping and Forwarding" guide and I can access my server via a cell phone as described in the troubleshooting guide. I haven't changed my router setting either (Ports 443 and 80 are forwarded since years...). Have no idea where to look next. letsencrypt.log
  18. With the new Nextcloud version 18 I was hoping to enable and use the internal Onlyoffice but with the LSIO docker it seems to be an issue. I am back using your docker @Jidovu Marius Adrian I again performed all steps and have the docker running but currently only by adding https://192.168.178.28:4432/ into the Onlyoffice server address. As soon as I am trying to use https://myaddress.com/apps/onlyoffice I am getting this error: HealthcheckRequest on check error: Client error: `GET https://myaddress.com/apps/onlyoffice/healthcheck` resulted in a `401 Unauthorized` response: {"mes
  19. That is done. /mnt/user/system/docker/appdata/onlyoffice/DocumentServer/data is existing (however it is empty) but I created the /mnt/user/system/docker/appdata/onlyoffice/DocumentServer/data/certs folder which contains: -rwxr-xr-x 1 110 114 424 Dec 9 12:04 dhparam.pem* -rwxr-xr-x 1 110 114 1298 Dec 9 12:03 onlyoffice.crt* -rwxr-xr-x 1 110 114 1078 Dec 9 12:02 onlyoffice.csr* -rwxr-xr-x 1 110 114 1679 Dec 9 12:01 onlyoffice.key* I changes the template towards: https://[IP]:[PORT:4432] which is now successfully showing the Welcome Screen. Other than that no success.
  20. That doesn't work and I can't see any log messages. I have attached the setting of my container. http://192.168.178.28:8082/ is providing the welcome screen and the message, that onlyoffice is running https://192.168.178.28:4432/ is providing an error mesage - website not accessible http://server.com:8082/ is providing an error mesage - website not accessible https://server.com:4432/ is providing an error mesage - website not accessible
  21. Sorry, in Nextcloud setting under onlyoffice you can try the demo server. I have installed Nextcloud and Let's Encrypt docker containers. Is there anything required regarding these settings?
  22. Thanks a lot @Jidovu Marius Adrian for this docker. I was looking for a way to edit documents on my iPad without using MS Office/Word etc. Your guide is excellent and I was successfull installing the docker. Opening documents by using the demo server is working well. My only remaining issue is accessing my own server rather than the demo server. creating the onlyoffice network was successful http://192.168.178.28:8082/welcome/ ist showing: Document Server is running -rw-rw-rw- 1 root root 424 Dec 9 12:04 dhparam.pem -rw-rw-rw- 1 root root 1298 Dec 9 12:03
  23. Thanks @saarg Modifying default under /mnt/user/system/docker/appdata/letsencrypt/nginx/site-confs is having an effect: The "Strict-Transport-Security" HTTP header is not set to at least "15552000" seconds. For enhanced security, it is recommended to enable HSTS as described in the security tips ↗. However I guess you are correct that the issues are generated by Nextcloud (this time in English): The "X-Content-Type-Options" HTTP header is not set to "nosniff". This is a potential security or privacy risk, as it is recommended to adjust this setting accordingly. The "X-R
  24. I used the guide here to update my Nextcloud Docker: PSA: Nextcloud & CVE-2019-11043. Since then I am getting onyl an A security grade and some warnings: Der „X-Content-Type-Options“-HTTP-Header ist nicht so konfiguriert, dass er „nosniff“ entspricht. Dies ist ein potentielles Sicherheitsrisiko und es wird empfohlen, diese Einstellung zu ändern. Der „X-Robots-Tag“-HTTP-Header ist nicht so konfiguriert, dass er „none“ entspricht. Dies ist ein potentielles Sicherheitsrisiko und es wird empfohlen, diese Einstellung zu ändern. Der „X-Download-Options“-HTTP-Header ist nicht so konfiguriert,