Nem

Members
  • Posts

    175
  • Joined

  • Last visited

Everything posted by Nem

  1. I'm having an extremely hard time trying to set this up. What are the key options I in the admin panel that I need to change? I have the correct ports forward on my router, but the connectivity test always fails, so I must have some settings wrong somewhere
  2. Nem

    openvpn AS

    I just installed openvpn access server, and I must be going blind because I can't find a place to change the default admin password. Is there a setting in the menus I missed? Or is there a way to change it via ssh?
  3. Wasn't sure where to post this as the problem spans a number of applications I have apache reverse proxy set up with most of my applications. I'm trying to set one up for the deluge webui. I'm using delugevpn so everything is hidden behind a vpn This is what I have in my apache conf: <Location /deluge> ProxyPass http://192.168.187.10:8112 ProxyPassReverse http://192.168.187.10:8112 </Location> When I navigate to domain.com/deluge I just see a blank page However, I have also tried port forwarding and that works fine. So if I go to publicip:8112 then everything works no problem Is there something I'm missing in my apache conf thats preventing reverse proxy from working?
  4. isn't ECC ram highly highly highly recommended when using ZFS? I'd like to see ZFS as an option, but not as the one and only file system for unraid (not that thats what you're suggesting, just voicing my concern)
  5. I should have specified this is for a windows guest. And I just checked, that feature is only available for linux guests
  6. Is there a way to pass through the contents of shares directly to the VM? I realize you can probably just access the share over the network, is this the only way? Are there any performance hits by doing it this way?
  7. ah thats a shame. I'm on a mini-itx board and only have 1 pcie slot. OK, will take a look at replacing the cpu, thanks
  8. That appears to have fixed things, thanks! So what did I do that caused this problem? Just trying to understand so I can avoid this type of thing in the future
  9. I was under the impression that unraid that can run headless and that it doesn't need integrated/discrete graphics in order to run. I have a xeon e3 with no iGPU, but I have a gtx960 as well. I've been trying to pass the 960 through to a windows VM but I keep seeing a blackscreen Could this be related to the fact that the 960 is the only graphics device in my system? Or has anyone successfully passed through a gpu to windows VM when its the only device?
  10. I had unraid with docker running fine before my server upgrades. One of the upgrades was replacing the cache drive with a larger one. I followed the instructions here: https://lime-technology.com/wiki/index.php/Replace_A_Cache_Drive After copying docker.img back to the cache drive and restarting the array everything appears to show up OK. The dockers appear to be working. When I go into the docker settings and scrub, however, I get 2 uncorrectable errors: scrub status for 73b6b03e-f0d6-498a-ae48-cbea42522c54 scrub started at Sat Dec 5 19:52:31 2015 and finished after 00:00:11 total bytes scrubbed: 5.66GiB with 2 errors error details: csum=2 corrected errors: 0, uncorrectable errors: 2, unverified errors: 0 I check the log and I see this: Dec 5 19:52:31 Server php: /usr/local/emhttp/plugins/dynamix/scripts/btrfs_scrub 'start' '/var/lib/docker' Dec 5 19:52:36 Server kernel: BTRFS: checksum error at logical 3003174912 on dev /dev/loop0, sector 7979112, root 395, inode 1207326, offset 5152768, length 3640, links 1 (path: var/log/auth.log) Dec 5 19:52:36 Server kernel: BTRFS: bdev /dev/loop0 errs: wr 0, rd 0, flush 0, corrupt 7, gen 0 Dec 5 19:52:36 Server kernel: BTRFS: unable to fixup (regular) error at logical 3003174912 on dev /dev/loop0 Dec 5 19:52:42 Server kernel: BTRFS: checksum error at logical 7370739712 on dev /dev/loop0, sector 16509512, root 395, inode 26832, offset 327606272, length 3936, links 1 (path: var/log/error) Dec 5 19:52:42 Server kernel: BTRFS: bdev /dev/loop0 errs: wr 0, rd 0, flush 0, corrupt 8, gen 0 Dec 5 19:52:42 Server kernel: BTRFS: unable to fixup (regular) error at logical 7370739712 on dev /dev/loop0 Dec 5 19:52:48 Server kernel: BTRFS warning (device loop0): csum failed ino 1207326 off 5152768 csum 3845547863 expected csum 1038413045 Dec 5 19:52:48 Server kernel: BTRFS warning (device loop0): csum failed ino 1207326 off 5152768 csum 3845547863 expected csum 1038413045 Dec 5 19:52:48 Server kernel: BTRFS warning (device loop0): csum failed ino 26832 off 327606272 csum 1778903515 expected csum 790652044 Dec 5 19:52:48 Server kernel: BTRFS warning (device loop0): csum failed ino 26832 off 327606272 csum 1778903515 expected csum 790652044 And whenever I open up the webgui of a docker this warning just keeps repeating in the log: Dec 5 19:53:48 Server kernel: BTRFS warning (device loop0): csum failed ino 1207326 off 5152768 csum 3845547863 expected csum 1038413045 Dec 5 19:53:48 Server kernel: BTRFS warning (device loop0): csum failed ino 1207326 off 5152768 csum 3845547863 expected csum 1038413045 Dec 5 19:53:48 Server kernel: BTRFS warning (device loop0): csum failed ino 26832 off 327606272 csum 1778903515 expected csum 790652044 Dec 5 19:53:48 Server kernel: BTRFS warning (device loop0): csum failed ino 26832 off 327606272 csum 1778903515 expected csum 790652044 Is there a way to fix this? I didn't get any errors prior to moving the image to a larger cache drive I'm not sure if this is related, but as part of the upgrades I removed the parity drive and had to turn it into another data drive (temporarily until I get a larger parity drive). To do this, I went into Tools > New Config, added all my old data drives to the array without a parity
  11. I have an SSL certificate for my server as i need to access it remotely for various reasons. Is it possible to use that with openvpn server for extra security? What are the steps required to get that set up?
  12. I see that there are dockers for OpenVPN AS, and also a separate plugin for running an OpenVPN server. What are the major differences between the 2? I'm looking for the one that will be easiest to set up and give me the least amount of headache.
  13. I'm seeing this warning in the delugevpn log file: 2015-11-29 16:20:42,310 DEBG 'deluge' stdout output: [warn] PIA incoming port is not an integer, downloads will be slow, check if remote gateway supports port forwarding Is this normal? Or is there a way to fix it?
  14. Does dropbox allow for local LAN syncing of files?
  15. I guess im mostly wondering about 1) how to move my current cache contents to the new SSD without breaking anything, and 2) whether plugging hard drives into different SATA ports will cause any issues with shares?
  16. Im currently planning on a few server upgrades: 1. Replacing the cpu 2. Switching my cache drive for a larger SSD 3. Moving to a larger case What special considerations should be given when making these changes? I want to minimize the chance of losing data or creating more problems as a result of changing hardware
  17. Here is what the directory permissions look like: The problem directory has nobody as owner, the one that works has simon set as owner I'm not really understanding how permissions work in linux... Unraid sets nobody as owner for all shares (confirmed). So, I have a Media share that is owned by nobody. On my main desktop (logged in as simon) I copied all my media files to that Media share. Even though the Media share is owned by nobody, all subdirectories are now owned by simon. The same thing happens for any other subdirectory - they're all owned by whoever copied the file to the share - is this normal? expected? What if one user wants to edit files moved there (and owned) by another user?
  18. So all of my user shares are set to nobody as owner and when I log in to the share on Windows with my account (simon) I can edit files no problem. How come when CP sets a directory to nobody, I can no longer edit the files/folder? This is despite the simon account having read/write permission to the share...
  19. the problem im facing is that I cant copy to/from or edit any directories created by couchpotatos renamer and im guessing its because of this ownership issue the share that CP is moving files to is read/writeable by myself (as set in unraid), but despite that I dont have the ability to edit the files. I can edit non-CP directories OK
  20. I have couchpotato to pull in files from a different directory, and it seems that everytime it does the renaming it sets the owner of the directory to 'nobody'. This means that any user on my unraid system does not have write permissions to that folder sonarr used to have the same problem, but that has an option in settings for assigning ownership to a user. I couldn't find a similar option for couchpotato What is the best way to handle this situation? Is there a setting in CP that I missed somewhere? On an unrelated note, I just checked /mnt/user and all of my shares have 'nobody' set as the owner too...is that normal?
  21. I appear to be getting scrambled audio issues when playing certain videos through emby. I wonder if this is an emby bug or whether a codec is missing that can be installed server side?
  22. My home network consists of a server holding all my media files, a mysql database on the server to hold kodi info, and kodi clients (windows, raspberry pi) that play the actual media. everything has worked nicely so far Can anyone explain what a headless kodi server is, and how it might improve my current network setup? From what I understand it does library updates in the background so my clients dont need to be online, which I'm assuming will update my mysql database in the process. But once clients boot up, don't they still need to poll the database and refresh their own library?
  23. regarding delugevpn: 1. Is there a killswitch built in such that internet connection gets cut off if VPN loses its connection? 2. Is there an autorestart for deluge and openvpn in case the daemon crashes?
  24. makes perfect sense, thanks In that case, is there a plugin that will create a backup of the cache drive so I don't risk losing my appdata/config data in the event of a cache drive failure? I've seen some scripts floating around the forum, but something like a plugin would be useful