Marco L.

Members
  • Posts

    19
  • Joined

  • Last visited

About Marco L.

  • Birthday March 28

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Marco L.'s Achievements

Newbie

Newbie (1/14)

1

Reputation

  1. Don't know then... That's what I'm seeing I'm launching a fourth one then !
  2. Hi, 1-2 months ago, power went down. After the automatic parity check Unraid did post-reboot, the server had 34 errors. Since then, I've done 2 more checks (3 in total), and all of the 3 gave 34 errors, so it seems that the errors can't be removed by the parity check. The checkbox for correcting is checked. What can I do ? I've already done a memtest with one successful pass (took already fairly long, a few hours). I don't think it is cable related, as I moved my server beginning of 2021 to the Silverstone NAS case and had to buy brand new special cables for that case (SFF-8643) that worked well for a while before this incident. I've started migrating my array from 4TB to 12TB disks, maybe one of the old 4TB that shows its age ? mediaserver-diagnostics-20211114-1607.zip
  3. I'm having issues with the scripts folder, why is it not there ? I've done a fresh reinstall of OpenVPN to be sure, same thing: Is it due to the issue with the as-repo PPA ? Current default time zone: 'Europe/Berlin' Local time is now: Sat May 15 21:12:23 CEST 2021. Universal Time is now: Sat May 15 19:12:23 UTC 2021. [cont-init.d] 20-time: exited 0. [cont-init.d] 30-config: executing... installing openvpn-as for the first time Hit:1 http://archive.ubuntu.com/ubuntu bionic InRelease Get:2 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB] Get:4 http://archive.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB] Get:5 http://archive.ubuntu.com/ubuntu bionic-updates/universe Sources [573 kB] Get:3 http://as-repository.openvpn.net/as/debian bionic InRelease Err:3 http://as-repository.openvpn.net/as/debian bionic InRelease Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?) Get:6 http://archive.ubuntu.com/ubuntu bionic-updates/main Sources [640 kB] Get:7 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [2,582 kB] Get:8 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages [2,183 kB] Get:9 http://archive.ubuntu.com/ubuntu bionic-security/restricted Sources [21.6 kB] Get:10 http://archive.ubuntu.com/ubuntu bionic-security/main Sources [317 kB] Get:11 http://archive.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [1,411 kB] Get:12 http://archive.ubuntu.com/ubuntu bionic-security/main amd64 Packages [2,150 kB] Get:13 http://archive.ubuntu.com/ubuntu bionic-security/restricted amd64 Packages [423 kB] Reading package lists... E: Failed to fetch http://as-repository.openvpn.net/as/debian/dists/bionic/InRelease Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?) E: The repository 'http://as-repository.openvpn.net/as/debian bionic InRelease' is not signed. Stopping openvpn-as now; will start again later after configuring cat: /var/run/openvpnas.pid: No such file or directory kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec ... or kill -l [sigspec] sed: can't read /usr/local/openvpn_as/etc/as_templ.conf: No such file or directory [cont-init.d] 30-config: exited 0. [cont-init.d] 40-openvpn-init: executing... find: ‘/config/etc/db’: No such file or directory /var/run/s6/etc/cont-init.d/40-openvpn-init: line 14: /usr/local/openvpn_as/bin/ovpn-init: No such file or directory Stopping openvpn-as now; will start again later after configuring cat: /var/run/openvpnas.pid: No such file or directory kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec ... or kill -l [sigspec] [cont-init.d] 40-openvpn-init: exited 0. [cont-init.d] 50-interface: executing... /var/run/s6/etc/cont-init.d/50-interface: line 9: /usr/local/openvpn_as/scripts/confdba: No such file or directory /var/run/s6/etc/cont-init.d/50-interface: line 10: /usr/local/openvpn_as/scripts/confdba: No such file or directory /var/run/s6/etc/cont-init.d/50-interface: line 11: /usr/local/openvpn_as/scripts/confdba: No such file or directory /var/run/s6/etc/cont-init.d/50-interface: line 12: /usr/local/openvpn_as/scripts/confdba: No such file or directory [cont-init.d] 50-interface: exited 127. [cont-init.d] 99-custom-scripts: executing... [custom-init] no custom files found exiting... [cont-init.d] 99-custom-scripts: exited 0. [cont-init.d] done. [services.d] starting services [services.d] done. ./run: line 3: /usr/local/openvpn_as/scripts/openvpnas: No such file or directory ./run: line 3: /usr/local/openvpn_as/scripts/openvpnas: No such file or directory ./run: line 3: /usr/local/openvpn_as/scripts/openvpnas: No such file or directory ./run: line 3: /usr/local/openvpn_as/scripts/openvpnas: No such file or directory ./run: line 3: /usr/local/openvpn_as/scripts/openvpnas: No such file or directory ./run: line 3: /usr/local/openvpn_as/scripts/openvpnas: No such file or directory It only started doing that since yesterday evening, before it was all fine
  4. I think I have another lead. Today I realized my OpenVPN server was not working anymore. Upon checking the logs, I saw this: Reading package lists... E: Failed to fetch http://as-repository.openvpn.net/as/debian/dists/bionic/InRelease Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?) E: The repository 'http://as-repository.openvpn.net/as/debian bionic InRelease' is not signed. Stopping openvpn-as now; will start again later after configuring After trying to manually check this IP in my browser, I got a nice message from my ISP telling me this website is not safe, is known to contain malware and was blocked..... It is literally an URL for a PPA repo from openvpn... Anyway, besides the fact this prevents apparently my OpenVPN server docker to install correctly, it made me realize I have now in my ISP packages a "surf protect" feature, which I didn't ask for "for free" (normally 5 bucks per month). I think that if you have this service enabled, they NEED to see your traffic to "protect" you, so that may explain my issues with the 1.1.1.1 DNS and Cie.... EDIT : I have obviously asked that this stupid thing be deactivated
  5. I have a lead. If I switch to "automatic DHCP" from static, everything is super snappy (unraid menus) and nslookup works, If I switch back to static and add DNS like 1.1.1.1 and 8.8.8.8, nslookup stops working. If I revert back to auto DHCP, it works again. If I revert back to static IP without touching DNS, it still works. ?????????????????????????????????????????????????? Is it possible that XGS-PON requires you to use your ISP provided DNSes ?
  6. I've started to have weird DNS issues since today and ended up here. Guess what changed since last week and this week ? I've got a new fiber line and started using a new (probably crappy) ISP provided fiber box. Seems everything points to the ISP boxes. But do you guys have all one thing in common maybe in regards to the ISP or line technology used? On my side, I'm stuck, because all the ISPs here block their routers from being used in bridge mode. And since it's a very last gen 10gig XGS-PON connection, you can't really use homelab equipment yet, as this technology has very specific requirements, because some authentication mechanism is put on the software side of the client's router. In other words, you can't just hook up any media converter like for regular 1gig connections. So I'm stuck with this ISP crap that I can't change and that apparently will give me a ton of DNS issues, as mentioned above by everyone else. Great .... 😅
  7. Yep, sorry I read it quickly and saw: so I thought it was only an issue for ports. So basically I guess that the other templates don't add fields for values that could be widely different depending on the user preferences, like shares & Cie. You said you were mainly using this for yourself, so I guess we would need another template with just the bare minimum filled and the rest to be filled by the user, as other "mainstream" templates do. You loose a bit of time the first time, but save some after that. TIL something.
  8. Thanks ! If anyone has any idea why this particular docker template would need the TemplateURL parameter to be manually removed, any feedback is welcome. I remember not having to do that with the activ-transmissionvpn one, which is fairly similar to this one, except for the missing extra GUI options (kettu, ...)
  9. Still, would be nice if CUSTOM was one option offered by default, to anyone using this. Thanks for the link
  10. Ok, after much research, I've come to this list. This is not necessarily the most "budget optimized, ebay hunter" list, I know. I will be getting soon a 10Gbps WAN fiber from my new ISP/location, hence the upgrade for my NAS at first. Mikrotik CRS309-1G-8S+INL : 8x SFP+, 1 RJ-45 mgmt. It has passive cooling, a must-have for office use. Netgear's XS708T are reviewed as silent but a lot of people's feedback says the pitch is not suited for office use, so bybye Netgear. I choose this over the 5 port cousin for futur proofing, when 10G becomes standard and everything is 10G, including my futurs NASes and PCes. Mikrotik S+RJ10 : SFP+ to 10gbe RJ-45 transceiver for my ISP router 10G connection. Chosen because it's listed in the compatibility list, same brand, and available at the same retailer Mikrotik DAC SFP28 cable : same reason as above, listed as compatible, not too expensive even new and available at the same retailer Now for the NIC, I've seens different things. Which one do you recommend ? Any compatiblity issues with the DAC cable ? With Unraid drivers ? INTEL X520-DA2 (eBay) SUPERMICRO AOC-STGN-i2s (eBay) MELLANOX Connect-X3 (eBay) MELLANOX Connect-X2 (eBay) ASUS XG-C100F (new)
  11. I have two issues with this unraid docker package: 1) The dropdown list for VPN providers doesn't contain the CUSTOM field, that is needed for example for AirVPN, because they use custom ovpn configs that you generate. This would not be a problem if not for issue #2 2) Everytime there is an update of this docker, some fields get reset and then the docker stop working. First some fields that I removed, like the /mnt/data/T_Media keep coming back, recreating over and over the share T_Media, which is annoying. More problematic is that the provider resets everytime to the first choice of the dropdown and I have everytime to remove it and manually add it back as CUSTOM, then removed the unneeded fields. Until I do that, the torrenting doesn't work because the VPN can't connect. In summary, it would be nice that the values don't reset like that and that the CUSTOM choice was available for VPN provider.
  12. My question is simple, but I want to confirm I understood the process correctly: Can I upgrade my 4TB HDDs to 12TB HDDs one by one each month, starting with the parity ones first (disable array, remove disk, replace disk, reassign disk, rebuild) ? Does it matter that the first month, one parity will be 4TB and the other 12TB ? Thanks
  13. TLDR : I had a 7200rpm 4TB failed drive, swapped it with my spare, but this failed drive was not replaced by std RMA. Instead I have a voucher as refund. I'm hesitating to buy a 5400 rpm 8TB instead, but it may not be wise considering how parity and HDD size works in unRAID. I plan to move to full 8TB array by 2020ish. Basically, some years ago I bought 9x 4TB 7200rpm HDDs and 1 of them was a spare. I had to use the spare some time ago. But the failed drive was not replaced by the retailer for some logistic reason, so they gave me a refund as a voucher on their website. I am hesitating to buy a 8TB 5400rpm with the voucher as their price is now almost the same as what I paid for this 4TB years ago (WD Red Pro). The problems are : The old drives are 7200rpm and this one is 5400rpm. BUT the speed of an old 4TB pro drive is now almost the speed of a non pro 8TB drive (210 vs 217) If a non Parity drive fails, I would have to buy another 8TB drive, do the parity swap for both parity drives (please confirm this) and then use one of the old parity drive to replace the failed one, which still leaves me with an unused 4TB drive at the end. The thing is that I'm planning to move to 8TB by 2020ish at the latest (maybe even 2019), so this comes down to the odds of a failure until then. EDIT : Or I simply can wait and see if something fails provided that the voucher expires not too soon and be reactive on the order in case of failure.
  14. Did you just spawn both dockers and it was working out of the box ? Maybe I have something in my nextcloud Nginx confs that is conflicting...
  15. Anyone has this docker working with the Nginx Proxy Manager docker for proxy and let's encrypt certs ?