Jump to content

ZosoPage1963

Members
  • Content Count

    19
  • Joined

  • Last visited

Community Reputation

0 Neutral

About ZosoPage1963

  • Rank
    Member
  1. ZosoPage1963

    Share Issues

    Need some help figuring this out. Yesterday, I posted that suddenly I have a ton of shares, and they are artists in my music collection. Most are empty. I went through and deleted them in /mnt/user/ and then today, they are all back. I have a folder called Plexx Media, that is shared, and under that, I have Movies, Music, TV Shows, etc. If I am sharing the Plexx Media folder, will unraid create shares of all the subdirectories under that parent folder? I don't remember having this issue until a few days ago. I must have made some kind of mistake in order for unraid to create all these shares, but I am not sure how to find out and stop them from being created. Yesteday I did a rmdir /mnt/user/A* (etc) to remove the directories without removing directories that had data in them. Any ideas would be appreciated.
  2. ZosoPage1963

    mass delete shares

    thanks... I guess to be very careful, I could do rmdir /mnt/user/A* and that would only remove directories that are empty, correct? (sorry, I am a noob and trying to learn command line)
  3. ZosoPage1963

    mass delete shares

    I have no idea how this happened, but obviously I did something wrong. I now have a ton of shares (with no data in them). One share for each music artist on my server. Is there a way to mass delete shares or do I have to do this one by one?
  4. ZosoPage1963

    Windows 10 VM issues

    I have been trying different things for a month, trying to update graphics drivers on my windows 10 vm. Each time I try installing the driver package, the screen flickers and then goes completely black and I can not get back into the VM. I have to go into the vm, set the graphics back to VNC, go into the VM, and do a restore, in order to get the VM to pass through again. After this past restore, now my sound doesn't work. (EDIT: Sound is working, I switched to onboard sound and am good) I am looking for starting places to look for solutions to a:) the sound issue and b:), finally being able to upgrade the graphics driver in the VM. I have attached the diags. I am running 6.6.6 with MSI X470 GAMING PRO CARBON (MS-7B78) and AMD Ryzen 5 2600 cpu. I have 32 gigs of RAM. My configuration for the VM is screen shot below. I am far from being the most technical person but I can follow instructions and really want to learn more on Unraid. SpaceInvader videos are what got me up and running, but I can not figure out this issue and can't find any resources to help. thank you in advance for any and all help. tower-diagnostics-20181229-1206.zip
  5. ZosoPage1963

    update rx580 drivers in windows 10 vm

    tried the one cpu thing with no luck. I looked in the vm log and am getting this quite a bit: 2018-12-22T15:00:54.296695Z qemu-system-x86_64: vfio: Cannot reset device 0000:1e:00.3, depends on group 17 which is not owned. 2018-12-22T15:00:55.380721Z qemu-system-x86_64: vfio: Cannot reset device 0000:1e:00.3, depends on group 17 which is not owned. 2018-12-22T15:03:40.810676Z qemu-system-x86_64: vfio: Cannot reset device 0000:1e:00.3, depends on group 17 which is not owned. 2018-12-22T15:03:43.866737Z qemu-system-x86_64: vfio: Cannot reset device 0000:1e:00.3, depends on group 17 which is not owned. Also got this warning: 2018-12-22T15:03:43.868014Z qemu-system-x86_64: vfio_err_notifier_handler(0000:1c:00.1) Unrecoverable error detected. Please collect any data possible and then kill the guest 2018-12-22T15:03:43.868080Z qemu-system-x86_64: vfio_err_notifier_handler(0000:1c:00.0) Unrecoverable error detected. Please collect any data possible and then kill the guest 2018-12-22T15:04:48.513494Z qemu-system-x86_64: terminating on signal 15 from pid 6973 (/usr/sbin/libvirtd) 2018-12-22 15:04:49.914+0000: shutting down, reason=destroyed Here is my IOMMU groups and system devices: IOMMU group 0: [1022:1452] 00:01.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge IOMMU group 1: [1022:1453] 00:01.3 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe GPP Bridge IOMMU group 2: [1022:1452] 00:02.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge IOMMU group 3: [1022:1452] 00:03.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge IOMMU group 4: [1022:1453] 00:03.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe GPP Bridge IOMMU group 5: [1022:1452] 00:04.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge IOMMU group 6: [1022:1452] 00:07.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge IOMMU group 7: [1022:1454] 00:07.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Internal PCIe GPP Bridge 0 to Bus B IOMMU group 8: [1022:1452] 00:08.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge IOMMU group 9: [1022:1454] 00:08.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Internal PCIe GPP Bridge 0 to Bus B IOMMU group 10: [1022:790b] 00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 59) [1022:790e] 00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 51) IOMMU group 11: [1022:1460] 00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 0 [1022:1461] 00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 1 [1022:1462] 00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 2 [1022:1463] 00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 3 [1022:1464] 00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 4 [1022:1465] 00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 5 [1022:1466] 00:18.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 6 [1022:1467] 00:18.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 7 IOMMU group 12: [1022:43d0] 03:00.0 USB controller: Advanced Micro Devices, Inc. [AMD] Device 43d0 (rev 01) [1022:43c8] 03:00.1 SATA controller: Advanced Micro Devices, Inc. [AMD] Device 43c8 (rev 01) [1022:43c6] 03:00.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43c6 (rev 01) [1022:43c7] 16:00.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43c7 (rev 01) [1022:43c7] 16:01.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43c7 (rev 01) [1022:43c7] 16:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43c7 (rev 01) [1022:43c7] 16:03.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43c7 (rev 01) [1022:43c7] 16:04.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43c7 (rev 01) [8086:1539] 18:00.0 Ethernet controller: Intel Corporation I211 Gigabit Network Connection (rev 03) IOMMU group 13: [1002:67df] 1c:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] (rev e7) [1002:aaf0] 1c:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 580] IOMMU group 14: [1022:145a] 1d:00.0 Non-Essential Instrumentation [1300]: Advanced Micro Devices, Inc. [AMD] Device 145a IOMMU group 15: [1022:1456] 1d:00.2 Encryption controller: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Platform Security Processor IOMMU group 16: [1022:145f] 1d:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] USB 3.0 Host controller IOMMU group 17: [1022:1455] 1e:00.0 Non-Essential Instrumentation [1300]: Advanced Micro Devices, Inc. [AMD] Device 1455 IOMMU group 18: [1022:7901] 1e:00.2 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 51) IOMMU group 19: [1022:1457] 1e:00.3 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) HD Audio Controller CPU Thread Pairings Pair 1: cpu 0 / cpu 1 Pair 2: cpu 2 / cpu 3 Pair 3: cpu 4 / cpu 5 Pair 4: cpu 6 / cpu 7 Pair 5: cpu 8 / cpu 9 Pair 6: cpu 10 / cpu 11 USB Devices Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 002: ID 1b1c:0c15 Corsair Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 002 Device 002: ID 0781:5583 SanDisk Corp. Ultra Fit SCSI Devices [0:0:0:0] disk SanDisk Ultra Fit 1.00 /dev/sda 30.7GB [1:0:0:0] disk ATA Hitachi HUS72404 A5F0 /dev/sdb 4.00TB [2:0:0:0] disk ATA Hitachi HUS72404 A5F0 /dev/sdc 4.00TB [3:0:0:0] disk ATA SATA SSD 12.4 /dev/sdd 240GB [4:0:0:0] disk ATA Samsung SSD 860 1B6Q /dev/sde 250GB [5:0:0:0] disk ATA ST2000DM001-1CH1 CC24 /dev/sdf 2.00TB [6:0:0:0] disk ATA WDC WD10EADS-00L 1A01 /dev/sdg 1.00TB any help would be appreciated.
  6. ZosoPage1963

    One CPU core stuck at 100%

    this happens to me sometimes when I am shutting down the VM. I also get a AMD-VI Completion Loop Wait timeout error on the screen. I am no expert so all I know to do is reboot the server...
  7. ZosoPage1963

    update rx580 drivers in windows 10 vm

    LOL, He is how I did most everything on unraid... I have watched them over and over.. .that is not for upgrading the drivers, it is for just getting passthrough to work. My pass through is working fine, but what I am trying to do is just update my drivers so I can play warcraft :)... thanks though... I don't think I can update drivers inside the VM, I have to update them in Unraid since I am passing them on to the windows VM.
  8. ZosoPage1963

    update rx580 drivers in windows 10 vm

    Thanks for the reply... I do remember seeing that in a video, may try that... I think I sorta figured it out after thinking about it for a while... Since I am passing through the GPU, shouldn't I update the "graphics ROM" in the VM setup? If I am correct, can someone give me an idea of where I can download the ROM BIOS file? I am not sure if the manufacture website offers that somewhere. the current driver that I am using here is dated for 2017, so I think I do need a new one... thanks again in advance for the help. Learning as I go along with Unraid.... Z
  9. Hello... Are there any issues updating a Radeon RX580 gpu driver within a windows 10 VM? I tried to do this a couple days ago and ended up with a broken VM (it was easier to rebuild than troubleshoot the issue). I have backed up my vdisk, and set a restore point in windows 10, but is there anything else I should be concerned with prior? My VM is running very well with an older driver, and all passthrough is working, but when trying to run my favorite game, it is now telling me that my driver is out of date and I must update. any pointers on (or good videos) on rebuilding a vm when you have the vdisk backed up? unraid 6.6.6 (we need to really move past that 666 version) Ryzen 2600 MSI x460 gaming pro carbon MB (bios updated 12/18 radeon rx580 gpu 32 gig ddr4 3600
  10. ZosoPage1963

    changing out an HD

    QQ for you all. I currently have a 1 TB drive that is my 4th drive out of 4 in my array. Nothing is on it. When I set up Unraid only a month ago, I set it up with this one TB drive, instead of a 2 TB that I had laying around. Can I just stop the array, pop out the 1 TB and then replace it with the 2TB? I do not have a parity drive yet----working on that soon. I have spent many hours trying to get this working perfectly, like it is, and don't want to mess with it if I will have all sorts of problems... or should I just wait for the parity drive, and then make the swap? Media Server --- MSI X470 Gaming Pro Carbon ATX AM4 MB, AMD Ryzen 5-2600 6 Core Processor, 32GB 3600 DDR4 RAM, Cache-Samsung 860 Evo 250GB + 240GB Generic, 2x4TB Hitachi HD, 1-2TB, 1-1TB HD 11TB Total, Corsair H100i Pro 75.0 CFM Liquid CPU Cooler, AMD Radeon RX470 GPU. Currently running 6.6.3 Plus
  11. ZosoPage1963

    [Support] Linuxserver.io - Nextcloud

    Hey guys, I think I know this answer, but thought I would ask. I am new to unraid and am trying to set up nextcloud. My issue is that I currently have an xfinity XB6 modem router. It does not have the ability to forward external ports to internal ports. I can do port forwarding but I cant take port 80 from an external source and map it over to port 81. Same with 443 -> 444. Obviously, the CM was designed for the masses, and when I start doing this type of port forwarding, I am no longer in the masses. Before you tell me to get rid of the modem and go get a good modem and a separate router, that will save me money, I have xfinity PODS, and xfinity home, which basically require one of their gateways. That being said, I don't believe there is a way for me to set up nextcloud with lets encrypt any other way. Am I correct?
  12. edit.... I figured it out... I am a dork... I just had to connect to the 172. address... apologies... Hello guys, another noob question so please be patient with me... I have installed OPENVPN via SpaceInvaders video, and it is working (able to connect to VPN with computer, phone, etc).but I can not connect to the GUI for the server. When I am connected to the VPN, if I do a tracert on a windows 10 computer, I see that the first hop is a 172 address, then the second is my router 192.168.1.1. I can not connect to my tower using tower/ or by the ip address. Is there another setting that I need to do to allow the connection to the GUI? I have tried searching around and am not seeing any suggestions other than using OpenVPN. TIA. MSI x470 Carbon Pro motherboard, 16 gigs of RAM, Ryzen 5 2600 CPU, Radeon RX580 OC 8 GPU. I have 4 drives in the box with 11 TB of storage. 6.6.1 Unraid
  13. ZosoPage1963

    General Windows VM issues (SOLVED)

    box has been up and stable after passing through one of my USB controllers and following this videos suggestion on windows settings exactly. Kept VM running overnight and it was still running without issue this morning. thanks all for the suggestions. https://www.youtube.com/watch?v=miYUGWq6l24
  14. ZosoPage1963

    General Windows VM issues (SOLVED)

    still not having any luck. Windows locks up multiple times during the day and then loses it sound drivers after a lookup reboot.
  15. ZosoPage1963

    General Windows VM issues (SOLVED)

    awesome! thank you, trying this today as I have still experienced lockups and reboots.