Unable to boot neither with legacy nor uefi mode

Go to solution Solved by itimpi,

Recommended Posts

I was about to try unRAID on my HP ProDesk 400 G5 with the trial license. I specifically bought the recommended Sandisk Cruzer Fit (32GB), but I only have a USB 3.0 port available for the drive to boot from.


I used Unraid USB Creator (Win32-1.8.exe) to create the boot drive (unRAID stable 6.10.1).


However I can't boot to unRAID. When I attempt to boot in UEFI mode, I only get a BIOS beep and am directed back to the boot options. I then re-enabled legacy mode and attempted to boot in legacy mode I get the message that the chosen device isn't a boot device.


Are there any BIOS settings I could try or another approach of creating the USB drive?

Link to comment
1 minute ago, itimpi said:

Have you checked to see if the EFI folder on the flash drive has trailing tilde character?   If so you need to remove this to enable UEFI boot.


The EFI folder had a trailing dash (-)! I had to clear the secure boot keys to allow the USB to boot, but now it worked. Thank you!

Link to comment
  • 5 months later...

I have been trying this all day, following every advice on differrent threads, but I can't seem to boot in legacy mode.


- originally created an UEFI compatible USB and  installed unraid 6.10

- using unraid for 3 months, without a problem

- when trying to boot to unraid OS GUI mode (using external monitor), I get the famous black screen with black cursor

- when passing through a GPU in W10 VM, it doesn't work - famous error 43 or something....


So, naturally  I tried changing the boot from UEFI to Legacy:

- CSM was already enabled in BIOS

- added "-" to EFI folder on the USB - but been getting "not bootable disk" message on startup, no matter if I select the USB as a first boot device, or pressing F11 and manually selecting the USB to boot (not UEFI USB)

- ran "Make bootable.bat" as administrator in Windows - same result on next boot (not bootable disk)

- tried all USB  ports on the motherboard (sadly all usb 3.0) and USB 2.0. front port on the case - same error


- changed back EFI- to EFI, changed primary boot to UEFI USB, boots normally. Went to flash setting in unraid and unticked UEFI support (I know it does the same, but figured there may be something more to it). Same thing (disk not bootable) - either with 1st boot order USB device or hand picked USB boot device from F11. Ran make bootable again - same thing.


I'm slowly loosing it. Renaming the USB folder back from EFI- to EFI and setting UEFI USB as 1st boots device works like a charm.


Any Ideas?

If the USB is corrupted somehow - wouldn't it be corrupted for UEFI boot also? I haven't done any modifications (or backup/restore) to the USB otherwise in between...


Link to comment
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.