Jump to content

Plex (in VM) - Not enough disk space to convert this item


Recommended Posts

Hi Guys


I have an issue with Plex installed in a VM on UnRAID and was wondering if anyone can advise...


I had a 40Gb Ubuntu VM with Plex installed and then shares on my main array for movies, music etc. Usually everything is fine, but today I tried to play a movie and get an error...


Playback Terminated - Not enough disc space to convert this item.


My array has 1.4Tb of free space, confirmed using sudo df -h in an SSH terminal.


The main ubuntu disk showed as 40Gb in size with 19Gb of free space... but I assumed I was reading this wrong, so enlarged the disk to 50Gb in UnRAID and then expanded it in gParted to go from 40Gb to 50Gb. However when I restarted Plex I expected it to be able to play the movie, but still shows the same error!

I tried playing the same movie from my laptop using Plex app and it plays fine :(


The device which is coming up with this error is a ROKU stick - I have tried restarting this too!!


Can anyone offer any ideas how to fix this, or where to start?


Many thanks

Edited by SliMat
Link to comment
  • SliMat changed the title to Plex (in VM) - Not enough disk space to convert this item (solved)

OK - an update...


I tried to update Plex using;


sudo apt-get update && sudo apt-get upgrade


When I tried before increasing the size of the partition I got a "not enough space" error - so, after I increased the disk size to 50Gb and expanded using Gparted, I ran the update again and it worked.


After it completed I tried playing the films which failed before and now they play - so am hoping this cures the problem ;-)

Link to comment
  • SliMat changed the title to Plex (in VM) - Not enough disk space to convert this item

Thanks @JonathanM & @kizer


I always did run it in a docker and cant remember the reason why I changed it to a VM as it was so long ago... I think it might have been because Plex always showed an update was needed and the docker update was really flakey - but not 100% sure now ;-)


This machine is in a datacentre in London - so will remotely create a new Plex docker and see how it goes. Its a shame as its been running really well for ages.


It may take a few days, but I'll try to get it done this week.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...