Jump to content

Cache issues - operator Malfunction

Go to solution Solved by kysdaddy,

Recommended Posts

Hello all,

O am looking for a bit of direction here. I made a major server upgrade over the past week. I upgraded from a dell 710 to a supermicro x10, increased my parity drives to 12tb, my cache pool to 1tb.

The issue was timing or project management.

My goal is to have to parity protected cache pools , a 1 tb pool and a 240gb pool. I want to use the 1 tb for downloads and temp files TDAR and plex. and the 240 for everything else.


My mistake was starting the system with only the 1tb. I think that I have fouled things up. 

I added the second pool yesterday. changed the cache that the shares pointed to and ran mover. Nothing happened it ran for under 10 minutes.


My next mistake (possibly) was that I set the shares to yes, expecting the data to be pulled of "both" pools and moved to the array, and ran mover.

12 hrs later mover is still running, no change in the 1tb  drive it is still showing 1.21gb used and the 240 went from 40mb to 1.06gb used.


I am showing reads and writes but do not think that this is working properly.



diag attached.


Thanks Chas


Link to comment

So If I read this right, my error was changing the assigned cache pool before I change the cache setting to yes. I told mover to look in a share that did not have files for the files.

Unfortunately I do not know the steps to correct this.

Currently mover is running. I have appdata folders on both pools, they have different information in them (not sure how I did that)

Pool# 2 appdata folder reflects dockers that I am currently running (set to auto start)

Pool# 2 only has appdata on it (as of now, mover is running)

pool # 1 is all of the dockers that are installed including ones that are not currently in use.

Pool# 1 has all shares including appdata

Not sure if it is possible to screw this up more than I have already.


Pool # 1





Pool #2







Link to comment
  • Solution

Sorry, I had ran out of patience before your reply (patience with my system, not your communication) 


I think that I know what I was doing wrong, and I hope that I am moving the right way now.


Docker and VMS were running on my system while mover was running, unless I am mistaken that requiered mover to check each and every file to see if it was in use before moving it. I'm not sure if it could or would move it if it was in use but I'm pretty sure that this check would slow down mover.


I ran Mover Stop. Set all of my Shares to the yes: 1tb  which is where the appdata was before I started this fiasco.

I then erased the data in the 250gb share pool, unraid then asked me to format the drives 8^)

I formatted and Unraid recreated the 240gb pool.


Next I stopped docker and my vm, then set both docker and vms to no.

Started mover again.


I think that everything is working right now, if I go to shares and click on compute on my appdata share I see it moving to the array.


Thank you for the assistance, I will update later if all works well, or if not I'll be back asking for help again.






Link to comment
29 minutes ago, kysdaddy said:

unless I am mistaken that requiered mover to check each and every file to see if it was in use before moving it.

It doesn't bother to check, it just fails to move the file the same way anything would. Nothing can move open files.


What you should have done is Disable Docker and VM Manager in Settings before attempting to move these files.


I'm not clear about the rest of your explanation but Diagnostics would help a lot with understanding where you are now and how you have things setup.


Attach diagnostics to your NEXT post in this thread.



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...