Jump to content

How can I restore docker images after reinstalling Unraid

Go to solution Solved by Bob-omb,

Recommended Posts

I recently reinstalled Unraid because I was having some problems. I still have the appdata folder and I have restored it, but now Unraid says the configuration files cannot be found.


I still have a flash backup, but I don't know which file/s I need to restore the configuration file/s for the docker images.


Also, it would be very helpful if we had a guide on how to backup docker images. It was my impression that simply backing up data was enough, but it seems it is not.

Link to comment

Thanks for the instant help @JorgeB Much appreciated!


I am still a beginner Unraider so please help me understand:

  1. Where can I find /config/plugins/dockerMan
  2. What is a custom docker network? I don't remember setting up one. Although I did pass some docker networks to another using --net=container:XYZ


Link to comment

The list of Docker installs is blank, but I have copied the app data content from the backup. What's going on?






I also copied everything under \config\plugins\dockerMan to the flash drive and rebooted.


What am I missing?

Link to comment
12 minutes ago, Bob-omb said:

I am confused. The first article?

Where does it explain that?

First explains how to first recreate the docker image file and then the next section explains how to reinstall docker applications with previous settings.

Link to comment
30 minutes ago, Bob-omb said:

Ok so I tried to go to previous apps, but only some show up. These are the apps I installed from scratch before attempting to restore tye previous docker apps.

Did you restore to the current flash drive the xml templates from the backup of the flash drive you said you have?   they need to be present to get the Apps->Previous Apps to know what to offer.

Link to comment
  • Solution
Posted (edited)

OK, I copied over /config/plugins/dockerMan once again, and I got it to work. Thanks guys!


For future Unraiders the solution was namely to do as jorgeB mentioned, but more specifically:

  1. Copy the contents of the backed-up appdata to the production version of appdata
  2. Copy the contents of config/plugins/dockerMan from your backed-up flash drive to /config/plugins/dockerMan on the production flash drive.
  3. Re-create the docker image file.
  4. Re-install the previous docker applications



Edited by Bob-omb
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...