Jump to content

[PhAzE] Plugins for Unraid 5/6


PhAzE

Recommended Posts

If you can include lxml you will do me and others a big favor!

Thank you for your great work and my condolences for your loss.

How can I test of its installed properly? What app do you need it for and how can you tell it's working?

Link to comment
  • Replies 3.6k
  • Created
  • Last Reply

Ok, I managed to get Python 2.7.10 compiled for both unRAID 5 and 6.  lxml is working on this python. I will be updating openSSL to version 1.0.1o to work with the new python version (this will not override the one installed on the OS, it will run separately and only by my plugins. Plugins have been tested with unRIAD 6 final and seem to all be working as is currently, with a few sub dependencies missing on 4 of them, which I will update as well.

 

I'm hoping to have these updated before the end of next week, so I can then check out that comic streamer. Then update all the v1 plugin users to the v2 plugins.

Link to comment

Ok, I managed to get Python 2.7.10 compiled for both unRAID 5 and 6.  lxml is working on this python. I will be updating openSSL to version 1.0.1o to work with the new python version (this will not override the one installed on the OS, it will run separately and only by my plugins. Plugins have been tested with unRIAD 6 final and seem to all be working as is currently, with a few sub dependencies missing on 4 of them, which I will update as well.

 

I'm hoping to have these updated before the end of next week, so I can then check out that comic streamer. Then update all the v1 plugin users to the v2 plugins.

Awesome news PhAzE!!! :D

Link to comment

Filebot plugin keeps giving me errors. Am I missing something? I just am supposed to be using this from the command line after installing the plugin right? I keep getting errors in my --format string when trying to run command via filebot-cli style. Is there a gui I'm missing maybe or could someone tell me why this command works on filebot-cli on another linux box but not with this plugin:

 

filebot -rename "/mnt/cache/appdata/sabnzbd/config/Downloads/complete" --format "{n.space('.'}.{'s'+s.pad(2)}e{e.pad(2)}.{vf}.{source}.{vc}.{ac}" --db TheTVDB

 

I keep getting back:

 

/bin/bash: -c: line 0: syntax error near unexpected token `('

/bin/bash: -c: line 0: `. /usr/local/PhAzE-Common/Filebot/startcfg.sh; /mnt/cache/appdata/filebot//filebot.sh --format {n.space('.'}.{'s'+s.pad(2)}e{e.pad(2)}.{vf}.{source}.{vc}.{ac} --db TheTVDB'

 

I'm sure this is something wrong on my end, but I can't seem to wrap my head around it...

Late response but...

 

filebot -rename "/mnt/cache/appdata/sabnzbd/config/Downloads/complete" --format "{n.space('.')}.{'s'+s.pad(2)}e{e.pad(2)}.{vf}.{source}.{vc}.{ac}" --db TheTVDB

 

See if you can spot the fix I made in the above code...

 

 

hint, its a missing )

Link to comment

Ok, regarding the BTSync problem where it moves the USB contents somewhere... can someone give me a few answers to the following questions so I can try and track down the root cause:

 

1. Did it move the root directory or just the contents on the USB stick (/boot)?

2. Where did it move it into, the config folder?

3. What steps were taken prior to this happening, starting app? updating app? updating plugin? changing config/install dir location?

 

It's a pain, because first I think it moves the USB files to the ram drive, then when you reboot, all the files are deleted! big no no.

Link to comment

Hey everyone,

 

Looks like I'm not able to get a test vm built with unraid 6.  It requires a trial key to be installed, so when i got one, it expired within 2 minutes one month and 2 minutes (lol). 

 

Anyways, the problem i'm having is i'm unable to assign drives with the trial key. I get a message saying "too many devices attached" but i only have 3 drives and the USB stick.

 

Any suggestions?

 

EDIT: Doing a 'new config' at least lets me assign the drives, but unfortunately, the USB cloned drive I require to get the VM to boot, counts as an attached device so I can't start the array. Closer though.  I thought on unraid, if you assign three drives, and have extra ones attached, it just would ignore then unassigned drives.

 

EDIT 2: Just read that it's a bug that needs addressing. Too many devices attached, unable to start array. Guess plugin production is on hold for now.

 

EDIT 3: I removed the parity drive from the VM, lets me start now. No biggie I guess, I don't actually put anything on this VM but what a pain that an unused drive prevents the array from starting up. I suppose non-array drives now count as 'devices' and the trial lets you have 3 devices hooked up max.

 

PhAzE,

 

Are you using trial because you need to test that end or would another license help you on your efforts?

I am sorry to hear about your loss  :-\

Link to comment

PhAzE thanks for doing these plugins! I am really looking forward to getting some of these working so I can just have one computer running instead of two all the time. Are there any walkthroughs for some of these though? I just did a clean install of unRaid6 and I still can't get Btsync or Sickbeard setup. Oddly enough CouchPotato installed fine and I can access the WebUI for it. Btsync installs and I can see it in the setting menu, but trying to apply settings always fails. I'm at work and can provide logs later, but I mainly wanted to know about any walkthroughs out there, especially ones that detail problems that you might run into. Thanks again, and thanks in advance to anyone that might have an answer.

Link to comment

Btsync is broken at the moment, but I will be updating it soon. They seem to be changing the install URL often.

 

What's the problem you're having with sickbeard?

 

Most of the walkthrough and issues are in the first post of this thread.

Link to comment

Thanks for the update on Btsync. Sickbeard wouldn't install. I tried both versions in the post. Using the url and by copy/pasting and saving the .plg and running the install straight from the that(really nice install update to unRAID6!). Like I said, I'll get logs later. Can I manually input the Btsync in the url, or is it not that simple? Once again thanks for these plugins! Next payday I'll be donating to your beer fund.

Link to comment

Hi Everyone,

 

All plugins have been updated for Unraid 6 final. Here's some changes:

- compiled python 2.7.10 for all python apps unraid 5 and 6

- added openssl 1.0.1o for both unraid versions

- added pyopenssl for all python apps

- fixed nzbmegasearch ssl issues

- btsync updated download url, now working again

- compiled ffmpeg 2.7.1 for both unraid versions

- compiled x265 version 1.7 for use with ffmpeg

- updated Emby icon (note: clear browser cache to see it)

- with updated dependencies comes missing sub-dependencies, which have been fixed also

 

NOTE: after updating all your apps, please reboot to make sure the dependencies work without conflicts!

 

Let me know if you come across any issues after the updates.  If you feel like donating, button to do so is on the first post or in the plugin settings page. Thanks and enjoy!

 

-=PhAzE=-

 

*** I haven't tracked down the Btsync issue where it moves the USB contents to the config directory. Its very rare, but backup your usb before updating that plugin just in case! ***

Link to comment

Btsync and Sickbeard installed and accessible through the WebUI on my end. Thanks!!! Is there anything special I need to do to make them stay on a reboot? Everythings in /boot/config/plugins now. Does anyone know any tips or tricks to getting Btsync working correctly? Right now I have it setup and it sees the server but it hasn't started syncing yet. I just allowed the port in my firewall so I'm waiting to see if that might have been the issue.

Link to comment

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...