Jump to content
dmacias

*DEPRECATED* Apache Web Server for unRAID 6.2

174 posts in this topic Last Reply

Recommended Posts

Got the ssl part running fine, thanks.

 

Now, I seem to be missing something obvious, I tried adding this

<Directory "/mnt/cache/Applications/www/html">
AuthType Basic
AuthName "Username and Password Required"
AuthUserFile /boot/config/plugins/apache/.htpasswd
Require valid-user
</Directory>

to httpd.conf and / or httpd-ssl.conf but it doesn't ask for a login. Yes, I generated a .htpasswd file and put it in the apache folder.

This method will work but the path is should be /srv/httpd/htdocs  The plugin symlinks "Document Root directory" from the webgui settings to /srv/httpd/htdocs.  So I have my Doc Root as /mnt/cache/www. If I have a folder /mnt/cache/www/test then "Directory" should be /srv/httpd/htdocs/test

Share this post


Link to post

Would it be possible to use this to access the unRAID Main page remotely? I attempted to edit the proxied hosts file to access the page as follows but all links and images on the page are broken.

 

<Location /Main>
order deny,allow
deny from all
allow from all
ProxyPass http://192.168.0.102:80
ProxyPassReverse http://192.168.0.102:80
</Location>

 

Thanks for the plugin!

 

Share this post


Link to post

Would it be possible to use this to access the unRAID Main page remotely? I attempted to edit the proxied hosts file to access the page as follows but all links and images on the page are broken.

 

<Location /Main>
order deny,allow
deny from all
allow from all
ProxyPass http://192.168.0.102:80
ProxyPassReverse http://192.168.0.102:80
</Location>

 

Thanks for the plugin!

Something like this will work you have to proxy /plugins to get the images to work.

 <VirtualHost *:80>
ServerName unraid

        ProxyPass / http://192.168.1.1:80/
        ProxyPassReverse / http://192.168.1.1:80/

<Location /Main>
        	ProxyPass http://192.168.1.1:80/Main
        	ProxyPassReverse http://192.168.1.1:80/Main
</Location>
<Location /Shares>
       		ProxyPass http://192.168.1.1:80/Shares
        	ProxyPassReverse http://192.168.1.1:80/Shares
</Location>
<Location /Users>
        	ProxyPass http://192.168.1.1:80/Users
        	ProxyPassReverse http://192.168.1.1:80/Users
</Location>
<Location /Settings>
        	ProxyPass http://192.168.1.1:80/Settings
        	ProxyPassReverse http://192.168.1.1:80/Settings
</Location>
<Location /Utilities>
        	ProxyPass http://192.168.1.1:80/Utilities
        	ProxyPassReverse http://192.168.1.1:80/Utilities
</Location>
<Location /Extensions>
        	ProxyPass http://192.168.1.1:80/Extensions
        	ProxyPassReverse http://192.168.1.1:80/Extensions
</Location>
<Location /plugins>
        	ProxyPass http://192.168.1.1:80/plugins
        	ProxyPassReverse http://192.168.1.1:80/plugins
</Location>
</VirtualHost> 

Share this post


Link to post

Your Apache.plg is broken. It will not install due to some of the changes you made in your github file structure. the plg is still trying to access a 2014.09.24 archive. I tried removing that from the plg with notepad++ and then I started getting errors because it wasnt pointing to the httpd folder correctly. after i fixed those in notepad to the correct path in your github, i started to get this error

 

/tmp/apache-install: line 7: unexpected EOF while looking for matching `"'
/tmp/apache-install: line 33: syntax error: unexpected end of file
plugin: run failed: /bin/bash retval: 2

 

this part is beyond my knowledge as I am a self taught novice.

Share this post


Link to post

Your Apache.plg is broken. It will not install due to some of the changes you made in your github file structure. the plg is still trying to access a 2014.09.24 archive. I tried removing that from the plg with notepad++ and then I started getting errors because it wasnt pointing to the httpd folder correctly. after i fixed those in notepad to the correct path in your github, i started to get this error

 

/tmp/apache-install: line 7: unexpected EOF while looking for matching `"'
/tmp/apache-install: line 33: syntax error: unexpected end of file
plugin: run failed: /bin/bash retval: 2

 

this part is beyond my knowledge as I am a self taught novice.

Yeah I know you caught me in the middle of updating everything.  I  was having trouble creating tags from my github program. I wasn't done yet. I'll fix it in a bit.

Share this post


Link to post

HaHa! Figures that happens when Im running maintenance myself.  :P

 

I was having issues getting virtualbox to work correctly with your plugin though. I could get to the PHP virtualbox login page, but the username and password admin/admin was coming back invalid. Still trying to figure that one out. Rebooted my server and it threw the apache_64.plg in the broken folder.

Share this post


Link to post

HaHa! Figures that happens when Im running maintenance myself.  :P

 

I was having issues getting virtualbox to work correctly with your plugin though. I could get to the PHP virtualbox login page, but the username and password admin/admin was coming back invalid. Still trying to figure that one out. Rebooted my server and it threw the apache_64.plg in the broken folder.

I finished updating it to the new plugin format and put new instructions on the first page.  I did change the location of the apache config files to /boot/config/plugins/apache/httpd. But basically I would remove the old plg and reboot then copy this link and paste in the Install Extension form in the Extensions menu of the unRAID webgui. Then click install.

https://raw.githubusercontent.com/dmacias72/apache/master/apache.plg

I will try virtual box when I get a chance and see if I can figure it out.  It's been a while since I tried it.

Share this post


Link to post

Got it up and running with your new plg. had to run "chgrp nobody /var/lib/php" after I had everything setup to get past the invalid username/pass error. but I am at the VBGui now.

Share this post


Link to post

Got it up and running with your new plg. had to run "chgrp nobody /var/lib/php" after I had everything setup to get past the invalid username/pass error. but I am at the VBGui now.

I installed vb but couldn't recreate the problem but saw in the vb thread someone else had it. You could change the

session.save_path = "/var/lib/php" in /boot/config/plugins/apache/httpd/php.ini to "/tmp" and see if that works too.  I saw another post about putting it in config.php for phpvirtualbox.

 

Also the update function was broken on the apache.plg  But is fixed now.  If you want to update you'll have to remove then reinstall it.

Share this post


Link to post

Any chance of an updated v6b12 version?

Sure I'll fix it for 12.

 

They changed the exec.php so it's an easy fix.

Share this post


Link to post

:)

I forgot to remove the css file so I updated one last time. It will look nicer.

Share this post


Link to post

:)

I forgot to remove the css file so I updated one last time. It will look nicer.

 

I uninstalled everything and then re-installed. Rolled back to v6b10a and the settings where fine. Went back to v6b12, Vbox was fine, the settings the same but nothing displays. Any ideas?

Share this post


Link to post

Where does nothing display? In the plugin settings?

 

Edit: I would try removing then reinstalling the plugin if that's the problem.

Share this post


Link to post

Where does nothing display? In the plugin settings?

 

Edit: I would try removing then reinstalling the plugin if that's the problem.

 

Grey rows appear but now columns or content. Don't even get any error codes.

 

Will investigate further today.

 

Thanks for the reply.

Share this post


Link to post

Where does nothing display? In the plugin settings?

 

Edit: I would try removing then reinstalling the plugin if that's the problem.

 

Grey rows appear but now columns or content. Don't even get any error codes.

 

Will investigate further today.

 

Thanks for the reply.

Are you on 10 or 12 now? I just removed the plugin and renamed /boot/config/plugin/apache to apache.old Then reinstalled and all is fine on my end.

 

Share this post


Link to post

Where does nothing display? In the plugin settings?

 

Edit: I would try removing then reinstalling the plugin if that's the problem.

 

Grey rows appear but now columns or content. Don't even get any error codes.

 

Will investigate further today.

 

Thanks for the reply.

Are you on 10 or 12 now? I just removed the plugin and renamed /boot/config/plugin/apache to apache.old Then reinstalled and all is fine I my end.

 

I am on 12, no settings have changed between the updates so not sure whats going on. I will dig around and get back to you with the results.

 

Thanks for the response.

Share this post


Link to post

Never been able to get this to work for me. Just tried again since it was updated, still no go.

Apr 19 06:58:23 unSERVER php: /etc/rc.d/rc.apache start 
Apr 19 06:58:23 unSERVER php: Starting Apache Web Server: sudo apachectl -k start -c Listen 8088 -c User nobody
Apr 19 06:58:24 unSERVER sudo: root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=root ; COMMAND=/usr/sbin/apachectl -k start -c Listen 8088 -c ServerName unSERVER -c User nobody -c Group users
Apr 19 06:58:35 unSERVER php: 1234567891011Apache httpd.pid not created for some reason... OK

syslog_2.zip

Share this post


Link to post

Never been able to get this to work for me. Just tried again since it was updated, still no go.

Apr 19 06:58:23 unSERVER php: /etc/rc.d/rc.apache start 
Apr 19 06:58:23 unSERVER php: Starting Apache Web Server: sudo apachectl -k start -c Listen 8088 -c User nobody
Apr 19 06:58:24 unSERVER sudo: root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=root ; COMMAND=/usr/sbin/apachectl -k start -c Listen 8088 -c ServerName unSERVER -c User nobody -c Group users
Apr 19 06:58:35 unSERVER php: 1234567891011Apache httpd.pid not created for some reason... OK

Did try with just the default settings? What does /var/log/httpd/error_log say?

Share this post


Link to post

Never been able to get this to work for me. Just tried again since it was updated, still no go.

Apr 19 06:58:23 unSERVER php: /etc/rc.d/rc.apache start 
Apr 19 06:58:23 unSERVER php: Starting Apache Web Server: sudo apachectl -k start -c Listen 8088 -c User nobody
Apr 19 06:58:24 unSERVER sudo: root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=root ; COMMAND=/usr/sbin/apachectl -k start -c Listen 8088 -c ServerName unSERVER -c User nobody -c Group users
Apr 19 06:58:35 unSERVER php: 1234567891011Apache httpd.pid not created for some reason... OK

Did try with just the default settings? What does /var/log/httpd/error_log say?

The only thing I had changed from defaults was setting Document root directory to /mnt/cache/appdata/web, where I have index.html which was created from exporting my Chrome bookmarks.

 

Just tried it again with leaving that at /var/www/html and no difference. Still httpd.pid not created.

 

In both scenarios, the folder /var/log/httpd exists but there is nothing in it.

Share this post


Link to post

Never been able to get this to work for me. Just tried again since it was updated, still no go.

Apr 19 06:58:23 unSERVER php: /etc/rc.d/rc.apache start 
Apr 19 06:58:23 unSERVER php: Starting Apache Web Server: sudo apachectl -k start -c Listen 8088 -c User nobody
Apr 19 06:58:24 unSERVER sudo: root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=root ; COMMAND=/usr/sbin/apachectl -k start -c Listen 8088 -c ServerName unSERVER -c User nobody -c Group users
Apr 19 06:58:35 unSERVER php: 1234567891011Apache httpd.pid not created for some reason... OK

Did try with just the default settings? What does /var/log/httpd/error_log say?

The only thing I had changed from defaults was setting Document root directory to /mnt/cache/appdata/web, where I have index.html which was created from exporting my Chrome bookmarks.

 

Just tried it again with leaving that at /var/www/html and no difference. Still httpd.pid not created.

 

In both scenarios, the folder /var/log/httpd exists but there is nothing in it.

What's the output of ls -la /var/log/httpd? Try sudo chmod -R 755 /var/log/httpd.

Share this post


Link to post

Never been able to get this to work for me. Just tried again since it was updated, still no go.

Apr 19 06:58:23 unSERVER php: /etc/rc.d/rc.apache start 
Apr 19 06:58:23 unSERVER php: Starting Apache Web Server: sudo apachectl -k start -c Listen 8088 -c User nobody
Apr 19 06:58:24 unSERVER sudo: root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=root ; COMMAND=/usr/sbin/apachectl -k start -c Listen 8088 -c ServerName unSERVER -c User nobody -c Group users
Apr 19 06:58:35 unSERVER php: 1234567891011Apache httpd.pid not created for some reason... OK

Did try with just the default settings? What does /var/log/httpd/error_log say?

The only thing I had changed from defaults was setting Document root directory to /mnt/cache/appdata/web, where I have index.html which was created from exporting my Chrome bookmarks.

 

Just tried it again with leaving that at /var/www/html and no difference. Still httpd.pid not created.

 

In both scenarios, the folder /var/log/httpd exists but there is nothing in it.

What's the output of ls -la /var/log/httpd? Try sudo chmod -R 755 /var/log/httpd.

Empty as I said

root@unSERVER:~# ls -la /var/log/httpd
total 0
drwxr-xr-x  2 root root  40 Apr 18 01:04 ./
drwxr-xr-x 14 root root 660 Apr 19 04:40 ../

After chmod and trying to start apache again, same result, no pid, no log

root@unSERVER:~# sudo chmod -R 755 /var/log/httpd

Apr 19 10:47:54 unSERVER php: /etc/rc.d/rc.apache start 
Apr 19 10:47:54 unSERVER php: Starting Apache Web Server: sudo apachectl -k start -c Listen 8088 -c User nobody
Apr 19 10:47:55 unSERVER sudo: root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=root ; COMMAND=/usr/sbin/apachectl -k start -c Listen 8088 -c ServerName unSERVER -c User nobody -c Group users
Apr 19 10:48:06 unSERVER php: 1234567891011Apache httpd.pid not created for some reason... OK

root@unSERVER:~# ls -la /var/log/httpd
total 0
drwxr-xr-x  2 root root  40 Apr 18 01:04 ./
drwxr-xr-x 14 root root 660 Apr 19 04:40 ../

 

Also, nothing else on 8088

root@unSERVER:~# netstat -lptu | grep 6789
tcp        0      0 *:6789                  *:*                     LISTEN      30421/docker-proxy
root@unSERVER:~# netstat -lptu | grep 8088
root@unSERVER:~#

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.