Jump to content
dmacias

*DEPRECATED* Apache Web Server for unRAID 6.2

174 posts in this topic Last Reply

Recommended Posts

Hi, I'm on B14 and when I try to run the plg file I get this:

 

plugin: installing: https://raw.githubusercontent.com/dmacias72/apache/master/apache.plg

plugin: downloading https://raw.githubusercontent.com/dmacias72/apache/master/apache.plg

plugin: downloading: /tmp/plugins/apache.plg ... done

 

Warning: simplexml_load_file(): /tmp/plugins/apache.plg:1: parser error : Document is empty in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 191

 

Warning: simplexml_load_file(): in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 191

 

Warning: simplexml_load_file(): ^ in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 191

 

Warning: simplexml_load_file(): /tmp/plugins/apache.plg:1: parser error : Start tag expected, '<' not found in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 191

 

Warning: simplexml_load_file(): in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 191

 

Warning: simplexml_load_file(): ^ in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 191

plugin: xml parse error

 

I had it instaled on b14, but it would just load to a blank screen.  I tried b15 just to see if it had any fix that would help.

 

Thanks

Share this post


Link to post

Hi, I'm on B14 and when I try to run the plg file I get this:

 

plugin: installing: https://raw.githubusercontent.com/dmacias72/apache/master/apache.plg

plugin: downloading https://raw.githubusercontent.com/dmacias72/apache/master/apache.plg

plugin: downloading: /tmp/plugins/apache.plg ... done

 

Warning: simplexml_load_file(): /tmp/plugins/apache.plg:1: parser error : Document is empty in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 191

 

Warning: simplexml_load_file(): in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 191

 

Warning: simplexml_load_file(): ^ in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 191

 

Warning: simplexml_load_file(): /tmp/plugins/apache.plg:1: parser error : Start tag expected, '<' not found in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 191

 

Warning: simplexml_load_file(): in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 191

 

Warning: simplexml_load_file(): ^ in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 191

plugin: xml parse error

 

I had it instaled on b14, but it would just load to a blank screen.  I tried b15 just to see if it had any fix that would help.

 

Thanks

This is typical of a bad download. Did you download the plugin yourself? This is not the correct way to install a v6 plugin. You don't download the plg yourself and run it.  See first post

Share this post


Link to post

Hi, I'm on B14 and when I try to run the plg file I get this:

 

plugin: installing: https://raw.githubusercontent.com/dmacias72/apache/master/apache.plg

plugin: downloading https://raw.githubusercontent.com/dmacias72/apache/master/apache.plg

plugin: downloading: /tmp/plugins/apache.plg ... done

 

Warning: simplexml_load_file(): /tmp/plugins/apache.plg:1: parser error : Document is empty in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 191

 

Warning: simplexml_load_file(): in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 191

 

Warning: simplexml_load_file(): ^ in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 191

 

Warning: simplexml_load_file(): /tmp/plugins/apache.plg:1: parser error : Start tag expected, '<' not found in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 191

 

Warning: simplexml_load_file(): in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 191

 

Warning: simplexml_load_file(): ^ in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 191

plugin: xml parse error

 

I had it instaled on b14, but it would just load to a blank screen.  I tried b15 just to see if it had any fix that would help.

 

Thanks

Like trurl said. Bad download.  Try pasting

https://raw.githubusercontent.com/dmacias72/apache/master/apache.plg

into install plugin section again. You might check your flash drive in a Windows machine too.

Share this post


Link to post

Never been able to get this to work for me. Just tried again since it was updated, still no go.

Apr 19 06:58:23 unSERVER php: /etc/rc.d/rc.apache start 
Apr 19 06:58:23 unSERVER php: Starting Apache Web Server: sudo apachectl -k start -c Listen 8088 -c User nobody
Apr 19 06:58:24 unSERVER sudo: root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=root ; COMMAND=/usr/sbin/apachectl -k start -c Listen 8088 -c ServerName unSERVER -c User nobody -c Group users
Apr 19 06:58:35 unSERVER php: 1234567891011Apache httpd.pid not created for some reason... OK

Did try with just the default settings? What does /var/log/httpd/error_log say?

The only thing I had changed from defaults was setting Document root directory to /mnt/cache/appdata/web, where I have index.html which was created from exporting my Chrome bookmarks.

 

Just tried it again with leaving that at /var/www/html and no difference. Still httpd.pid not created.

 

In both scenarios, the folder /var/log/httpd exists but there is nothing in it.

What's the output of ls -la /var/log/httpd? Try sudo chmod -R 755 /var/log/httpd.

Empty as I said

root@unSERVER:~# ls -la /var/log/httpd
total 0
drwxr-xr-x  2 root root  40 Apr 18 01:04 ./
drwxr-xr-x 14 root root 660 Apr 19 04:40 ../

After chmod and trying to start apache again, same result, no pid, no log

root@unSERVER:~# sudo chmod -R 755 /var/log/httpd

Apr 19 10:47:54 unSERVER php: /etc/rc.d/rc.apache start 
Apr 19 10:47:54 unSERVER php: Starting Apache Web Server: sudo apachectl -k start -c Listen 8088 -c User nobody
Apr 19 10:47:55 unSERVER sudo: root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=root ; COMMAND=/usr/sbin/apachectl -k start -c Listen 8088 -c ServerName unSERVER -c User nobody -c Group users
Apr 19 10:48:06 unSERVER php: 1234567891011Apache httpd.pid not created for some reason... OK

root@unSERVER:~# ls -la /var/log/httpd
total 0
drwxr-xr-x  2 root root  40 Apr 18 01:04 ./
drwxr-xr-x 14 root root 660 Apr 19 04:40 ../

 

Also, nothing else on 8088

root@unSERVER:~# netstat -lptu | grep 6789
tcp        0      0 *:6789                  *:*                     LISTEN      30421/docker-proxy
root@unSERVER:~# netstat -lptu | grep 8088
root@unSERVER:~#

Here's the command for starting. Try that, maybe the console will give some clues.

sudo apachectl -k start -c "Listen 8088" -c "ServerName unSERVER" -c "User nobody" -c "Group users"

Change start to stop to kill it if it works.

Share this post


Link to post

Never been able to get this to work for me. Just tried again since it was updated, still no go.

Apr 19 06:58:23 unSERVER php: /etc/rc.d/rc.apache start 
Apr 19 06:58:23 unSERVER php: Starting Apache Web Server: sudo apachectl -k start -c Listen 8088 -c User nobody
Apr 19 06:58:24 unSERVER sudo: root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=root ; COMMAND=/usr/sbin/apachectl -k start -c Listen 8088 -c ServerName unSERVER -c User nobody -c Group users
Apr 19 06:58:35 unSERVER php: 1234567891011Apache httpd.pid not created for some reason... OK

Did try with just the default settings? What does /var/log/httpd/error_log say?

The only thing I had changed from defaults was setting Document root directory to /mnt/cache/appdata/web, where I have index.html which was created from exporting my Chrome bookmarks.

 

Just tried it again with leaving that at /var/www/html and no difference. Still httpd.pid not created.

 

In both scenarios, the folder /var/log/httpd exists but there is nothing in it.

What's the output of ls -la /var/log/httpd? Try sudo chmod -R 755 /var/log/httpd.

Empty as I said

root@unSERVER:~# ls -la /var/log/httpd
total 0
drwxr-xr-x  2 root root  40 Apr 18 01:04 ./
drwxr-xr-x 14 root root 660 Apr 19 04:40 ../

After chmod and trying to start apache again, same result, no pid, no log

root@unSERVER:~# sudo chmod -R 755 /var/log/httpd

Apr 19 10:47:54 unSERVER php: /etc/rc.d/rc.apache start 
Apr 19 10:47:54 unSERVER php: Starting Apache Web Server: sudo apachectl -k start -c Listen 8088 -c User nobody
Apr 19 10:47:55 unSERVER sudo: root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=root ; COMMAND=/usr/sbin/apachectl -k start -c Listen 8088 -c ServerName unSERVER -c User nobody -c Group users
Apr 19 10:48:06 unSERVER php: 1234567891011Apache httpd.pid not created for some reason... OK

root@unSERVER:~# ls -la /var/log/httpd
total 0
drwxr-xr-x  2 root root  40 Apr 18 01:04 ./
drwxr-xr-x 14 root root 660 Apr 19 04:40 ../

 

Also, nothing else on 8088

root@unSERVER:~# netstat -lptu | grep 6789
tcp        0      0 *:6789                  *:*                     LISTEN      30421/docker-proxy
root@unSERVER:~# netstat -lptu | grep 8088
root@unSERVER:~#

Here's the command for starting. Try that, maybe the console will give some clues.

sudo apachectl -k start -c "Listen 8088" -c "ServerName unSERVER" -c "User nobody" -c "Group users"

Change start to stop to kill it if it works.

root@unSERVER:~# sudo apachectl -k start -c "Listen 8088" -c "ServerName unSERVER" -c "User nobody" -c "Group users"
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:8088
no listening sockets available, shutting down
AH00015: Unable to open logs

In fact, if I do the netstat like this

root@unSERVER:~# netstat -lptun | grep 8088
tcp        0      0 0.0.0.0:8088            0.0.0.0:*               LISTEN      1487/inetd

but I don't know how inetd is getting launched if not from apache. Just double-checked and none of my dockers are on that port, and that is not the way docker would be reported as seen from my earlier netstat for port 6789 (NZBget)

Share this post


Link to post

Never been able to get this to work for me. Just tried again since it was updated, still no go.

Apr 19 06:58:23 unSERVER php: /etc/rc.d/rc.apache start 
Apr 19 06:58:23 unSERVER php: Starting Apache Web Server: sudo apachectl -k start -c Listen 8088 -c User nobody
Apr 19 06:58:24 unSERVER sudo: root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=root ; COMMAND=/usr/sbin/apachectl -k start -c Listen 8088 -c ServerName unSERVER -c User nobody -c Group users
Apr 19 06:58:35 unSERVER php: 1234567891011Apache httpd.pid not created for some reason... OK

Did try with just the default settings? What does /var/log/httpd/error_log say?

The only thing I had changed from defaults was setting Document root directory to /mnt/cache/appdata/web, where I have index.html which was created from exporting my Chrome bookmarks.

 

Just tried it again with leaving that at /var/www/html and no difference. Still httpd.pid not created.

 

In both scenarios, the folder /var/log/httpd exists but there is nothing in it.

What's the output of ls -la /var/log/httpd? Try sudo chmod -R 755 /var/log/httpd.

Empty as I said

root@unSERVER:~# ls -la /var/log/httpd
total 0
drwxr-xr-x  2 root root  40 Apr 18 01:04 ./
drwxr-xr-x 14 root root 660 Apr 19 04:40 ../

After chmod and trying to start apache again, same result, no pid, no log

root@unSERVER:~# sudo chmod -R 755 /var/log/httpd

Apr 19 10:47:54 unSERVER php: /etc/rc.d/rc.apache start 
Apr 19 10:47:54 unSERVER php: Starting Apache Web Server: sudo apachectl -k start -c Listen 8088 -c User nobody
Apr 19 10:47:55 unSERVER sudo: root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=root ; COMMAND=/usr/sbin/apachectl -k start -c Listen 8088 -c ServerName unSERVER -c User nobody -c Group users
Apr 19 10:48:06 unSERVER php: 1234567891011Apache httpd.pid not created for some reason... OK

root@unSERVER:~# ls -la /var/log/httpd
total 0
drwxr-xr-x  2 root root  40 Apr 18 01:04 ./
drwxr-xr-x 14 root root 660 Apr 19 04:40 ../

 

Also, nothing else on 8088

root@unSERVER:~# netstat -lptu | grep 6789
tcp        0      0 *:6789                  *:*                     LISTEN      30421/docker-proxy
root@unSERVER:~# netstat -lptu | grep 8088
root@unSERVER:~#

Here's the command for starting. Try that, maybe the console will give some clues.

sudo apachectl -k start -c "Listen 8088" -c "ServerName unSERVER" -c "User nobody" -c "Group users"

Change start to stop to kill it if it works.

root@unSERVER:~# sudo apachectl -k start -c "Listen 8088" -c "ServerName unSERVER" -c "User nobody" -c "Group users"
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:8088
no listening sockets available, shutting down
AH00015: Unable to open logs

In fact, if I do the netstat like this

root@unSERVER:~# netstat -lptun | grep 8088
tcp        0      0 0.0.0.0:8088            0.0.0.0:*               LISTEN      1487/inetd

but I don't know how inetd is getting launched if not from apache. Just double-checked and none of my dockers are on that port, and that is not the way docker would be reported as seen from my earlier netstat for port 6789 (NZBget)

Try killall httpd

Share this post


Link to post

root@unSERVER:~# sudo apachectl -k start -c "Listen 8088" -c "ServerName unSERVER" -c "User nobody" -c "Group users"
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:8088
no listening sockets available, shutting down
AH00015: Unable to open logs

In fact, if I do the netstat like this

root@unSERVER:~# netstat -lptun | grep 8088
tcp        0      0 0.0.0.0:8088            0.0.0.0:*               LISTEN      1487/inetd

but I don't know how inetd is getting launched if not from apache. Just double-checked and none of my dockers are on that port, and that is not the way docker would be reported as seen from my earlier netstat for port 6789 (NZBget)

Try killall httpd

root@unSERVER:~# killall httpd
httpd: no process found
root@unSERVER:~#

The netstat was for inetd, not httpd. Should I try to kill that instead?

Share this post


Link to post

root@unSERVER:~# sudo apachectl -k start -c "Listen 8088" -c "ServerName unSERVER" -c "User nobody" -c "Group users"
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:8088
no listening sockets available, shutting down
AH00015: Unable to open logs

In fact, if I do the netstat like this

root@unSERVER:~# netstat -lptun | grep 8088
tcp        0      0 0.0.0.0:8088            0.0.0.0:*               LISTEN      1487/inetd

but I don't know how inetd is getting launched if not from apache. Just double-checked and none of my dockers are on that port, and that is not the way docker would be reported as seen from my earlier netstat for port 6789 (NZBget)

Try killall httpd

root@unSERVER:~# killall httpd
httpd: no process found
root@unSERVER:~#

The netstat was for inetd, not httpd. Should I try to kill that instead?

No just was making sure no httpd was running.  If I netstat and grep inetd, I get port 21, 23 and 37. Not sure what's running on your 8088.  apachectl just runs 4 httpd processes. But you should just be able to change the port and it will work.

Share this post


Link to post

Switched to port 88 and it works! Still have no idea what inetd is doing on 8088.

 

Thanks

 

edit

Just had a look at /etc/inetd.conf. It has only 1 line in it that is uncommented, for time. Unpacking bzroot, this file is quite a bit longer, and has several other lines uncommented, including 2 for time, ftp, telnet. So something is apparently modifying this file but I don't know what or why.

 

Searching syslog for inet turned up several matches but nothing obvious.

 

About the only thing that might make sense is unMenu is doing this, or possibly a plugin. Maybe I will try to get to the bottom of this. In the meantime, if anyone knows what inetd is doing...

Share this post


Link to post

Switched to port 88 and it works! Still have no idea what inetd is doing on 8088.

 

Thanks

You might check /etc/inetd.conf but glad it's working. I'll try and add some error logging for the start command in the system log.

Share this post


Link to post

Thanks for the advice.  I ended up having to download the PLG file as just giving the URL doesn't seem to want.

 

However now I'm having an issue with the MD5's of some of the files.  I know that it has happened for a few of the txz similar to whats below. I had tried to manually download them and placing them into the /boot/packages directory, but then it seems to run into issue with other things.

 

plugin: installing: /boot/config/plugins/apache.plg

plugin: downloading: /boot/packages/apr-1.5.0-x86_64-1_slack14.1.txz ... done

plugin: bad file MD5: /boot/packages/apr-1.5.0-x86_64-1_slack14.1.txz

Share this post


Link to post

Thanks for the advice.  I ended up having to download the PLG file as just giving the URL doesn't seem to want.

 

However now I'm having an issue with the MD5's of some of the files.  I know that it has happened for a few of the txz similar to whats below. I had tried to manually download them and placing them into the /boot/packages directory, but then it seems to run into issue with other things.

 

plugin: installing: /boot/config/plugins/apache.plg

plugin: downloading: /boot/packages/apr-1.5.0-x86_64-1_slack14.1.txz ... done

plugin: bad file MD5: /boot/packages/apr-1.5.0-x86_64-1_slack14.1.txz

Did you try checking your flash drive on a Windows machine? You could post your system log. You are getting write errors to your flash drive or somehow the files are being corrupted.

Share this post


Link to post

I checked the USB and it seems to be fine.  No errors or any other problems with it. 

 

Reviewing the syslog, nothing seems to really be there, but here's a copy.  I had just tried to do it but nothing is really showing.

syslog.txt

Share this post


Link to post

Added fix for phpvirtualbox

"For installs prior to 2015.04.21 you need to change "short_open_tag" to "On" in /boot/config/plugins/apache/httpd php.ini in order for phpvirtualbox, phpMyAdmin and others that use php short cut codes <? code ?> instead of full <?php code ?> to work."

 

or delete the apache php.ini and reinstall the plugin.

Share this post


Link to post

Hi

 

I need help and more details explainations on how to active SSL on this Apache Plugins, it working perfectly for now at "standard mode"

also I would like to know how to active or access to phpmyadmin

 

Thanks :)

Share this post


Link to post

Hi

 

I need help and more details explainations on how to active SSL on this Apache Plugins, it working perfectly for now at "standard mode"

also I would like to know how to active or access to phpmyadmin

 

Thanks :)

For phpMyAdmin on your flash drive in /config/plugins/apache/httpd edit php.ini and "change short_open_tag = On". For ssl edit httpd.conf and uncomment "Include /etc/httpd/httpd-ssl.conf" then edit  the httpd-ssl.conf to fit your needs. Like servername and port.  There is also a script cert.sh you need to run in /boot/config/plugins/apache to create server.crt.  That should get you started.  I'll see if there's more to it.

Share this post


Link to post

So its been a while and Im rusty with this stuff. I have apache working (tower:8088) showing IT WORKS!, but I dont remember how to link virtualbox to apache to show the virtualbox webgui. Help?

Share this post


Link to post

You need to download phpvirtualbox and extract it to your apache document root directory. Then rename the config.php-example to config.php edit as needed.

 

I have that. I have all my files from v6b5 or whatever when I had it working. I just updated the plugin to the current working version. all my paths are pointing to the right places, so I didnt think I would need to edit anything. Did updating the plugin and Vbox version overwrite the config.php? it looks like its pointing to 127.0.0.1:18083 isnt that where the default location is?

Share this post


Link to post

 

 

You need to download phpvirtualbox and extract it to your apache document root directory. Then rename the config.php-example to config.php edit as needed.

 

I have that. I have all my files from v6b5 or whatever when I had it working. I just updated the plugin to the current working version. all my paths are pointing to the right places, so I didnt think I would need to edit anything. Did updating the plugin and Vbox version overwrite the config.php? it looks like its pointing to 127.0.0.1:18083 isnt that where the default location is?

 

Oh ok. Nothing should get overwritten. Do you get anything when you go to the phpvirtualbox webpage? You may have an older php.ini that needs editing (see first post or a few back). Also what version phpvirtualbox? Try the latest.

Share this post


Link to post

 

 

You need to download phpvirtualbox and extract it to your apache document root directory. Then rename the config.php-example to config.php edit as needed.

 

I have that. I have all my files from v6b5 or whatever when I had it working. I just updated the plugin to the current working version. all my paths are pointing to the right places, so I didnt think I would need to edit anything. Did updating the plugin and Vbox version overwrite the config.php? it looks like its pointing to 127.0.0.1:18083 isnt that where the default location is?

 

Oh ok. Nothing should get overwritten. Do you get anything when you go to the phpvirtualbox webpage? You may have an older php.ini that needs editing (see first post or a few back). Also what version phpvirtualbox? Try the latest.

 

I have the latest apache and virtualbox plugins. just updated 10min ago. fired up the bookmark I had for phpvirtualbox and now istead of a blank page im getting the IT WORKS! from Apache. If I use the link you gave me, witch is the same as my bookmark except that yours had the extra "\phpvirtualbox" in the url.  I get "Not Found The requested URL /phpvirtualbox was not found on this server." looks like the modify date of the config.php is from 2012 even though I have edited it more recently then that. Is it that the phpvirtualbox files are outdated for the new plugin?

Share this post


Link to post

It works! is the default apache index.html.  Either the document root is pointed to the wrong directory or phpvirtualbox isn't in the right place. There should be a phpvirtualbox directory in the document root directory from the apache plugin.

 

Share this post


Link to post

Ok you must have phpvirtualbox in the route of your web server and the index.html was overwritten. Just copy the phpvbox index.html I'll check if the plugin overwrites that for some reason.

Share this post


Link to post

It works! is the default apache index.html.  Either the document root is pointed to the wrong directory or phpvirtualbox isn't in the right place. There should be a phpvirtualbox directory in the document root directory from the apache plugin.

 

as far as I can tell I have everything in the right place. I havent moved anything or changed DIRs since I had it working before.

 

link

http://imgur.com/a/OVK8o

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.