Jump to content
dmacias

*DEPRECATED* Apache Web Server for unRAID 6.2

174 posts in this topic Last Reply

Recommended Posts

Updated for 6.1

 

Have you tested it on 6.0.1? - I had to run the "start" script from command line after reboot in order to get phpvirtualbox working.

No I didn't. Is there anything in the logs that's suggests why it didn't start? It should run the /usr/local/emhttp/plugins/apache/scripts/start script on disks_mounted.  I thought the only thing that would be broke was the file tree for docroot and the httpd logs. There's also a newer version of php extensions since 6.1rc6 is on a newer version. I could post the plg file for the previous 6.01 version or it's in my github.

 

From the log file:

Aug 30 21:20:41 Tower php: /plugins/apache/scripts/stop
Aug 30 21:20:55 Tower php: /plugins/apache/scripts/start
Aug 30 21:21:05 Tower emhttp: /usr/bin/tail -n 42 -f /var/log/syslog 2>&1
Aug 30 21:21:34 Tower php: /plugins/apache/scripts/stop
Aug 30 21:21:53 Tower php: /plugins/apache/scripts/start
Aug 30 21:21:57 Tower emhttp: /usr/bin/tail -n 42 -f /var/log/syslog 2>&1

 

The plugin didn't start and also didn't stop but indicated that it was running.

I update the POST with the full path.  That should fix the start and stop problem but given the changes in the plugin and 6.1rc some things may be broke for earlier 6.01.  I'll include the 2015-06-13 plg file in the first post and you can install that version for pre 6.1.

Share this post


Link to post

I'm on unRAID 6.1.3 and the plugin is not working for me. It installs fine, but whenever I try to start the service it fails.

Error Message in log is:

Oct 8 22:09:28 lafiel apache: nohup: failed to run command 'apachectl': No such file or directory

Share this post


Link to post

What happens if you try running apachectl from the command line? Maybe bad httpd package? I would try removing the plugin and reinstalling. Also I just installed from scratch and it works for me on 6.1.3

Share this post


Link to post

I just upgraded unRAID to 6.2 and get the following error in the syslog when trying to run the web server:

 

apache: /usr/sbin/httpd: error while loading shared libraries: libsasl2.so.2: cannot open shared object file: No such file or directory

 

I know this plugin is not supported any more, but can someone please help?

 

Share this post


Link to post

I just upgraded unRAID to 6.2 and get the following error in the syslog when trying to run the web server:

 

apache: /usr/sbin/httpd: error while loading shared libraries: libsasl2.so.2: cannot open shared object file: No such file or directory

 

I know this plugin is not supported any more, but can someone please help?

I'll see if I can get it working now that stable is released.

Share this post


Link to post

I just upgraded unRAID to 6.2 and get the following error in the syslog when trying to run the web server:

 

apache: /usr/sbin/httpd: error while loading shared libraries: libsasl2.so.2: cannot open shared object file: No such file or directory

 

I know this plugin is not supported any more, but can someone please help?

 

I updated the plugin for 6.2 and the OP. Let me know if it works.  You'll need to remove the old plugin and install from the new link below.

https://raw.githubusercontent.com/dmacias72/unRAID-plugins/master/plugins/apache.plg

Share this post


Link to post

I just upgraded unRAID to 6.2 and get the following error in the syslog when trying to run the web server:

 

apache: /usr/sbin/httpd: error while loading shared libraries: libsasl2.so.2: cannot open shared object file: No such file or directory

 

I know this plugin is not supported any more, but can someone please help?

 

I updated the plugin for 6.2 and the OP. Let me know if it works.  You'll need to remove the old plugin and install from the new link below.

https://raw.githubusercontent.com/dmacias72/unRAID-plugins/master/plugins/apache.plg

 

Installed and there is still an ERROR but it seems on a different file:

apache: /usr/sbin/httpd: error while loading shared libraries: libaprutil-1.so.0: cannot open shared object file: No such file or directory

 

Share this post


Link to post

I just upgraded unRAID to 6.2 and get the following error in the syslog when trying to run the web server:

 

apache: /usr/sbin/httpd: error while loading shared libraries: libsasl2.so.2: cannot open shared object file: No such file or directory

 

I know this plugin is not supported any more, but can someone please help?

 

I updated the plugin for 6.2 and the OP. Let me know if it works.  You'll need to remove the old plugin and install from the new link below.

https://raw.githubusercontent.com/dmacias72/unRAID-plugins/master/plugins/apache.plg

 

Installed and there is still an ERROR but it seems on a different file:

apache: /usr/sbin/httpd: error while loading shared libraries: libaprutil-1.so.0: cannot open shared object file: No such file or directory

 

Sounds like apr-util isn't installed or a previous version overwrote it. Try these

ls -l /var/log/packages/ | grep apr
ls -l /boot/config/plugins/NerdPack/packages/6.2/ | grep apr

Edit: I put all the packages in /boot/config/plugins/apache except the 2 apr packages. I use the ones from the NerdPack repo. Even if you don't use that plugin I place them at that location.

Share this post


Link to post

I just upgraded unRAID to 6.2 and get the following error in the syslog when trying to run the web server:

 

apache: /usr/sbin/httpd: error while loading shared libraries: libsasl2.so.2: cannot open shared object file: No such file or directory

 

I know this plugin is not supported any more, but can someone please help?

 

I updated the plugin for 6.2 and the OP. Let me know if it works.  You'll need to remove the old plugin and install from the new link below.

https://raw.githubusercontent.com/dmacias72/unRAID-plugins/master/plugins/apache.plg

 

Installed and there is still an ERROR but it seems on a different file:

apache: /usr/sbin/httpd: error while loading shared libraries: libaprutil-1.so.0: cannot open shared object file: No such file or directory

 

Sounds like apr-util isn't installed or a previous version overwrote it. Try these

ls -l /var/log/packages/ | grep apr
ls -l /boot/config/plugins/NerdPack/packages/6.2/ | grep apr

 

the output is:

root@Tower:~# ls -l /var/log/packages/ | grep apr
root@Tower:~# ls -l /boot/config/plugins/NerdPack/packages/6.2/ | grep apr
-rwxrwxrwx 1 root root   234776 Sep 17 20:50 apr-1.5.2-x86_64-1.txz*
-rwxrwxrwx 1 root root   125180 Sep 17 20:50 apr-util-1.5.4-x86_64-2.txz*

 

The versions seem to be the same as in the apache.plg file.

I removed the old ones from the packages folder before installing the new plugin.

 

Share this post


Link to post

I just upgraded unRAID to 6.2 and get the following error in the syslog when trying to run the web server:

 

apache: /usr/sbin/httpd: error while loading shared libraries: libsasl2.so.2: cannot open shared object file: No such file or directory

 

I know this plugin is not supported any more, but can someone please help?

 

I updated the plugin for 6.2 and the OP. Let me know if it works.  You'll need to remove the old plugin and install from the new link below.

https://raw.githubusercontent.com/dmacias72/unRAID-plugins/master/plugins/apache.plg

 

Installed and there is still an ERROR but it seems on a different file:

apache: /usr/sbin/httpd: error while loading shared libraries: libaprutil-1.so.0: cannot open shared object file: No such file or directory

 

Sounds like apr-util isn't installed or a previous version overwrote it. Try these

ls -l /var/log/packages/ | grep apr
ls -l /boot/config/plugins/NerdPack/packages/6.2/ | grep apr

 

the output is:

root@Tower:~# ls -l /var/log/packages/ | grep apr
root@Tower:~# ls -l /boot/config/plugins/NerdPack/packages/6.2/ | grep apr
-rwxrwxrwx 1 root root   234776 Sep 17 20:50 apr-1.5.2-x86_64-1.txz*
-rwxrwxrwx 1 root root   125180 Sep 17 20:50 apr-util-1.5.4-x86_64-2.txz*

 

The versions seem to be the same as in the apache.plg file.

I removed the old ones from the packages folder before installing the new plugin.

 

From those commands, I see they are on the flash drive but not installed. Maybe they got uninstalled somehow. This should fix it. You might want to uninstall the plugin then reinstall if the apr packages don't fix it. Maybe other packages are not installed.

installpkg /boot/config/plugins/NerdPack/packages/6.2/apr*.txz

 

Edit: You could also try upgradepkg /boot/config/plugins/apache/*.txz

That would fix any missing packages.

 

Share this post


Link to post

From those commands, I see they are on the flash drive but not installed. Maybe they got uninstalled somehow. This should fix it. You might want to uninstall the plugin then reinstall if the apr packages don't fix it. Maybe other packages are not installed.

installpkg /boot/config/plugins/NerdPack/packages/6.2/apr*.txz

 

Edit: You could also try upgradepkg /boot/config/plugins/apache/*.txz

That would fix any missing packages.

 

Thank you for your help and patience.

 

OK, I saw that NerdPack was not installing these packages so I turned them ON, rebooted and now Apache is running OK.

 

But I have another problem. I am trying to run phpvirtualbox, as before, and am getting (I cleared the browser cache - no help):

PHP does not have the SOAP extension enabled.

 

I check the php.ini file and

extension=soap.so

is OK - not commented. php.ini file is exactly the same as it was in the previous Apache version I was running.

 

when running:

php -i | grep -i soap

 

No mention of SOAP is given. Could it be that soap is missing in your package?

 

Can you help here as well?

Share this post


Link to post

From those commands, I see they are on the flash drive but not installed. Maybe they got uninstalled somehow. This should fix it. You might want to uninstall the plugin then reinstall if the apr packages don't fix it. Maybe other packages are not installed.

installpkg /boot/config/plugins/NerdPack/packages/6.2/apr*.txz

 

Edit: You could also try upgradepkg /boot/config/plugins/apache/*.txz

That would fix any missing packages.

 

Thank you for your help and patience.

 

OK, I saw that NerdPack was not installing these packages so I turned them ON, rebooted and now Apache is running OK.

 

But I have another problem. I am trying to run phpvirtualbox, as before, and am getting (I cleared the browser cache - no help):

PHP does not have the SOAP extension enabled.

 

I check the php.ini file and

extension=soap.so

is OK - not commented. php.ini file is exactly the same as it was in the previous Apache version I was running.

 

when running:

php -i | grep -i soap

 

No mention of SOAP is given. Could it be that soap is missing in your package?

 

Can you help here as well?

 

php -i | grep -i soap

This will only show unRAID's php settings which is loaded before the plugin installs the extensions.

I use a file in the web servers docroot like /mnt/cache/www/phpinfo.php with this content then go to server url like http://server:8088/phpinfo.php

 

phpinfo.php

<?
// Show all information, defaults to INFO_ALL
phpinfo();
?>

 

try this to see if soap is installed

ls -l /usr/lib64/php/extensions | grep soap

 

also given the missing packages the install could be messed up so try this to symlink /etc/httpd to your flash drive

 

rm -rf /etc/httpd
ln -sfT /boot/config/plugins/apache/httpd /etc/httpd

Share this post


Link to post

php -i | grep -i soap

This will only show unRAID's php settings which is loaded before the plugin installs the extensions.

I use a file in the web servers docroot like /mnt/cache/www/phpinfo.php with this content then go to server url like http://server:8088/phpinfo.php

 

phpinfo.php

<?
// Show all information, defaults to INFO_ALL
phpinfo();
?>

 

try this to see if soap is installed

ls -l /usr/lib64/php/extensions | grep soap

 

also given the missing packages the install could be messed up so try this to symlink /etc/httpd to your flash drive

 

rm -rf /etc/httpd
ln -sfT /boot/config/plugins/apache/httpd /etc/httpd

 

ls -l /usr/lib64/php/extensions | grep soap

returns

-rwxr-xr-x 1 root root  364504 Sep  7 01:59 soap.so*

 

I looked at /etc/httpd/php.ini and it looked OK.

I tried the symlink anyway and still same issue.

 

Share this post


Link to post

I installed your vbox plugin and get

Exception Object
(
    [message:protected] => PHP does not have the SOAP extension enabled.
    [string:Exception:private] => 
    [code:protected] => 32
    [file:protected] => /mnt/cache/www/phpvirtualbox/lib/ajax.php
    [line:protected] => 123
    [trace:Exception:private] => Array
        (
        )

    [previous:Exception:private] => 
)

 

It could be the version of php extensions I'm using.  I'll play around with it some more.

Share this post


Link to post

It should work now. It wasn't using the php.ini from the flash drive. I linked the php.ini to /etc/php.d/php.ini and updated the extensions to match 6.2.

 

Share this post


Link to post

Yes, it is working now.

Thank you

No problem. Your welcome. I'll update it a little more when I get a chance. The delete logs doesn't work and a reload or restart button would be nice. I need to update the unRAID reverse proxy, it needs a couple more folders proxied.

Share this post


Link to post

owncloud prompt

"PHP module GD not installed."

 

please add the module

thanks

What version of unRAID and what version of the plugin? The gd module is loaded in the default php.ini which should be in the apache plugin folder.

Share this post


Link to post

unRAID version 6.2.1

Plugin  version 2016.10.15

You can create a couple files in your docroot to check what's enabled.

 

This is one I have named phpinfo.php

<?
// Show all information, defaults to INFO_ALL
phpinfo();
?>

And I made this one named gdinfo.php

<?
if(function_exists("imagepng")){echo "GD is installed\n";}else{echo "GD is not installed\n";}
?>

Check that your php.ini in the apache plugin folder has this line uncommented

extension=gd.so

 

Also what version of owncloud? Maybe there's a compatibility problem with unRAID's php. I'll try running it when I get a chance.

 

Share this post


Link to post

gdinfo.php show "GD is not installed"

 

and in the php.ini file,  extension=gd.so is uncommented

 

owncloud's version is latest 9.1.1

Share this post


Link to post

Thanks for such a nice plugin, making it fairly easy to run a web server on UnRaid.

I have on problem though. Something seems wrong with the php permissions?

I tried running phpMyAdmin and got the following:

 

phpMyAdmin - Error
Error during session start; please check your PHP and/or webserver log file and configure your PHP installation properly. Also ensure that cookies are enabled in your browser.

session_start(): open(SESSION_FILE, O_RDWR)) failed: Permission denied (13)

 

It doesn't matter if I run the webserver as 'nobody' or as a user. What's wrong here? How can I change the permissions needed?

Share this post


Link to post

Thanks for such a nice plugin, making it fairly easy to run a web server on UnRaid.

I have on problem though. Something seems wrong with the php permissions?

I tried running phpMyAdmin and got the following:

 

phpMyAdmin - Error
Error during session start; please check your PHP and/or webserver log file and configure your PHP installation properly. Also ensure that cookies are enabled in your browser.

session_start(): open(SESSION_FILE, O_RDWR)) failed: Permission denied (13)

 

It doesn't matter if I run the webserver as 'nobody' or as a user. What's wrong here? How can I change the permissions needed?

 

I'll setup phpMyAdmin and see. It's possible when you installed phpMyAdmin into your docroot you set root permissions. I need to have the rc script just redo permissions on start. Right now it just sets them on new install or on user change but not sub directories. Anyway try running this from the command line using the path and user you setup for apache.

 

chown -R nobody: users /mnt/cache/www

 

Also what version phpMyAdmin?

 

Edit: also run this. It will fix session permissions but not sure if it would affect emhttp or other php processes

 

chown -R nobody: users /var/lib/php

 

Edit2: or change the session.save_path in the php.ini in the apache plugin folder on the flash drive to a path that's writable by the apache user. e.g.

 

session.save_path = "/tmp"

 

The restart the server.

I tested it with latest phpMyAdmin and it works now.

 

Share this post


Link to post

gdinfo.php show "GD is not installed"

 

and in the php.ini file,  extension=gd.so is uncommented

 

owncloud's version is latest 9.1.1

Only thing I could suggest would be to uninstall the plugin then rename or delete the plugin folder then reinstall. Maybe even try a different docroot on the new install.

 

I included a Config Editor now that you can check and edit the conf's and php.ini.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.