(Support) Aptalca's docker templates


Recommended Posts

You don't want host mode. You can't forward to different ports with that.

 

You probably didn't enter the url prefix variable in unraid properly. Post a screenshot of your container settings page.

 

Use the ip of your unraid machine, not the hostname

 

 

Link to comment
5 hours ago, aptalca said:

You don't want host mode. You can't forward to different ports with that.

You probably didn't enter the url prefix variable in unraid properly. Post a screenshot of your container settings page.

Use the ip of your unraid machine, not the hostname

I switched back to bridge a while ago, but here are the relevant screenshots.  Alschrome_2017-05-24_07-41-03.thumb.png.f0f9182af2fc412670bb64d4cea6afcd.pngchrome_2017-05-24_07-41-18.thumb.png.5565986d126e32ddb5a8f648f489e677.pngbash_2017-05-24_07-43-22.png.0e736985c5a4b6b5146b50203795bceb.pngVNC-Viewer-6.0.0-Windows-64bit_2017-05-24_07-45-00.thumb.png.a5a13fd193d9f459ac74f04c7eca8623.pngbash_2017-05-24_07-45-42.png.57fd7302cda53d3690ee393964420fb2.pngVNC-Viewer-6.0.0-Windows-64bit_2017-05-24_07-47-05.png.ba26e0cf37ab52c7dcc03249db64f024.pngo tried with IP, no luck.

 

 

Link to comment
  • 3 weeks later...

 

I am having some issues with plexrequests... It does not seem to start. maybe things are still loading but here are my logs...

*** Running /etc/my_init.d/00_regen_ssh_host_keys.sh...
*** Running /etc/my_init.d/firstrun.sh...
<-------------------------------------->
<-------------------------------------->
Starting container on Tue Jun 13 03:29:03 CDT 2017
Updating repository
HEAD is now at ea2c74b Smallest change to Radarr Quality Profile ID to shake it lose
Already up-to-date.
Selecting the desired branch
Using the master branch
Already on 'master'
Your branch is up-to-date with 'origin/master'.
Fixing permissions
Updating meteor. . . may take a while if meteor servers are being slow. The web gui will not go up until update is completed and there will be another message about PlexRquests starting
=> Errors while initializing project:
While downloading fourseven:scss@3.4.1...:
error: Command failed:
module.js:340
throw err;
^
Error: Cannot find module '../'
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.<anonymous>
(/tmp/mt-1ej1wsn/plugin.compileScssBatch.os.linux.x86_64/npm/compileScssBatch/node_modules/.temp-8ffq/node_modules/node-sass/node_modules/cross-spawn/node_modules/spawn-sync/node_modules/try-thread-sleep/node_modules/thread-sleep/node_modules/.bin/node-pre-gyp:15:20)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Function.Module.runMain (module.js:497:10)
npm ERR! Linux 4.4.30-unRAID
npm ERR! argv "node"
"/home/.meteor/packages/meteor-tool/.1.3.5_1.cmlynv++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/npm"
"rebuild" "--no-bin-links" "--update-binary"
npm ERR! node v0.10.46
npm ERR! npm  v3.10.5
npm ERR! code ELIFECYCLE
npm ERR! thread-sleep@1.0.4 install: `node-pre-gyp install --fallback-to-build`
npm ERR! Exit status 8
npm ERR!
npm ERR! Failed at the thread-sleep@1.0.4 install script 'node-pre-gyp install
--fallback-to-build'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the thread-sleep
package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-pre-gyp install --fallback-to-build
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs thread-sleep
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls thread-sleep
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR!
/tmp/mt-1ej1wsn/plugin.compileScssBatch.os.linux.x86_64/npm/compileScssBatch/node_modules/.temp-8ffq/npm-debug.log
module.js:340
throw err;
^
Error: Cannot find module '../'
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.<anonymous>
(/tmp/mt-1ej1wsn/plugin.compileScssBatch.os.linux.x86_64/npm/compileScssBatch/node_modules/.temp-8ffq/node_modules/node-sass/node_modules/cross-spawn/node_modules/spawn-sync/node_modules/try-thread-sleep/node_modules/thread-sleep/node_modules/.bin/node-pre-gyp:15:20)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Function.Module.runMain (module.js:497:10)
npm ERR! Linux 4.4.30-unRAID
npm ERR! argv "node"
"/home/.meteor/packages/meteor-tool/.1.3.5_1.cmlynv++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/npm"
"rebuild" "--no-bin-links" "--update-binary"
npm ERR! node v0.10.46
npm ERR! npm  v3.10.5
npm ERR! code ELIFECYCLE
npm ERR! thread-sleep@1.0.4 install: `node-pre-gyp install --fallback-to-build`
npm ERR! Exit status 8
npm ERR!
npm ERR! Failed at the thread-sleep@1.0.4 install script 'node-pre-gyp install
--fallback-to-build'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the thread-sleep
package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-pre-gyp install --fallback-to-build
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs thread-sleep
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls thread-sleep
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR!
/tmp/mt-1ej1wsn/plugin.compileScssBatch.os.linux.x86_64/npm/compileScssBatch/node_modules/.temp-8ffq/npm-debug.log

Starting PlexRequests. The web gui will be up once the message 'App running at: http://localhost' is displayed
*** Running /etc/rc.local...
*** Booting runit daemon...
*** Runit started as PID 111
Jun 13 03:31:16 3eedb91f2bda syslog-ng[118]: syslog-ng starting up; version='3.5.3'
[[[[[ /config/plexrequests-meteor ]]]]]
=> Started proxy.
=> Meteor 1.3: ES2015 modules, npm integration, app testing, mobile
improvements, and more.
This release is being downloaded in the background. Update your app to
Meteor 1.3 by running 'meteor update'.
Unexpected mongo exit code 14. Restarting.
Unexpected mongo exit code 14. Restarting.
Unexpected mongo exit code 14. Restarting.
Can't start Mongo server.
Unspecified unrecoverable error. Exit was not clean

 

Link to comment
4 minutes ago, max32268 said:

 

I am having some issues with plexrequests... It does not seem to start. maybe things are still loading but here are my logs...


*** Running /etc/my_init.d/00_regen_ssh_host_keys.sh...
*** Running /etc/my_init.d/firstrun.sh...
<-------------------------------------->
<-------------------------------------->
Starting container on Tue Jun 13 03:29:03 CDT 2017
Updating repository
HEAD is now at ea2c74b Smallest change to Radarr Quality Profile ID to shake it lose
Already up-to-date.
Selecting the desired branch
Using the master branch
Already on 'master'
Your branch is up-to-date with 'origin/master'.
Fixing permissions
Updating meteor. . . may take a while if meteor servers are being slow. The web gui will not go up until update is completed and there will be another message about PlexRquests starting
=> Errors while initializing project:
While downloading fourseven:scss@3.4.1...:
error: Command failed:
module.js:340
throw err;
^
Error: Cannot find module '../'
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.<anonymous>
(/tmp/mt-1ej1wsn/plugin.compileScssBatch.os.linux.x86_64/npm/compileScssBatch/node_modules/.temp-8ffq/node_modules/node-sass/node_modules/cross-spawn/node_modules/spawn-sync/node_modules/try-thread-sleep/node_modules/thread-sleep/node_modules/.bin/node-pre-gyp:15:20)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Function.Module.runMain (module.js:497:10)
npm ERR! Linux 4.4.30-unRAID
npm ERR! argv "node"
"/home/.meteor/packages/meteor-tool/.1.3.5_1.cmlynv++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/npm"
"rebuild" "--no-bin-links" "--update-binary"
npm ERR! node v0.10.46
npm ERR! npm  v3.10.5
npm ERR! code ELIFECYCLE
npm ERR! thread-sleep@1.0.4 install: `node-pre-gyp install --fallback-to-build`
npm ERR! Exit status 8
npm ERR!
npm ERR! Failed at the thread-sleep@1.0.4 install script 'node-pre-gyp install
--fallback-to-build'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the thread-sleep
package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-pre-gyp install --fallback-to-build
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs thread-sleep
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls thread-sleep
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR!
/tmp/mt-1ej1wsn/plugin.compileScssBatch.os.linux.x86_64/npm/compileScssBatch/node_modules/.temp-8ffq/npm-debug.log
module.js:340
throw err;
^
Error: Cannot find module '../'
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.<anonymous>
(/tmp/mt-1ej1wsn/plugin.compileScssBatch.os.linux.x86_64/npm/compileScssBatch/node_modules/.temp-8ffq/node_modules/node-sass/node_modules/cross-spawn/node_modules/spawn-sync/node_modules/try-thread-sleep/node_modules/thread-sleep/node_modules/.bin/node-pre-gyp:15:20)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Function.Module.runMain (module.js:497:10)
npm ERR! Linux 4.4.30-unRAID
npm ERR! argv "node"
"/home/.meteor/packages/meteor-tool/.1.3.5_1.cmlynv++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/npm"
"rebuild" "--no-bin-links" "--update-binary"
npm ERR! node v0.10.46
npm ERR! npm  v3.10.5
npm ERR! code ELIFECYCLE
npm ERR! thread-sleep@1.0.4 install: `node-pre-gyp install --fallback-to-build`
npm ERR! Exit status 8
npm ERR!
npm ERR! Failed at the thread-sleep@1.0.4 install script 'node-pre-gyp install
--fallback-to-build'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the thread-sleep
package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-pre-gyp install --fallback-to-build
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs thread-sleep
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls thread-sleep
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR!
/tmp/mt-1ej1wsn/plugin.compileScssBatch.os.linux.x86_64/npm/compileScssBatch/node_modules/.temp-8ffq/npm-debug.log

Starting PlexRequests. The web gui will be up once the message 'App running at: http://localhost' is displayed
*** Running /etc/rc.local...
*** Booting runit daemon...
*** Runit started as PID 111
Jun 13 03:31:16 3eedb91f2bda syslog-ng[118]: syslog-ng starting up; version='3.5.3'
[[[[[ /config/plexrequests-meteor ]]]]]
=> Started proxy.
=> Meteor 1.3: ES2015 modules, npm integration, app testing, mobile
improvements, and more.
This release is being downloaded in the background. Update your app to
Meteor 1.3 by running 'meteor update'.
Unexpected mongo exit code 14. Restarting.
Unexpected mongo exit code 14. Restarting.
Unexpected mongo exit code 14. Restarting.
Can't start Mongo server.
Unspecified unrecoverable error. Exit was not clean

 

This is pretty much deprecated in favour of Ombi nowadays.

Link to comment

The RDP-Calibre container I am using updated to the latest Calibre v3.0. Since then I cannot reach the server. I am not sure what is relevant in the logs. I did see this:
 

calibre-server: error: no such option: --with-library

 

Any suggestions where to start?

Link to comment
The RDP-Calibre container I am using updated to the latest Calibre v3.0. Since then I cannot reach the server. I am not sure what is relevant in the logs. I did see this:
 
calibre-server: error: no such option: --with-library
 
Any suggestions where to start?


Uh oh. Looks like they made some significant changes in 3.0

I'll look into it
Link to comment
1 minute ago, aptalca said:

 


Uh oh. Looks like they made some significant changes in 3.0

I'll look into it

 

 

One of the big new features is this:

  • A completely re-written Content server with support for reading books in-browser on your phone/tablet. Also works in offline mode.

So maybe that is why. Thank you for looking into it.

Link to comment
Any thoughts on my post prior with the URLPREFIX setting not working?


Sorry, I forgot to respond to that. But there were a couple of issues.

Url prefix should have been just the prefix, no forward slash.

And the prefix option only applied to the calibre webserver, not the calibre gui. Calibre gui already has a prefix that can be used in reverse proxy situations.

With the latest update the url prefix option has been deprecated. You can set that in the calibre gui webserver settings.
Link to comment
  • 2 weeks later...
Hi Mr. Aptalca,
 
Looks like the RDP-Calibre docker is broken. The RDP part does not load. Someone says that v. 3 of Calibre broke the RDP.
 
This is in my top 3 favorite dockers....
 
Thank,
 
H.


Works fine here. It wasn't the rdp part that broke, it was the built in server. It is now fixed but you have to enable in the gui settings. Details on docker hub description
Link to comment
6 hours ago, aptalca said:

 


Works fine here. It wasn't the rdp part that broke, it was the built in server. It is now fixed but you have to enable in the gui settings. Details on docker hub description

 

 

Perfect. Works. Looks like new interface too.

 

many thanks!

 

H.

Link to comment

So I'm new to docker, new to unRaid, etc. I was trying to set up RDP-Calibre, but when I try to set my library to /config on first boot in the Calibre wizard in the WebUI, it gives me an error that the folder is not empty and that the library folder must be empty. What am I missing here?

Link to comment
3 hours ago, CHBMB said:

/config is where the application data is stored rather than the library.  I've used a /books folder for my library, like so.

Screenshot from 2017-07-18 09-25-23.png

Thanks for the reply. I was trying to do the step in the docker hub instructions that say this:

 

  • IMPORTANT: On first start, select "/config" as the library location in the Calibre wizard

I know you can set up a different path for subsequent boots, but it sounds like I'm supposed to select config as the location for the library for first set up in the wizard (not docker). Is that incorrect?

Link to comment
56 minutes ago, Eyeheartpie said:

Thanks for the reply. I was trying to do the step in the docker hub instructions that say this:

 

  • IMPORTANT: On first start, select "/config" as the library location in the Calibre wizard

I know you can set up a different path for subsequent boots, but it sounds like I'm supposed to select config as the location for the library for first set up in the wizard (not docker). Is that incorrect?

 

Well was your config empty at first boot?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.