[support] MakeMKV-RDP container Deprecated

Recommended Posts

Hello i'm not sure what i might be doing wrong but i keep getting this error. Any help would be great. 


root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="MakeMKV-RDP" --net="bridge" -e TZ="America/Los_Angeles" -e HOST_OS="unRAID" -e "WIDTH"="1280" -e "HEIGHT"="720" -p 3389:3389/tcp -p 8080:8080/tcp -v "/mnt/user/Downloads/completed/":"/unRaid":rw -v "/mnt/user/appdata/MKV/":"/config":rw --device=/dev/sr0:/dev/sr0 tobbenb/makemkv-rdp

/usr/bin/docker: Error response from daemon: linux runtime spec devices: error gathering device information while adding custom device "/dev/sr0": lstat /dev/sr0: no such file or directory.

The command failed.

Link to comment
4 hours ago, mikedpitt420 said:

I had the same issue as I don't have an optical drive. If this is also your problem remove the /dev/sr0 line from the advanced options. Hope that helps! 

How do i access that file it does not create the file or folder so how do i got about editing it? I'm a bit new to this thank you.

Link to comment

Hit "Advanced View" at the top right, and remove the "extra parameters" line referencing the optical drive like the attached picture. I believe I made the same mistake and it's in this forum post a few pages back. I think that most people use this for use with an optical drive so the author included those parameters. I just use them for ISO and BDMV index files, so my container also failed in this same way as I don't have an optical drive.


Edited by mikedpitt420
Link to comment
12 hours ago, cherritaker said:

Is the error that states that you have anydvd enabled normal or how do i disable it? Or should i just ignore it?


It's not possible to disable. It means that you use an iso or a folder that has already been ripped and decrypted. 

So nothing to worry about. 

Link to comment
  • 1 month later...
  • 1 month later...

the license key seems to fail to work now. Every time I start this docker, it replaces settings.conf with a blank file with no key, then when the UI loads it says the license is expired. I also checked and both the settings.conf and screen.conf modify times match the time the docker starts. Is it stuck this way or am I doing something wrong?

Edited by mikedpitt420
Link to comment
56 minutes ago, mikedpitt420 said:

I removed the docker and image and data, reinstalled, and now I don't even have a settings.conf file. It worked and just threw the "this is a 30 day trial" warning. So I suppose this just needs removed and redone every 30 days then?

Look here --> http://www.makemkv.com/forum2/viewtopic.php?f=5&t=1053


But I have a script that add a new key to to MakeMKV when I boot  my server.




Link to comment
5 hours ago, mikedpitt420 said:

Nope still same behavior. When I start the docker it erases settings.conf with a blank file without the key


You need to supply more info about your setup. Docker template and where stuff are stored. 

What do you mean by a blank file? Just an empty file or is there content?

Provide the output of the below command inside the makemkv appdata folder/config


I just tried installing it fresh and have no problems here, so it's related to your setup.


Link to comment

Apologies. The only thing even slightly different about my setup is I have no optical drive. The docker installs to /mnt/cache/appdata/makemkv. When I install the docker now, there is no settings.conf file at all, and it gives me the 30 day warning. If I then stop the doctor, create a settings.conf file and add the line with the code in it, then restart the docker the settings.conf file reverts to not having the key. Note the modify time for settings.conf in the 2nd set of terminal windows, and you can see it's been modified as the docker starts and the app key is goneCapture.thumb.JPG.ae0bedc4028cef795db13f00c1bfae09.JPG





Link to comment

I don't see anything wrong there. I also did not use an optical drive when I tested a new install.

Can you post a screenshot of the template for the container and click the Show advanced settings line?


Your setting files shows that it was created by makemkv 1.10.5, but a fresh install should say 1.10.7. 

Have you tried changing some settings the first time the container starts, and then go see if the file exists?

Link to comment
  • 1 month later...
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.