Unraid on older Mac Pro's


Recommended Posts

  • 1 year later...

I would like to submit my findings on this topic as I came across this thread when I was research the same question.


I have a Mac Pro 4,1 (early 2009) that I have updated the EFI Firmware to be a 5,1.  Both before and after the update, my Mac refused to boot from a MBR configured usb flash stick.  I was able to take the Unraid flash device and boot my '14 Macbook Pro from it, but the old Mac EFI just won't do it.


I DID manage to boot the Unraid install from an SSD, connected to an internal SATA port, but.....  Unraid doesn't support this option for use.  You HAVE to have the USB flash device to save the configuration to as the system refuses to use the internal SSD after it's booted and the system is loaded into memory.  I did read a post from Lime Tech saying that they do not support booting form an internal drive.


Being that I had it working, all but saving my configuration for the next reboot, I went on a mission to find a way to make it work.  I found this link:  http://www.ostricher.com/2012/09/setting-up-unraid-vm/

After reading through it, I tried that method too.  I booted ESXi from a USB flash drive, used the empty space on the flash drive to create a datastore and then configured PCI Passthrough on the 6 port SATA controller AND my USB 3 PCI card.  While I did get it to boot and it worked, it was definitely sluggish because of all the extra processing occurring with Unraid being in a VM.  The setup process DID get me thinking of an option though.


In his guide, Itamar explained how he used Plop Bootloader to make VMware boot directly of a USB device, which was otherwise, unsupported and impossible.  THIS got me thinking.  I did a ton of reading about Plop Bootloader and the methods of installing it and using it.  Ultimately, I needed a syslinux boot loader to load Plop Bootmanager, which I had already configured to stay hidden and load my USB flash drive directly.  I HATE dealing with Grub and Grub2 and in general, boot loaders are not my thing.  I found a thread talking about an app called YUMI to install a MULTIBOOT ISO boot manager with syslinux and you can boot any ISO or live ISO of linux and all kinds of operating system.  The downside is that YUMI is a Windows app, but what the hell, right?  I took my SSD that I had booting before, wrote the new MBR to the disk with syslinux and MULTIBOOT which then opens Plopbootloader as hidden and loads UNRAID.  It sounds complicated, but the boot process literally takes about 40-50 seconds to get to the UNRAID boot.  I modified MULTIBOOT's menu to skip everything, timeout after 3 seconds and load Plop by default with no keyboard interaction.  I think the amount of time it takes for UNRAID to start loading is about 30 seconds now.  


How often do you really reboot a NAS anyway?  The bootloaders have nothing to do with the system once it's running.

There is 2 negatives to this and neither affect me at all.

1. I have to waste an internal SATA port JUST for the MBR and bootloader.

2. I'm using an SSD for nothing else, other than the bootloader.


I have 5 other internal SATA ports which are all being used for my disk Array and I have a 4 port, USB3 PCI card which I have a 4 drive external enclosure on and still have the ability to connect another enclosure, invidiual drives, etc.


Ultimately, UNRAID is running perfectly on my 2009 Mac Pro 4,1 with 32 gb of ram and 20 TB of storage space on the array with 2 TB of ssd cache space.  I think that's a pretty damn good setup.

I'm also sure there is an easier method to get Plop Bootmanager loading on the internal disk, but every possibility I tried to load it from USB flash drive failed.  This Mac Pro (and assuming others of this age and older) absolutely refuse to boot from an MBR partitioned USB flash device.


Here's a link with a tutuorial on using YUMI:  http://smyl.es/tutorial-how-to-build-the-ultimate-custom-usb-drive-with-multiple-bootable-installs-for-windows-and-linux-and-portableapps-for-windows/

And the download link here:  https://www.pendrivelinux.com/yumi-multiboot-usb-creator/


Hopefully my info will help someone else make use their old Mac Pro or other old Mac. They are very solid machines!

Link to comment
  • 10 months later...
  • 1 year later...
On 3/19/2018 at 4:20 PM, Holla said:

Burn the Plop Bootloader to a CD. Works on Mac pro 1.1.



Did you need to update the EFI on the 1,1 to get Plop to play nice? I'm trying to run it on my 1,1 via superdrive to test unRAID but I can't get the actual manager to function. My understanding is that the manager should run directly from the cd drive, but so far I'm only seeing the installer, which is unresponsive.

Link to comment
  • 5 months later...
  • 3 months later...
  • 3 months later...
On 9/26/2020 at 7:40 PM, Holla said:

For posterity, an UNRAID 6.8.3 bootable USB created with the provided tool boots fine with a plopkexec 1.6 CD on a Mac Pro 1.1 with 2.1 flashed SMC. May this saves someone an ungodly amount of wasted time 🤗

I'm confirming that this method works on a a MacPro 3,1  as well.


I hope that this can save others as much time as it saved me! 

Link to comment
  • 5 months later...

This WorKs !

Thanks, really thanks for this information.

Works on a MacPro 3.1.


Nice, nice...


Concerning the boot, how did you configure the machine? During a reboot, you have to select the CD manually with the keyboard (press the C key), or without anyone behind the keyboard that's a problem. Thank you ;)

Edited by PicPoc
Link to comment
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.