Anyone got Idrive working on Unraid ?


Recommended Posts

Hi All

 

Was happy with Crashplan for a long time, but switched to Idrive for backing up the increasing number of mobile devices in the family.

Idrive makes some linux stuff...

Have anyone got Idrive working on Unraid, which could give me some hints or a how-to, I would be grateful !!

 

/René

Link to comment
  • 2 years later...

Hi,

Did you manage to get Idrive working on unRaid i any way.

 

I am running idrive backup from a unraid vm - but maybe there is a smarter way to do this.

There is a idrive docker in the hub, but there is very little description  of what i actually does. Apart from it a idrive datacenter edition (akanto/idrive)

Maybe this doesnt work for homeusers.

 

/michael

Link to comment
  • 1 year later...
  • 1 month later...
On 3/19/2020 at 4:27 AM, TheSpook said:

This is an old thread, but I got this working using a Docker container if anyone is interested. Takes some basic Linux commands but nothing too difficult.

I would be very interested how you got it working using a Docker container. I allready asked and received the script-files from idrive-support, but I'm not as proficiënt with docker-making and only baby-steps in Linux... So, every piece of advice and help is good for me... And maybe it will help others with this precious info :)

 

Greetings

/Mario

Link to comment
  • 2 months later...

Hi, I would also be interested in how you got this working using a docker container.

 

I am in the process of migrating a WHS2011 server to unRaid. I was backing up the WHS to IDrive. I could use a Windows VM on the Unraid server but docker would be nicer. I would like to get the backups working before I move the rest of data over to Unraid.

Link to comment
  • 4 weeks later...

So sorry! I come here so rarely and didn't turn on "Notify me of replies". My bad! If you're still intrested, here is the method I used.

 

1. Create a new Docker container based on a version of Linux that has all the dependancies. I used the "Python" container because it seemed to have Perl and everything I needed. I mounted a folder for the config file as well ad the /mnt/user directory so I can choose what to backup. You have to run the Docker container in interactive mode or it will just shut down because it has nothing to do. I couldn't find a way to do this in the GUI. So just open a teminal (the little symbol in the top right hand corner of the unRAID dashboard) and type:

 

/usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -it --name='idrive_ubuntu-ur1' --net='bridge' -e TZ="Australia/Sydney" -e HOST_OS="Unraid" -v '/mnt/user/':'/data':'ro' -v '/mnt/user/appdata/idrive_ubuntu/':'/config':'rw' 'python'

 

Change your Timezone and the name of the container if you want.

 

I mounted the /mnt/user folder as read only because it should only need to read from that folder for the backups.

 

2. Once this is done, exit out of the terminal. Then go to your Docker tab in unRAID. You should see the new container you just created.

3. Copy the idrive Linux scripts into the folder /mnt/user/appdata/idrive_ubuntu/. If you don't have the scripts, let me know and I can send them to you.

4. (optional) Modify the account_settings.pl script and add your idrive username and password. This will avoid you having to manually type them in later:

    a) change the line my $uname = Helpers::getAndValidate(['enter_your', " ", $Configuration::appType, " ", 'username', ': '], "username", 1);
                                to
                                my $uname = 'idriveuser@email.com';

    b) change the line my $upasswd = Helpers::getAndValidate(['enter_your', " ", $Configuration::appType, " ", 'password', ': '], "password", 0);
                                to
                                my $upasswd = 'password';

    c) save the modified file as account_settings2.pl

5. Bash into the new container (in the Docker tab of unRAID, click on the question mark icon next to the container name and click Console.

6. Once you are in, type: perl /config/scripts/account_setting2.pl (or if you didn't modify the script, perl /config/scripts/account_setting.pl)

7. That's it, just follow the prompts to setup the server in your idrive account. Once it is setup, you can configure what you want to backup from your idrive dashboard (https://www.idrive.com/idrive/in/console?path=/remote/devices).

You should see your new docker container there. If you click on Settings you can choose what to backup. Expand the data folder and you will see all your shares in unRAID.

 

Let me know if you have any issues!

 

 

  • Like 1
  • Thanks 2
Link to comment
  • 1 month later...

@TheSpook, Thanks for the walk through. I'm running into an issue though where the IDrive service doesn't automatically start up whenever the docker is restarted. I have to go back in the docker and manually start the services again.

 

How do you get the IDrive service and cron service to start automatically?

 

Thanks

Edited by MrLinux
Link to comment
  • 4 months later...

Hi boohbah. Yeah I ran into this issue too. I didn't notice it at first as I basically never restarted that container, but then realised at a later date. I think you might have to build a docker image with the cron script (and the IDrive scripts) already included. Unfortunately, that was a little beyond me. So in the end I just used a small Ubuntu VM in iDrive (1GB RAM and 1 CPU) and ran the scripts on that. The IDrive service seems to start successfully and so far it has been working well for me. Pretty much the same process applies - when you create the VM, you just mount the NFS shares and run the idrive script to log on. Once idrive is logged onto the account, you can choose the mounted share in the idrive web console...

Link to comment
  • 4 weeks later...
On 1/27/2021 at 7:07 PM, TheSpook said:

If you're interested in that method and want me to take you through the steps I took, let me know.

Can you please provide what you did?

 

If I understand correctly, you created a Ubuntu VM with 1GB RAM and 1 CPU and ran the iDrive scripts within that VM? Then have it mount the shares you want to backup to iDrive and then I'll be able to select them in the iDrive web console?

Link to comment

Yup that's pretty much it.

  • I created an Ubuntu VM and made sure to add the UnRAID share /mnt/user (or wherever the data is you want to backup)
  • Then I jumped into the VM and installed NFS: sudo apt-get update; sudo apt-get upgrade; sudo apt-get install nfs-common 
  • Then I created the folder in Ubuntu where I wanted to mount my shares: sudo mkdir /mnt/shares/share1; sudo mkdir /mnt/shares/share2
  • Then I added the NFS share(s) to /etc/fstab so it would load at boot: eg your UnRAID server IP is w.x.y.z add line: w.x.y.z:/mnt/user/share1 /mnt/shares/share1 nfs auto,nofail,noatime,nolock,intr,tcp,actimeo=1800 0 0 to /etc/fstab 
  • If you have other shares you want to add, just add them in seperate lines: w.x.y.z:/mnt/user/share2 /mnt/shares/share2 nfs auto,nofail,noatime,nolock,intr,tcp,actimeo=1800 0 0
  • I avoided mounting the whole /mnt/user because it seemed safer to me only adding what I needed to backup.
  • I then installed cpanminus (frommemory this is needed for the idrive scripts: sudo cpan App::cpanminus 
  • Then installed zip and unzip (also needed for the idrive scripts): sudo apt-get install zip unzip 
  • Then copied the idrive Linux scripts into /opt/idrive 
  • And lastly I ran perl /opt/idrive/login.pl and perl /opt/idrive/account_setting.pl

That should be it. Just follow the prompts in the scripts to configure your idrive backup location (just use the defaults). After that, you can log into iDrive and use the GUI to setup your backup schedule and what files you want to backup (these will be the folders that you mounted earlier in /mnt/shares/.

 

Let me know how you go :)

Link to comment
  • 1 month later...

It's easy to install IDrive scripts for Linux 2.29. Version 2.30 is not working on unRaid but iDrive support promised to change that in future update 

 

1. install Plugin NerdPack GUI
2. Using NerdPack install Perl (perl-5.32.0-x86_64-1.txz)
3. Download IDrive scripts for Linux 2.29 https://www.idrivedownloads.com/downloads/linux/download-for-linux/IDriveScripts/IDriveForLinux.zip
4. Unpack to any folder on the server ie. \appdata\iDrive\
5. Follow the instructions from readme.txt
    - connect with putty or use unRaid web terminal
    - go to \appdata\iDrive\
    - execute chmod a+x *.pl
    - run account_setting.pl to configure your account
    - run help.pl to learn how to use scripts

 

after initial configuration you can find (and manually edit) all config files in \appdata\idriveIt\

IDriveForLinux_2.29.zip

Edited by stalkerama
Link to comment
  • 6 months later...
  • 8 months later...

i don't think so, they promised me two times last year that they will work on it, still waiting .... I just noticed download button Linux disappear, contact support if more people will keep asking maybe they will do something about it.

Link to comment
On 7/23/2022 at 10:15 AM, suedenimes said:

Has there been any change in iDrive working with unraid?

 

I've just ordered components to build an unraid server and I currently use iDrive for backing up data

i am also hoping someone can share a idrive docker.. 

  • Like 1
Link to comment
  • 1 month later...

I am trying to set this up for iDrive but I am getting this when running the account_setting.pl script

I downloaded 2.29 version of scripts

 

Verifying your account information...

Starting Dashboard service...
Failed to start Dashboard service.
 

 

Link to comment

@stalkerama

This is what I get and I do not see my linux machine in the list of computers

 

root@Tower:/mnt/cache/appdata/iDrive# ./Status_Retrieval_Script.pl
==========================================================================================
Version: 2.29                                Developed By: IDrive Inc.
-------------                                ---------------------------------------------
Status: Logged In                            IDrive Username: xxxxxxxxxxxxxxxxx
-----------------                            ---------------------------------------------
Storage Used: 55.98 MB of 10000.00 GB        Linux Username: root
==========================================================================================
Warning(s):
* Dashboard service has stopped.
------------------------------------------------------------------------------------------

No Backup/Express Backup/Restore Job is running.
 

 

Edited by Blade
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.