Jump to content
linuxserver.io

[Support] Linuxserver.io - Domoticz

72 posts in this topic Last Reply

Recommended Posts

I haven't actually run Domoticz on another system, but I might look at firing it up on a Linux VM, my list of modifications after a pull is getting a bit long. Or maybe it should move onto a pi.

Sent from my SM-G935F using Tapatalk

Share this post


Link to post
56 minutes ago, Wob76 said:

I haven't actually run Domoticz on another system, but I might look at firing it up on a Linux VM, my list of modifications after a pull is getting a bit long. Or maybe it should move onto a pi.

Sent from my SM-G935F using Tapatalk
 

 

It would be nice to know if it's domoticz or the container that is the problem.

Share this post


Link to post

From the build log of the latest container, there are no runtime folder installed. So either they are changing stuff in the beta version or they forgot to include it somehow.

It's there in the stable-3.5877.

Share this post


Link to post
2 hours ago, Wob76 said:

I'll report back how I go.

Sent from my SM-G935F using Tapatalk
 

 

I tested dzVents in stable-3.8153 and I got it working, but.... I had to move the runtime folder from /var/lib/domoticz/scripts/dzVents to /config/scripts/dzVents/.

The problem is that at installation domoticz installs the scripts in the first location, but we add -userdata /config when running domoticz and that moves the scripts folder to /config, but the runtime folder doesn't get moved.

I'll see how we can get this to work. This is what I don't like with domoticz. It's a mess where it looks for stuff.

Share this post


Link to post
3 hours ago, saarg said:

From the build log of the latest container, there are no runtime folder installed. So either they are changing stuff in the beta version or they forgot to include it somehow.

It's there in the stable-3.5877.

 

I believe they've moved it in the latest betas but that should also have been incorporated into the latest stable, which isn't available as part of this container yet (still!).

 

I copied the dzvents from the windows install and fixed the permissions, seems to work fine for most things BUT I if I try to update a virtual temp sensor with a script I get reboots every minute - this can't be replicated by others on the domoticz forum, so can only assume it's something weird with the container...

 

I'm debating moving it to a dedicated pi as my house gets more dependant on it and I need to ensure the WAF!

Share this post


Link to post
46 minutes ago, air_marshall said:

 

I believe they've moved it in the latest betas but that should also have been incorporated into the latest stable, which isn't available as part of this container yet (still!).

 

I copied the dzvents from the windows install and fixed the permissions, seems to work fine for most things BUT I if I try to update a virtual temp sensor with a script I get reboots every minute - this can't be replicated by others on the domoticz forum, so can only assume it's something weird with the container...

 

I'm debating moving it to a dedicated pi as my house gets more dependant on it and I need to ensure the WAF!

 

You can add stable-3.8153 manually to the repo field. This is how you have to do it when a new update is available. 

Edited by saarg

Share this post


Link to post

Domoticz is a frustrating beast. On one had the development seems patchy and the forums are not very responsive to questions or issues. On the other hand it seems to be the easiest and most flexible open source home automation option, I have tried HASS, OpenHAB and a anything else I could find to run in a docker, and domoticz is still the best choice for me.

 

I have told myself a couple of times that I would move to another system when I couldn't get help on the forum, but I have managed to fix the problem eventually. I am going to give a Smartthing hub a go soon, but I don't think it will have the scripting flexibility of domoticz, I have a number of things scripted depending on house occupancy, temps, etc. I don't think anyone has managed to get domoticz and smartthings to work together, but it would be nice to just use the scripting from domoticz and hand off the basic stuff to a hardware device.

Share this post


Link to post

OK, I built up a VM with ubuntu server 16.04.3 and pulled down domoticz as per the install guide (https://www.domoticz.com/wiki/Linux) to ensure I wasn't messing anything up.

 

After the install dzVents runtime is located in ~/domoticz/dzVents/runtime

 

I did the same thing I was doing on a new pull of the container, created a dzvents script using the example code, this caused caused a segfault crash of the system. I found a thread that suggested going to Setup\Settings\Other and disabling both EventSystem and dzVents and then re-enabling them. This fixed the segfault.

 

I then enabled the sample script, no crashing, created dummy hardware and a dummy switch, linking them, testing the switch and script and all behaved as expected.

 

I could try the above on the container, but as you mention the dzvents runtime just doesn't exist, it seems it get cleaned from the old location, but not created in the new location. I can pull it seperate, but I want to ensure I am not introducing issues.

 

I have now restored my database to see if it runs anymore stable than the container (at the moment it crashes every few days), I have just disabled any scripts that directly control anything, I have enough others running that dzVents it still active.

 

I would like to stick to a container, as it uses less system resources, but stability is causing me issues, just trying to work out if this is due to the container, domoticz (maybe the beta) or I have a corruption in my database. Also considering going to a pi, now that my automation scripts are working nicely I need to keep it stable to keep the WAF and stop the lights, etc being manually turned off :).

 

I would go back to a stable build, but I am using stuff in my scripting that requires dzVents 2.3 and that is not in stable, also much of the Xiaomi plugin requires beta and I have a heap of those sensors, hoping they get to another stable soon, but much of the bugs being reported seem to go without much response.

Share this post


Link to post

Has anyone managed to pass a usb device to the container?

 

i'm trying to pass an arduino using - - -device=/dev/bus/usb/001/005:/dev/ttyUSB0

 

 

 

dmesg | tail

[ 1298.319801] usb 1-1.1: USB disconnect, device number 3
[ 1303.099442] usb 1-1.1: new full-speed USB device number 5 using ehci-pci
lsusb                                                         

Bus 001 Device 005: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter
docker exec -it domoticz lsusb

Bus 001 Device 005: ID 1a86:7523

5a70eae90e4d6_ScreenShot2018-01-28at23_12_51.thumb.png.16b75982e9cbb39357830e34d4ff07bc.png

 

So looks like the arduino/rflink has been passed to the container ok but it wont ever pick up any sensors/devices.

 

I've tested it on a windows laptop and it worked fine.

 

any suggestions?

 

thanks 

 

 

 

 

 

 

 

 

 

Share this post


Link to post
1 hour ago, gareth_iowc said:

Has anyone managed to pass a usb device to the container?

 

i'm trying to pass an arduino using - - -device=/dev/bus/usb/001/005:/dev/ttyUSB0

 

 

 


dmesg | tail

[ 1298.319801] usb 1-1.1: USB disconnect, device number 3
[ 1303.099442] usb 1-1.1: new full-speed USB device number 5 using ehci-pci

lsusb                                                         

Bus 001 Device 005: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter

docker exec -it domoticz lsusb

Bus 001 Device 005: ID 1a86:7523

5a70eae90e4d6_ScreenShot2018-01-28at23_12_51.thumb.png.16b75982e9cbb39357830e34d4ff07bc.png

 

So looks like the arduino/rflink has been passed to the container ok but it wont ever pick up any sensors/devices.

 

I've tested it on a windows laptop and it worked fine.

 

any suggestions?

 

thanks 

 

 

 

 

 

 

 

 

 

No point in mapping it to /dev/ttyUSB0 as it should be given that name in unraid if the correct module was loaded. 

I replied in another thread to you to try running a modprobe command to load the correct module, but that didn't work? 

 

To pass through a device to a container, it needs drivers in unraid. It's not enough that you see it when doing lsusb. 

Edited by saarg

Share this post


Link to post

Just an update on my progress, It seems to be a stability issue with dzVents, with that disabled the docker is fairly stable (still crashed after a week), but as soon as I enable the scripts it will crash every few days.

 

I have updated with each docker release, and currently at the version with Domoticz v3.8875, still crashing.

 

The VM I am running is on v3.8834 and has been up for almost 13 days, so for the moment I am going to stick with a VM, seems more logical for my config as I have a few customisations I was having to do after each pull anyway, resources are higher, but not a deal breaker.

 

Thanks for your efforts, I might revisit the docker again if future.

 

Wob

Share this post


Link to post

Something went wrong with the last update. Using latest.

 

Log fills with this:

 

Quote

2019-02-19 14:59:16.565 Status: Domoticz V4.9701 (c)2012-2018 GizMoCuz
2019-02-19 14:59:16.565 Status: Build Hash: 98723b7d, Date: 2018-06-28 08:00:58
2019-02-19 14:59:16.565 Status: Startup Path: /var/lib/domoticz/
2019-02-19 14:59:16.567 [1;31mError: Database incompatible with this Domoticz version. (You cannot downgrade to an old Domoticz version!)[0;0m

V4.9701, the latest stable was 4.9700. Looks like it pulled from stable instead of latest?

Edited by Niklas

Share this post


Link to post
6 minutes ago, Niklas said:

Something went wrong with the last update. Using latest.

 

Log fills with this:

 

V4.9701, the latest stable was 4.9700. Looks like it pulled from stable instead of latest?

 

I'll check it later today when I get back from work. 

Share this post


Link to post

Is domoticz in this container started with -daemon added to the command line? If not, should it be added? Maybe with "-log /config/domoticz.log"?

The logging is filling the logfile for the container itself. It could be several lines every second added to the log file for the container itself.

Edited by Niklas

Share this post


Link to post
9 hours ago, Niklas said:

Is domoticz in this container started with -daemon added to the command line? If not, should it be added? Maybe with "-log /config/domoticz.log"?

The logging is filling the logfile for the container itself. It could be several lines every second added to the log file for the container itself.

 

It's not started with daemon and it should not be. Processes in a container using S6 overlay must be in the foreground.

 

As for the log, you can add the max log parameter to the extra parameter box in the container template.

Share this post


Link to post

I need to install a python plugin  in domoticz but I need to install both "python3-httplib2" and "git" to be able to run it. Is this possible someway using the docker? I tried opening the console but could not use apt-get inside the docker to install the required packages.

Share this post


Link to post

The deconz plugin need the request library to work.

Could it be added to the container please?

 

2019-12-19 21:04:57.206 Error: (Deconz) Your pyton version miss requests library

2019-12-19 21:04:57.206 Error: (Deconz) To install it, type : sudo -H pip3 install requests | sudo -H pip install requests

Edit:
"pip3 install requests" in container will make the plugin work.
Guess it will work until any re-installation of the continer?

Edited by Niklas

Share this post


Link to post
2 hours ago, Niklas said:

The deconz plugin need the request library to work.

Could it be added to the container please?

 

2019-12-19 21:04:57.206 Error: (Deconz) Your pyton version miss requests library

2019-12-19 21:04:57.206 Error: (Deconz) To install it, type : sudo -H pip3 install requests | sudo -H pip install requests

Edit:
"pip3 install requests" in container will make the plugin work.
Guess it will work until any re-installation of the continer?

Check our blog on linuxserver.io for the Customizing our containers post. Then it will survive an update.

Can you add a github issue for the request. Knowing myself, I will most likely forget it when I wake up tomorrow.

Share this post


Link to post

Yesterday i moved my domoticz setup from my rpi to my unraid server and everything went well, but i have one problem. I use controlicz to connect google assistant to domoticz and it requires an ssl connection. To enable ssl in domoticz you need to edit domoticz.sh but i cant find that file in the docker. Can somebody please point me in the right direction?

Share this post


Link to post
1 hour ago, Jorgen_ said:

Yesterday i moved my domoticz setup from my rpi to my unraid server and everything went well, but i have one problem. I use controlicz to connect google assistant to domoticz and it requires an ssl connection. To enable ssl in domoticz you need to edit domoticz.sh but i cant find that file in the docker. Can somebody please point me in the right direction?

The ssl port is 1443, unless you have changed it.

domoticz.sh isn't used in the container.

Share this post


Link to post
Posted (edited)

That port does seem to be open but i get ERR_EMPTY_RESPONSE. Is there anything in the domoticz settings i have to enable?

 

Edit: Ok, it is working now. Found on the domoticz forums you really have to type in https in stead of http for it to work. Thanks for the help!

Edited by Jorgen_

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.