Jump to content

[Support] knex666 - Icecast

Recommended Posts

Application Name: Icecast

Overview: Support for Docker image of Icecast

Application: Icecast - http://icecast.org/

Docker Hub: https://hub.docker.com/r/infiniteproject/icecast/

GitHub: https://github.com/maschhoff/docker/tree/master/icecast


Please read all information in the Overview Box. And use the configuration and files providet on github.

Is a good combination with Mopidy

For any question - dont mind to ask!

Edited by knex666
Link to comment
  • 9 months later...

even though im specifying the directive




The docker wont start because:


Couldn't find user "icecast" in password file
Couldn't find group "icecast" in groups file


What do i have to do?

Link to comment

Tells me :


Couldn't find user "nobody" in password file
Couldn't find group "nobody" in groups file
ERROR: You should not run icecast2 as root
Use the changeowner directive in the config file


I use:



I check:





I add variables to container:




Still user/group "Nobody" found.


Whats wrong with this container?


Edited by je82
Link to comment

I'm a complete newb at docker but it looks like this container is broken as it is not running:


RUN addgroup -S icecast && \

adduser -S icecast


There's no user icecast for this docker container, so the icecast server won't start because it has no users, anyone have any idea how to fix it?

Link to comment
7 hours ago, knex666 said:

As written in the description please copy and use the icecast.xml from here:



This should work fine.


Cheers and merry xMas

I used this config file, it gives me the same error.

Config file contains:



This user is not exist within the container according to icecast and it won't boot.

Or is it something else that is wrong and it errors out the wrong thing? Should i be looking at something else?


I tried a different container for Icecast and all of them give the exact same error, the user/group does not exist, i've tried with user:group nobody:users as this is the user that runs docker containers on unraid but this doesn't work either.


Ideas would be welcome, merry christmas!

Edited by je82
Link to comment
  • 9 months later...
  • 1 year later...
5 hours ago, PicPoc said:

Another problem :

I want to user the same IP for Apache-PHP and IceCast.

Same IP, but not the same port.


IceCast :


It's impossible to set the same IP.

Is there any workaround ?

Yes, use bridge instead of bro0

Link to comment
  • 1 year later...
43 minutes ago, JonathanM said:

Question, is it possible to use both Icecast and Snapcast with the same Mopidy player container? I'd like to have LAN clients on snapcast and broadcast over WAN using Icecast.

I thing that was the way I ran Mopidy usibg that config


snapcast_enabled = true
snapcast_port = 6680

enabled = true
protocols =
timeout = 5000

Link to comment
  • 2 weeks later...

Hello! attempting to get this up and running - I copied/added the xml and void files as specified, but still am getting the following error when trying to spin up the container: 


docker run
  -e TZ="America/New_York"
  -e HOST_OS="Unraid"
  -e HOST_HOSTNAME="Diskomo"
  -l net.unraid.docker.managed=dockerman
  -l net.unraid.docker.webui='http://[IP]:[PORT:8000]/'
  -l net.unraid.docker.icon='https://rockhost.com/wp-content/uploads/2018/11/icecast-server-hosting-cdn.jpg'
  -v '/mnt/user/appdata/icecast/icecast.xml':'/etc/icecast.xml':'rw'
  -v '/mnt/user/appdata/icecast/void.mp3':'/usr/share/icecast/web/void.mp3':'rw' 'infiniteproject/icecast'

docker: Error response from daemon: failed to create task for container: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: error during container init: error mounting "/mnt/user/appdata/icecast/icecast.xml" to rootfs at "/etc/icecast.xml": mount /mnt/user/appdata/icecast/icecast.xml:/etc/icecast.xml (via /proc/self/fd/6), flags: 0x5000: not a directory: unknown: Are you trying to mount a directory onto a file (or vice-versa)? Check if the specified host path exists and is the expected type.

The command failed.


any way to fix?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...