Jump to content

37 posts in this topic Last Reply

Recommended Posts

30 minutes ago, johnnie.black said:

Seems a little harsh no? :)

Just carrying forward the tone of the post I was replying to.

 

I replied to the original post with a little education about who we are, and what is the purpose of these forums. I gave the benefit of the doubt that the person was just googling around for similar situations, and posted here thinking we were a general tech support area.

 

The reply was less than cordial and did not address my question at all, so I replied in kind.

Share this post


Link to post
2 hours ago, jonathanm said:

Just carrying forward the tone of the post I was replying to.

 

I replied to the original post with a little education about who we are, and what is the purpose of these forums. I gave the benefit of the doubt that the person was just googling around for similar situations, and posted here thinking we were a general tech support area.

 

The reply was less than cordial and did not address my question at all, so I replied in kind.

Maybe some other Unraid users might appreciate the given background info.

Yes, I've found this thread via Google and took the time to register as a new user in order to help you guys. I've only worked with XenServer, Freenas/bhyve, VMware and Hyper-V so far. No experience with Unraid yet. The issue discovered by the OP is not related to Unraid, Hyper-V or any other hypervisor. It's just another bug in Windows 10 1903. So sorry for answering the OPs question. Goodbye.

Share this post


Link to post
7 minutes ago, laterv said:

So sorry for answering the OPs question.

I'm sorry I didn't see your post for what it was, a genuine effort to help.

 

Most of the time when a first time poster jumps in to a thread with a bunch of links to external websites, it's a spammer, only out to further their own agenda.

When you declined to answer any of my questions and instead got defensive, I took that as confirmation of your intent to help yourself instead of helping others.

Share this post


Link to post
Posted (edited)

Maybe the wall of links given in my first post might be a bit long winded. I'll try to sum up the info:

 

Windows 10 1903 introduces a new display driver for remote desktop sessions (WDDM based Indirect Display Driver - IDD). As soon as a rdp session gets disconnected (i.e. the user is still logged in, but the rdp session is disconnected) the new driver causes the Desktop Window Manager (dwm.exe) to max out one cpu core.

 

Until Microsoft comes up with a proper fix/update, the following workarounds are known so far:

 

- Revert back to Windows 10 1809

 

- Switch off the new driver by disabling the following Group Policy: "Use WDDM graphics display driver for Remote Desktop Connections" in "Computer Configuration\Policies\Windows Settings\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment\"

This Group Policy was introduced in Windows 10 1903. Configure it either locally via Group Policy Editor gpedit.msc or as a domain wide group policy object in Active Directory.

The new Indirect Display Driver is related to another RDP issue in Windows 10 1903 as well: RDP showing a black screen when trying to establish a session.

 

Because I don't wanna hijack this thread with possibly unrelated workarounds, I'm looking forward to feedback from affected users, first of all the OP.

Edited by laterv

Share this post


Link to post
Posted (edited)

I basically had the same issue (i just noticed i couldnt connect to my VM, when home i always saw that much CPU is used, count VNC to it) and coulnt find anything problematic, it happend like 2 days in a row, both times i hjard reset the VM and till then its working for weeks now without probelms.

Edited by nuhll

Share this post


Link to post
10 hours ago, laterv said:

Switch off the new driver by disabling the following Group Policy: "Use WDDM graphics display driver for Remote Desktop Connections" in "Computer Configuration\Policies\Windows Settings\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment\"

This is what I used and appears to solve the problem for now.

Share this post


Link to post
On 8/6/2019 at 8:42 PM, laterv said:

Maybe the wall of links given in my first post might be a bit long winded. I'll try to sum up the info:

 

Windows 10 1903 introduces a new display driver for remote desktop sessions (WDDM based Indirect Display Driver - IDD). As soon as a rdp session gets disconnected (i.e. the user is still logged in, but the rdp session is disconnected) the new driver causes the Desktop Window Manager (dwm.exe) to max out one cpu core.

 

Until Microsoft comes up with a proper fix/update, the following workarounds are known so far:

 

- Revert back to Windows 10 1809

 

- Switch off the new driver by disabling the following Group Policy: "Use WDDM graphics display driver for Remote Desktop Connections" in "Computer Configuration\Policies\Windows Settings\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment\"

This Group Policy was introduced in Windows 10 1903. Configure it either locally via Group Policy Editor gpedit.msc or as a domain wide group policy object in Active Directory.

The new Indirect Display Driver is related to another RDP issue in Windows 10 1903 as well: RDP showing a black screen when trying to establish a session.

 

Because I don't wanna hijack this thread with possibly unrelated workarounds, I'm looking forward to feedback from affected users, first of all the OP.

Just found that I had the same issue with both of my Windows 10 VM's. Changed the GPO setting as suggested and this resolved the issue after a reboot. Thank you for your suggestion. 

Share this post


Link to post
On 8/6/2019 at 1:42 PM, laterv said:

Maybe the wall of links given in my first post might be a bit long winded. I'll try to sum up the info:

 

Windows 10 1903 introduces a new display driver for remote desktop sessions (WDDM based Indirect Display Driver - IDD). As soon as a rdp session gets disconnected (i.e. the user is still logged in, but the rdp session is disconnected) the new driver causes the Desktop Window Manager (dwm.exe) to max out one cpu core.

 

Until Microsoft comes up with a proper fix/update, the following workarounds are known so far:

 

- Revert back to Windows 10 1809

 

- Switch off the new driver by disabling the following Group Policy: "Use WDDM graphics display driver for Remote Desktop Connections" in "Computer Configuration\Policies\Windows Settings\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment\"

This Group Policy was introduced in Windows 10 1903. Configure it either locally via Group Policy Editor gpedit.msc or as a domain wide group policy object in Active Directory.

The new Indirect Display Driver is related to another RDP issue in Windows 10 1903 as well: RDP showing a black screen when trying to establish a session.

 

Because I don't wanna hijack this thread with possibly unrelated workarounds, I'm looking forward to feedback from affected users, first of all the OP.

I did not revert windows, newest version, all updates, just disabled WDDM driver in GPEDIT, then rebooted VM.

fixed.

Share this post


Link to post
On 8/6/2019 at 10:49 AM, jonathanm said:

Then there was no need to post here.

Wow you're an azz. Who peed in your cornflakes this morning?

Share this post


Link to post
3 hours ago, Sleepyme said:

Wow you're an azz. Who peed in your cornflakes this morning?

It wasn’t this morning.

 

it was over 2 months ago.

 

it was also somewhat resolved.

 

I’m sure everyone appreciates your post.

 

plus: who would fall for that? Pee in cornflakes. You’d probably smell it before taking a bite, or, if the ratio of pee to milk was high, certainly taste it, but not take more than one bite. And if the ratio was low, then maybe you’d finish it all, and it would be ok because pee is usually sterile anyways so no harm no foul, I mean, haven’t we all gotten a little pee in our mouths at some point? That really is the basis of the insult, right? Asking if another person is mad because they got pee in their mouth. But you know what, we’ve actually all had worse. Did you know, I learned from watching myth busters, that our toothbrushes all have trace amounts of fecal and urine on them. So if you brush your teeth, you’re brushing on fecal and urine. So given that information, even off you consumed an entire bowl of pee soaked cornflakes, given the exposure to human waste via your toothbrush over your lifetime, I bet it doesn’t even increase your exposure by 1%. But if you don’t brush your teeth then your exposure will percentage probably higher, unless you’re into water play in the bedroom and golden showers. 
 

Long story short: wash your hands folks, and we live in the twitterverse now. 20 minutes ago is now yesterday, yesterday is now last week, last month was a decade ago, and 2 months ago is a trip to medieval times (the date range in history, not the super cool restaurant. Hey, I wonder if the food there gets horse fecal matter in it due to proximity....)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.