Jump to content
Skitals

[KERNEL] 6.8.0-RC5 w/ navi reset v2, vega reset, k10temp Ryzen patches, x570 onboard audio fix

49 posts in this topic Last Reply

Recommended Posts

25 minutes ago, cobhc said:

Thanks for this. Any chance of the final 6.8 kernel with the navi patch to test?

I will update for 6.9 rc1 when it's out. 6.8 final reverted to a 4.x kernel. 6.9rc1 will be identical to 6.8 final with the addition of the 5.x kernel.

Share this post


Link to post
On 12/11/2019 at 4:18 AM, Skitals said:

I didn't see any kernels with the latest version of the navi reset patch that came out nov 26. This should be identical to the unraid rc5 kernel with only the addition of the navi reset patch v2.

kernel-6.8.0-RC5-navi-reset-v2.zip 13.31 MB · 7 downloads

can you help me to apply a patch in unraid 6.8.0 rc5 kernel?

 

i need to apply vega reset patch like here, but with different vendor id

+DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_ATI, 0x687f, quirk_no_bus_reset);

PCI_VENDOR_ID_ATI supposed to be 0x6863 instead of 0x687f

 

I have search in internet how to apply it myself but no luck

Share this post


Link to post
15 hours ago, hygoggx said:

can you help me to apply a patch in unraid 6.8.0 rc5 kernel?

 

i need to apply vega reset patch like here, but with different vendor id


+DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_ATI, 0x687f, quirk_no_bus_reset);

PCI_VENDOR_ID_ATI supposed to be 0x6863 instead of 0x687f

 

I have search in internet how to apply it myself but no luck

just updated the first post with a kernel that adds this. ymmv, it's untested.

Share this post


Link to post

Updated to add flr kernel patch. You can now pass through 1022:1487 [AMD] Starship/Matisse HD Audio Controller on x570 boards! 

 

I haven't tested, but you should also be able to pass through the cursed isolated 1022:149c [AMD] Matisse USB 3.0 Host Controller. I believe you are best off using that controller for your unraid usb/keyboard/mouse/ups and passing through the other two controllers, however.

Share this post


Link to post
4 hours ago, Skitals said:

Updated to add flr kernel patch. You can now pass through 1022:1487 [AMD] Starship/Matisse HD Audio Controller on x570 boards! 

 

I haven't tested, but you should also be able to pass through the cursed isolated 1022:149c [AMD] Matisse USB 3.0 Host Controller. I believe you are best off using that controller for your unraid usb/keyboard/mouse/ups and passing through the other two controllers, however.

Hello, sorry for the noob questions.

it's compatible with unraid 6.8.1? thank you very much.

Share this post


Link to post
5 minutes ago, rachid596 said:

Hello, sorry for the noob questions.

it's compatible with unraid 6.8.1? thank you very much.

No, it have different kernel version, and array drivers so its not compatible

Share this post


Link to post

OK, and the 6.8.0 ? Because i don't have rc5

Envoyé de mon HD1913 en utilisant Tapatalk

Share this post


Link to post

This is only for 6.8.0-rc5.

 

To manually upgrade/downgrade, delete all the bz* files from the root of your usb drive (or rename them adding .bak to the end of the file name). Download rc5 zip here. Extract and copy the bz* files to your unraid usb drive. Download the kernel in the first post. Extract to your usb drive (overwriting bzimage, bzmodules, etc).

 

All your settings are in /config (and maying /syslinux/syslinux.cfg) so back it up before mucking around.

Share this post


Link to post
20 hours ago, skois said:

Only on rc5. I have Rc7 and array won't start. 

I did this post on reddit, you could try that to downgrade. Didn't tried it yet. So do that at your own risk 

https://www.reddit.com/r/unRAID/comments/erknff/downgrade_from_680_rc7_to_rc5/?utm_medium=android_app&utm_source=share

It works 👍🏻👍🏻👍🏻👍🏻. Thank you very much skois and skitals for the kernel. 

Share this post


Link to post

My unraid was on 6.8.1 already and decided to downgrade to the rc5 to see if all works for me.

 

I renamed my bz* files - copied in the rc5 bz* files - copied in the Skitals bz* kernel files.

I was forced to Delete VM and recreate new VM, as when I tried to pass through one of the USB devices listed inside Form view - Error about not understanding the "Vendor" of a PCI device. The recreate of the VM and then passing through the device and also passing through the nvme bare metal with the HostDev method in XML view worked perfect.

Afterwards I used the VFIO-pci-config tool to create the config file for passing the USB controller through BIND=08:00.0 08.00.1 08.00.3 05.00.0 07.00.0 0f.00.4

I have a extra USB controller card to pass to my VM.

 

And the AMD Navi bug......Working now perfectly.

On this note - could Limetech not build this is with a flag to enable if you have a AMD x5700 XT card and experiencing this reset issue....so it becomes mainstream. I am worried that we might get stuck on older builds and having to burden Skitals with rebuild requests of the kernel.

 

Cudos to Skitals for making the fix for us - love it !!!! thanks

 

CrystalDiskMark image included of Win10 VM nvme baremetal....not sure if its good or not.

Could not get a driver to replace the redhat one so still on virtualised driver.

crystaldiskmark.jpeg

Share this post


Link to post
13 hours ago, righardt.marais said:

My unraid was on 6.8.1 already and decided to downgrade to the rc5 to see if all works for me.

 

I renamed my bz* files - copied in the rc5 bz* files - copied in the Skitals bz* kernel files.

I was forced to Delete VM and recreate new VM, as when I tried to pass through one of the USB devices listed inside Form view - Error about not understanding the "Vendor" of a PCI device. The recreate of the VM and then passing through the device and also passing through the nvme bare metal with the HostDev method in XML view worked perfect.

Afterwards I used the VFIO-pci-config tool to create the config file for passing the USB controller through BIND=08:00.0 08.00.1 08.00.3 05.00.0 07.00.0 0f.00.4

I have a extra USB controller card to pass to my VM.

 

And the AMD Navi bug......Working now perfectly.

On this note - could Limetech not build this is with a flag to enable if you have a AMD x5700 XT card and experiencing this reset issue....so it becomes mainstream. I am worried that we might get stuck on older builds and having to burden Skitals with rebuild requests of the kernel.

 

Cudos to Skitals for making the fix for us - love it !!!! thanks

 

CrystalDiskMark image included of Win10 VM nvme baremetal....not sure if its good or not.

Could not get a driver to replace the redhat one so still on virtualised driver.

crystaldiskmark.jpeg

I'm glad it's working for you. On a couple of the 6.8 Release Candidates limetech did include v1 of the navi reset patch (this kernel has v2 which is improved but still not perfect). My understanding is it was causing issues with some hardware setups so they pulled it. I'm not sure what the rest of your hardware is, but it seems to work great in conjunction with amd x570 boards. The patch, as it's written, is all or nothing and applies to everyone with a navi gpu. Perhaps limetech would consider including the patch again if it was written to be exclusively opt-in with a kernel flag. I don't mind building my own kernel (and sharing), but I can understand why it would be frustrating to be dependent on someone like me to keep this updated. 

Share this post


Link to post
4 hours ago, Skitals said:

I'm glad it's working for you. On a couple of the 6.8 Release Candidates limetech did include v1 of the navi reset patch (this kernel has v2 which is improved but still not perfect). My understanding is it was causing issues with some hardware setups so they pulled it. I'm not sure what the rest of your hardware is, but it seems to work great in conjunction with amd x570 boards. The patch, as it's written, is all or nothing and applies to everyone with a navi gpu. Perhaps limetech would consider including the patch again if it was written to be exclusively opt-in with a kernel flag. I don't mind building my own kernel (and sharing), but I can understand why it would be frustrating to be dependent on someone like me to keep this updated. 

Hello Skitals, i have a question, is it hard to compile for 6.8.1? Thank you very much 

Share this post


Link to post
2 hours ago, rachid596 said:

Hello Skitals, i have a question, is it hard to compile for 6.8.1? Thank you very much 

I'm guessing that depends on what patches you need. I'm using this kernel on 6.8.0 for the Navi reset bug as I don't yet need x570 support.

 

 

Share this post


Link to post

Thank you very much, i want Only x570 patch for Audio passthrough and maybe navi reset because i Just ordered a 5600 xt

Envoyé de mon HD1913 en utilisant Tapatalk

Share this post


Link to post
On 1/24/2020 at 1:12 AM, rachid596 said:

Hello Skitals, i have a question, is it hard to compile for 6.8.1? Thank you very much 

The same as compiling any other linux kernel. The unraid specific patches you will find in /usr/src, including the kernel config file.

Share this post


Link to post

Is there any update on the recent version 6.8.2 really need the temps working isn’t messing around with the kernel risky is there a detailed guide to applying the kernel fix? Can’t see why the guys at unraid can’t put this in a fix looks like a lot of people having the same issues I love unraid but I worried about losing my system to high temps

Share this post


Link to post
On 12/10/2019 at 4:18 PM, Skitals said:

build 2020.01.21:

6.8.0-rc5 kernel with

navi reset v2

vega reset patch* (used in conjunction with this script)

k10temp Ryzen patches from 1/18/20

(new) Fix for onboard audio passthrough on x570

 

*modified to add 0x6863 in addition to 0x687f

 

 

6.8.0-rc5-Skitals-2020.01.21.zip 18.16 MB · 25 downloads

Hey there bud, bit of a noobie here when it comes to this level.  Running a 3900X on an ROG B450-I board with a Strix Vega 64 and still back on 6.7.2.  Looks like upgrading to your build is my best bet now having just moved to the Vega 64 and discovering it is not a smooth sailing as I hoped (MacOS VMs so needed to keep to the Radeon camp).  Sorry for asking such a basic question, but perhaps it could also help others, what is my best bet for upgrading to your specific build with these fixes as I've not done such an upgrade before.

Edited by TheTechnoPilot

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.