Monitor display is blank after Unraid is up and running

Recommended Posts

Unraid is 6.8.2 and I have had no recent issues with my server at all.   I have a SuperMicro X11SSM-f, and full specs in are in my sig.


I built a new windows 10 pc and I was having KVM Console connection issues with my new pc, so opened a case with Supermicro.  They directed me to update both my system bios and the IPMI firmware to fix the issue, and to use a new version of IPMIView.


I have updated the bios and the BMC fw and the process worked without any errors.  I followed the instructions exactly.  I did Restore Settings to Default after the bios update, and then went back in and put back the settings as they were before (working system with no issues at all).   The motherboard bios shows it is now 2.3.  I took pictures of every bios screen before doing anything so I could be sure to put everything back.


 Before Starting the BMC firmware update, I unchecked both boxes per the instructions, means those settings were put back to factory default as well.  After the fw update I connected to the server BMC via web gui, I updated the BMC password and made no other changes.  Firmware shows 1.58.


I can boot the system to the Bios screen and I can also boot to the Shell and I see output on the attached monitor.  I can use the web gui and login to the BMC without any issues.  The System screen shows the same thing as the attached monitor and I can also iKVM and take control of the server.  So far everything is good.


The IPMI application from my pc works now, the KVM Console works again so the updates fixed that issue.  Although it seems the BMC web gui has all the same features of IPMI View, so I’m not sure I need that application now.  


Now the big issue.  When I boot to Unraid I can see the initial boot screen for Unraid on the attached monitor as it is loading the unraid OS.  However, after it boots, the attached monitor goes blank and I cannot see the unraid screen anymore.  I normally would see the Unraid login screen.  I also connect to the server BMC via web gui and when it shows the server screen, it too is blank, just like the attached monitor.  When I use iKVM  via BMC web gui, it also shows the blank screen if I take control of the sever.   However, if I just connect to the server via the browser (regular interface - Not BMC interface), my server is up and running perfectly.  I just no longer have video to the attached monitor.  When I go to reboot Unraid, it drops out of the unraid OS, ie shutting down, I again see the screen logs as it shuts down, so it goes back to normal display on the monitor.  It looks like I only have the issue when unraid is fully running.  I of course did not have this issue with Unraid prior to the Bios and BMC firmware updates.


Any ideas?

Link to comment

Do you have Plex setup for hardware encoding/decoding or anything where you are passing the GPU to a vm or docker. I have the same board as soon as I pass the intel GPU over to my plex docker I lose kvm support. This is issues with how supermicro handles integrated GPU's vs using the Aspeed GPU. 

Edited by halfelite
Link to comment

Thanks for your reply.  I don't use plex at all and I only have a few dockers installed.  Also, it's not just KVM, I also do not have any video to the attached monitor.


Just to confirm, I just stopped and disabled all of my dockers, but that didn't resolve the issue.


I've never had a pci video card in my server.  I'm using the CPU onboard GPU.


I do find your issue interesting, so thanks for sharing.


Link to comment

It would not be the Docker itself. Have you modified the go file to include the following


modprobe i915

chmod -R 777 /dev/dri


as that will cause this.


Also if not I would check the Bios settings for using the onbaord gpu. That would be the second spot to look. If you are using the VGA out on the X11SSM it is not connected to the iGPU its only connected to the Aspeed GPU for the BCM. Its under PCI settings if I remember right. 




Link to comment

I do not use a Go file anymore and haven't for a long time, so that can't be it.  Also, just to point out that I have not made any changes to my server except the bios updates and everything on the server was working fine before that.


I just went back and checked the bios settings and I do not find anything to change.  There are a couple of new options in the bios after the update, see attached pics.  Thanks for the info on the igpu.  I'm using the vga port on the motherboard connected to a monitor.  


I do have a ticket open with Supermicro as well, but they have not yet responded to it.


Please take a look at the pics and let me know if you see anything that I should try changing.  After the bios update, I went back and changed everything to match what I had before.


The last pic I included is the last screen I see on the monitor attached to the server, before it goes dark.


Thank you!

pci bus before bios update.JPG

pci bus updated bios.JPG

graphics config before bios upgrade.JPG

graphics cofig after update.JPG

video output right before blank.JPG

Link to comment

I heard back from Supermicro, and given you have the same mb, you will run into this same issue if you upgrade the bios and fw.


Here are the steps to fix it.  I will try this in the next few days and report back.


1. The KVM console file from the WEBGUI is JAVA applications, you will need install JAVA to run it.

2. The latest BMC FW contains a security fix which require to update ASPEED drivers to the latest 1.10 for the OS, it looks like your Unraid OS does not have it so it shows black screen.
To fix this,
1. Please roll back the BMC drivers to previous 1 version. FW 1.48 (Attached)
2. Do AC off (remove power cord), after the FW is downgraded to FW 1.48 successfully.
3. The OS should be fine with FW 1.48, then download the ASPEED drivers from our SMC website to do the drivers update.
4. Upgrade the system to the latest BMC FW. 


Link to comment

Supermicro came back and said I now need to update the ASPEED drivers inside Unraid.  Anyone have instructions on how to do that?


Here is the link to the new drivers,


Would be great if these new drivers were just added to Unraid.  :)


I'm told that after I do this, my video output will be restored. 


I forgot to mention that Support had me roll back the BMC fw to 1.48 and  the video is once again working normal.  I'll have to figure out how to install the new ASPEED drivers and then I will be able to upgrade the BMC fw to the latest,.  Latest contains Security fixes.

Edited by Switchblade
Link to comment
  • 9 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.