Solution to Failed to Allocate memory for kernel command line, bailing out on Dell Servers


n1L

28 posts in this topic Last Reply

Recommended Posts

Well, I have an archlinux box. Installed the syslinux package there, and copied all files over onto the files with the same name. I can't really remember which files I put in which folder, so I packaged you the files i have on my stick. Copy these to your stick overwriting the existing files.

 

Good Luck, let me know if it works.

syslinux_update.tar.bz2

Link to post

Thanks for the files but unfortunately it didn't work. I made a new Unraid stick with the unraid USB creator. I used the next version(Beta) with my ip settings. After that i copied the files you send and replaced the one on the USB stick. But i'm still getting the "Failed to Allocate memory for kernel command line, bailing out" error.
Any more advice what i could try? 

Link to post
  • 1 month later...
  • 1 month later...

@n1L and anyone else working on this, there is serious interest in addressing this and fixing this bug/inadequacy of unRAID (see bug report and post:

)

 

Could you please either 1) document the process of creating the USB in Linux with details or 2) share a currently bootable version of the image that we can test and dissect? 

 

It appears the most recent version of syslinux is 6.04 from https://mirrors.edge.kernel.org/pub/linux/utils/boot/syslinux/Testing/ but I don't see any beta here. (Changelog) There might be some new development here: https://wiki.syslinux.org/wiki/index.php?title=Development but I don't know how to compile that to be used in our case. 

 

I believe the developers will implement the fix if we can get sufficient details and steps here.

Edited by princ3ssa
Link to post

Fuck, I forgot. Again! Thanks for bugging me. I have no documentation, I just worked on it till my stick was working. I'll have to try to get a new one running again, noting the steps I did. I'll try to find some time at the end of next week. Honestly I was SURE that the developers would switch the build tool to a newer syslinux version immediately, which should have fixed that problem. They are the ones getting paid for it, not me...

 

If the developers would want to do a fix for this, they really only would have to use a newer Syslinux Version in their USB Creator. This should be straightforward to implement. The Problem with my method is that I create an official USB stick and then try do replace all the files of syslinux that I can find with the newer version afterwards, trying to skip the files with unraid specific configuration. I thought it'd be easy to recreate with this Information. But if someone overwrites to much it'll not work if someone overwrites to less it'll not work. Problem is I don't have a clue which files I replaced. The developers shouldn't have this problem. As replacing the files didn't work for "Yourself" maybe it's only the bootsector. I'll have to do some tests.

 

The developers don't seem to care. Maybe the percentage of old Dell's is to small. I'm just using my stick and I'm at the moment not risking doing regular updates. (Because of this it's time I do a manual update anyway) I hope I don't fry my Array by doing it.

 

As I don't have Arch on my main machine anymore I'll try to script this in WSL as platform independent as possible which will be better for others to reproduce.

 

I also have no Idea which version of syslinux it was, As I was using Arch back then it could have been a version compiled from AUR. I remember that i found an information which syslinux version fixed it, i'm sure it was an rather old one. The syslinux files in the repository of the USB Creater were updated 2 Years ago, so no one tried that. As the download on the website still points to the old 1.6 release it wouldn't help much anyway. I could try to update the USB creator myself, but, I'm not setting up a whole developement environment to fix this!

 

I'll however try to create a patch script which will get the stick created with the USB Creater tool, to boot on my Dell. I'll have to, to get my stick to the new version anyway, as I simply don't know if an update over the webinterface will fry the fix, or not.

Link to post
7 hours ago, n1L said:

Honestly I was SURE that the developers would switch the build tool to a newer syslinux version immediately, which should have fixed that problem. They are the ones getting paid for it, not me...

As most of the veterans here will tell you, except in the cases of a gaping security hole or potential array corruption, there is no immediately with the unRAID developers.  

Quote

The developers don't seem to care.

Its more likely that they are unaware of the issue or that it is just to far down the priority queue. There are so few actual employees of Limetech that things tend to move slow and they dont monitor every forum post. It looks to me like the Bug report post is extremely new.

Edited by primeval_god
Link to post

So @n1L you're using an MBR/BIOS boot and not GPT/UEFI boot on the Dell server? 

 

If so, do you not have the 2TB drive size limit that Dell warns about? I think the Dell support people who said this were wrong in saying the limits affect Windows and Linux and maybe it's only Windows....

Link to post

AFAIK, that *2TB* limit would only affect the boot drive. When using unRAID, you will be booting from a small USB stick and whether you use BIOS or UEFI will be irrelevant. In order to format a drive larger than 2TB to full capacity, you would need it to GPT since MBR support is up to 2TB.

Link to post
Posted (edited)

I'm using uefi i think. Maybe got that mixed up. However the only difference besides the files i posted above is that i ran syslinux --install which i presumed changed something in bootsector or something like that. I've never fully checked which parts are involved in UEFI booting.  

 

Edited by n1L
Link to post

Alright, so this is making some more sense, but can you give some explicit stepwise instructions as to what you did? I tried with both "Allow UEFI Boot" and not with it. So here for example are my steps that I tried (that have not worked):

1) insert flash drive into Windows computer

2) run Unraid USB Flash Creator with these settings (this is for the MBR/BIOS attempt that also failed):

mbr.jpg.3295c1fb8bda0dd04d142d8111b6fcc0.jpg

3) took USB flash drive out of Windows computer

4) inserted USB flash drive into Linux computer (Pop!_OS in this case)

5) wrote your MBR image with this command:

sudo dd if=MBR_HardDisk4.dat of=/dev/disk/by-label/UNRAID bs=446 count=1

6) took out USB flash drive

7) inserted USB flash drive into R710 with BIOS boot turned on

8 ) started R710 server and waited for it to try to boot - failure to detect a boot device.

 

Link to post

Hoping for some more details from @n1L following my example format above, but no word yet... The key here is that we lock into a reproducible process. I'm hearing that one other R710 user has been able to use the existing Unraid tool to make BIOS boot USB flash drives successfully that boot...

Link to post

I only have a r410 at the moment to test with as far as Dell systems go. I was able to boot off of it on my custom built server, it has a supermicro board in it. I have a friends server here as well, its a Dell r730xd and it boots off the regular unraid tool bios boot usb fine. Makes no sense!

 

Link to post

Hey guys, I finally got it working. I will post the start to finish down here:

1.Create a new usb via Windows using the Creation tool (I used the stable version in combination with a USB 3.0 Flash drive) 

2.Went to Linux (ubuntu in my case) installed the newest version of syslinux on ubuntu (sudo apt install syslinux)

3.Used Make_bootable_linux (might not be needed) (command: Sudo bash make_bootable_linux) Remember to put this in a different folder NOT the USB drive

3.In the BIOS of my Dell R510 i switched the BIOS to BIOS mode, NOT UEFI.

4.Reboot to have this go into effect

5.In the Dell BIOS turned USB flash drive emulation type to Hard disk.

6.Boot from flash drive and everything works now.

 

I hope this works for you aswell.

 

EDIT: Typo

Edited by Yourself
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.