• docker "host access to custom networks" needs to be reenabled on each unsafe shutdown

    • Annoyance

    just to keep this issue alive as there are more open questions regarding this and its still open in 6.10 rc2


    description is simple as the topic, whenever there was a unsafe shutdown, starting unraid with docker setting




    will result in a non working state, stopping/starting docker service or rebooting clean resolving the issue.


    easy to reproduce and annoying when you externally working on the mashine and hard reboot externally while using as sample ssh guac to access it again, but doesnt work as described above, so only VPN backdoor to restart it.


    may a workaroud possible if its a bigger issue ? like you can trigger parity after a unclean shutdown, trigger a docker service restart too ?


    tested here from 6.92 until today 6.10 rc2 on 4 different mashines with the same result, open issues as reminder






    • Like 2

    User Feedback

    Recommended Comments

    i have the same problem.

    after an unclean shutdown (rc2 crashes sometimes, there are many other bug reports about this), i have to disable and reenable this setting. very annoying.

    • Like 1
    Link to comment

    It works fine when using a static IP address assignment for Unraid.


    Using DHCP may cause a race condition, and the shim network is not created when your DHCP server is slow in responding.


    Link to comment
    On 7/7/2022 at 12:13 PM, bonienl said:

    It works fine when using a static IP address assignment for Unraid.


    Using DHCP may cause a race condition, and the shim network is not created when your DHCP server is slow in responding.

    sorry @bonienl but i cant confirm this, as i didnt had any "unsafe" shutdowns lately i just forced one and ...





    and i use a static assignement since day 1 i use unraid (all local devices here use static ip's here)




    docker setting




    so for now i have to stop/start docker service to get the "host access" back to work or make a clean restart ...


    then its back again




    as i stated, no chance to make a simple routine ? unclean shutdown = docker service restart ;)


    Link to comment
    9 hours ago, ionred said:

    Can confirm all unraid related ips on my system are static as well 

    x2, static ip as well

    Link to comment

    I am just using bridge for all my containers, unraid uses DHCP client to get IP (2xNIC in LACP), and on every reboot, I need to turn docker off and on again. then it works. I am on 6.11.1, still present.

    Link to comment

    may as friendly reminder, 6.12 has still the same issue ...


    unsafe shutdown, reboot, most common ends in broken (missing shim) host access.

    Link to comment

    just happened to me.... again. damn.  shows enabled, but things stopped working.


    it has felt so random. sometimes it works, sometimes it dont.  OMFG

    enable/ disable docker and my dockers can again talk to eachother.

    when this happens my home assistant docker on HOST cant see/talk to other dockers on br0.
    i had to reconfigure swag with some hardcoded address to access guacamole from outside the lan.

    Edited by TRusselo
    Link to comment

    I just had this problem also.  Took me a while to come across this thread.  My nginx docker hung on an update and wouldn't quit.  I couldn't force the docker container to stop so I had to do a hard reset/unclean shutdown of Unraid.  I've been spinning my wheels for the last hour trying to figure out why I was getting 502 bad gateway messages from nginx.  Turns out I had to disable/reenable host access to custom networks.  


    Just wanted to post this to say, this is still valid and apparently has been going on for quite a while.

    Link to comment

    Also posting here as this is making my time a pain in the arse too. I'd say this is not an annoyance but also affects functionality as it makes automatic recovery unlikely.

    Edited by Jambo
    Link to comment

    Same issue here running latest version of Unraid 6.12.3 with static IP assignment for host. How has this not been fixed already??

    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.