Jump to content

cen

Members
  • Content Count

    29
  • Joined

  • Last visited

Everything posted by cen

  1. Had the same thing happen to me yesterday. Changed a path folder and after applying the changes it restarted the docker and I had to reconfigure shares, login and the friends-list was empty (next time I should remember to export and save those settings and lists).
  2. I adjusted the folder mapping according to the README. Argh, thanks for the hint! I hadn't seen that the container needed 6080 and thought it needed 5900 published. The ports were really swapped in my config (sorry for being so blind). It works now and I have access.
  3. @realies, yes. I tried several ports thinking I maybe got something wrong. Removed, updated and reconfigured the container several times. Just tried it again with @iilied hint of port 6080 and unprivileged. It starts sucessfully with the unraid GUI saying: If in the unraid docker menu I click on the symbol and WebUI it sends me to [unraid.ip]:5950 (which leads to connection refused) even though I configured 6080. If I then manually go to [unraid.ip]:6080 it gives me the "ERR_EMPTY_RESPONSE". Is there any way via CLI inside the docker I can check what is going wrong? Accessing the other docker has been working perfectly for years (on port 9099). The other krusader docker on port 6080 is stopped and not running.
  4. @realies thank you for the update. I still can't get to the WebUI even though the docker seems to start ok. I've tried it with privileged on or off and using different ports and I even tried to set it up via CLI instead of the unraid GUI but nothing works.
  5. Hi @BLKMGK , since I created my encrypted UD drive just like you did and I just stumbled upon this thread (still running on 6.7.2 but planning on updating to 6.8 soon, like maybe tomorrow)... does your last message mean I can update without a problem and my encrypted UD drive would mount when I start the array as usual and without problems?
  6. wonderful! so I can kick my VM-4-wireguard soon... =)
  7. any news on wireguard in unraid? I'd like to connect my unraid build to my public server already running wireguard as a secure tunnel to home. I guess now the only way would be to have an additional VM running as the wireguard client?
  8. oh nice! thank you for the links. MV has been one of my favorite applications during the past decades (I can't really remember when I started using it) be it as a windows program (that has to be a couple of years back since I last uses windows;) or as a webapp and recently I started using the docker version on my root server (not the unraid home build). Will definitly try it out on unraid soon. I just found out last week that the webapp version of MV even has a (not so well documented) API. That got me all excited (thinking about automatically pulling my sons favorite show "Sendung mit der Maus" every Sunday) but I couldn't quite get it working the way I intended.
  9. @ridge thank you for the tip. Nope, doesn't change. The docker starts as the log says it all started sucessfully but the webpage does not load. I tried with port 6080 and priviledged turned on and also turned off. Really don't know why this shouldn't work. Is there something from the bash inside the docker I could maybe check? The krusader docker ist stopped and on it the port 6080 works well for the vnc part.
  10. Yes I know. Which is why I am trying to get it to work via the docker tab (see for example my question a few posts above where maybe you could help me?). @iilied is trying to get it working in unraid cli so I thought my answer would at least help him.
  11. @iilied you can add paths via dockers volume bind option when starting the docker via your cli command. You would have to add every folder you want accessible in the docker via: -v /mount/path/to/unraid/folder/:/where/to/mount/in/container/ (and for every next folder which should also be accessible you need another -v /unraid/folder/:/container/folder/ ). The same works with ports so if you want to change the port the container is available from you would need to add this into your cli command: -p 5950:5900 (for using 5950 instead of your 6080). Hope that helps.
  12. I've tried several configuration options and the docker starts (from what the logs tell me) but I cannot access the webGUI. In the browser tab I get: Is there anything I'm missing? @realies , @ridge do you see something wrong in my config?
  13. @jonathanm and @THO thank you very much for the workaround and the hint! It worked just fine and I could encrypt my brand new drive which will not be part of the array and only be mounted in unassigned devices.
  14. Nevermind, I just downloaded the rename version I like from github as prename.pl into usr/bin and can now use prename with the regex's I am used to.
  15. Hi there, over the years I have been using the bash rename for renaming the music (mp3 and/or flac) I buy (which of course never comes named as I prefer). I would also like to use this on unraid when I log in via SSH or when I use the link to the (web)Terminal but it doesn't work as expected (due to the fact that there are at least 3 different rename's out there). I guess upto now I never had the problem of a non working rename command as I would always automatically install the perl version of rename with the regex renaming I am used to. On unraid it uses rename from unix-util. Is there any non-system-corrupting option (in case other programs use the unix-util rename) of using the perl rename in unraid? Thank you.
  16. Hi @nekromantik I just had a similar problem in the transmission_vpn docker where it would constantly restart with the 'RTNETLINK answers: Permission denied' error. Solved it following this guide https://stackoverflow.com/questions/50600116/ipv6-with-openvpn-in-docker by editing the settings of the docker, while changing from the 'Basic View' to the 'Advanced View' of the settings and then adding to the part 'Extra Parameters:' this: '--sysctl net.ipv6.conf.all.disable_ipv6=0 ' . After applying the docker started without problems. Hope it helps.
  17. Hi, I feel kindof dumb because I cannot get the Transmission_VPN installed (had no problem with e.g. a krusader docker). How do I add the template? I added the link to https://github.com/clowrym/docker-templates/blob/master/Transmission_VPN.xml into the docker template repositories but then I cannot use it when adding a docker. It is not shown in the dropdown "Select a template". Nevermind... I didn't see that I could update the CA-plugin... now I feel even more dumb 😃
  18. As a quick fix you could add a cronjob to regularly do a 'chown -R nobody:users ...' to your complete-directory.
  19. Array is up and running with formatting the new drive and parity-sync in progress. I guess this will take a while so I'm off to bed. Thank you for the really fast help and keeping the nerves with the tired newbie that I am.
  20. ok thank you. Clearly logical of course and I guess I could've thought that one through but it s 1 am over here and past my bedtime but I wanted to get the build started for leaving it running over night.
  21. ok but should I then take out the "old" disc which already has data on it since the other one is going to be encrypted or does it not matter because parity check will be done on both discs once the parity drives are set? and should I first start the encryption of the new drive or first start the parity and then format the new drive?
  22. Just wondering: if I now have two data drives (the old one and the new encrypted one) how will Unraid then know which drive to do the parity check on. Won't both be added to the array? Sorry for being so new to Unraid.
  23. hmm, ok. I'll try that. Thank you for the advice.
  24. No the disc has not been touched yet (same xfs fs) except for hooking it to a other SATA port. The drive letter is also still the same (sdb). There is a green circle next to the drive.