Jump to content

WeAreTheDynamite

Members
  • Content Count

    16
  • Joined

  • Last visited

Community Reputation

3 Neutral

About WeAreTheDynamite

  • Rank
    Member
  • Birthday 03/17/1983

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Without the mods was unsuccessful but after wiping the appdata folders and reinstalling the container, I seem to be up and running! Thanks so much for your help! 😊
  2. The mods and serverconfig.xml were transferred using windows file explorer directly into the appdata/7dtdbeta folder, runing chomd/chown from the terminal seems to have fixed the permission issue. Its now using between 15-300MB of ram just cycling through a boot loop... Loading Steam API...Warning: failed to init SDL thread priority manager: SDL not found OK. Connecting anonymously to Steam Public...Logged in OK Waiting for user info...OK Success! App '294420' already up to date. ---Prepare Server--- ---SaveGameFolder location correct--- ---Savegame location found--- ---UserDataFolder location correct--- ---UserDataFolder location found--- ---Server ready--- ---Start Server--- Found path: /serverdata/serverfiles/7DaysToDieServer.x86_64 /opt/scripts/start-server.sh: line 91: 66 Aborted ${SERVER_DIR}/7DaysToDieServer.x86_64 -configfile=${SERVERCONFIG} ${GAME_PARAMS} ---Checking if UID: 99 matches user--- usermod: no changes ---Checking if GID: 100 matches user--- usermod: no changes ---Setting umask to 000--- ---Checking for optional scripts--- ---No optional script found, continuing--- ---Starting...--- ---Update SteamCMD--- Redirecting stderr to '/serverdata/Steam/logs/stderr.txt' [ 0%] Checking for available updates... [----] Verifying installation... Steam Console Client (c) Valve Corporation -- type 'quit' to exit -- Loading Steam API...Warning: failed to init SDL thread priority manager: SDL not found OK. Connecting anonymously to Steam Public...Logged in OK Waiting for user info...OK ---Update Server--- Redirecting stderr to '/serverdata/Steam/logs/stderr.txt' [ 0%] Checking for available updates... [----] Verifying installation... Steam Console Client (c) Valve Corporation -- type 'quit' to exit -- Loading Steam API...Warning: failed to init SDL thread priority manager: SDL not found OK. Connecting anonymously to Steam Public...Logged in OK Connecting anonymously to Steam Public...Logged in OK Waiting for user info...OK Success! App '294420' already up to date. ---Prepare Server--- ---SaveGameFolder location correct--- ---Savegame location found--- ---UserDataFolder location correct--- ---UserDataFolder location found--- ---Server ready--- ---Start Server--- Found path: /serverdata/serverfiles/7DaysToDieServer.x86_64 All is fine on my primary server which is on the stable release branch, and i don't think I've done anything different.... I've probably missed something.
  3. Upon a second restart, it appears the container is trying to set file permissions but is being denied access to do so...
  4. Mine seems to have Downloaded after a reboot of the docker, but it still won't start... Here are the logs. Success! App '294420' fully installed. ---Prepare Server--- ---Moving SaveGameFolder location--- ---Savegame location found--- ---Moving UserDataFolder location--- ---UserDataFolder location found--- ---Server ready--- ---Start Server--- Found path: /serverdata/serverfiles/7DaysToDieServer.x86_64 [S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed. Setting breakpad minidump AppID = 251570 ---Checking if UID: 99 matches user--- usermod: no changes ---Checking if GID: 100 matches user--- usermod: no changes ---Setting umask to 000--- ---Checking for optional scripts--- ---No optional script found, continuing--- ---Starting...--- ---Update SteamCMD--- Redirecting stderr to '/serverdata/Steam/logs/stderr.txt' [ 0%] Checking for available updates... [----] Verifying installation... Steam Console Client (c) Valve Corporation -- type 'quit' to exit -- Loading Steam API...Warning: failed to init SDL thread priority manager: SDL not found OK. Connecting anonymously to Steam Public...Logged in OK Waiting for user info...OK ---Update Server--- Redirecting stderr to '/serverdata/Steam/logs/stderr.txt' [ 0%] Checking for available updates... [----] Verifying installation... Steam Console Client (c) Valve Corporation -- type 'quit' to exit -- Loading Steam API...Warning: failed to init SDL thread priority manager: SDL not found OK. Connecting anonymously to Steam Public...Logged in OK Waiting for user info...OK Success! App '294420' already up to date. ---Prepare Server--- ---SaveGameFolder location correct--- ---Savegame location found--- ---UserDataFolder location correct--- ---UserDataFolder location found--- ---Server ready--- ---Start Server--- Found path: /serverdata/serverfiles/7DaysToDieServer.x86_64 [S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed. Setting breakpad minidump AppID = 251570 The server doesn't seem to actually start, though I do have the server files in appdata...
  5. I'm having trouble installing the 7dtd -beta latest_experimental, just keeps boot looping Steam Console Client (c) Valve Corporation -- type 'quit' to exit -- Loading Steam API...Warning: failed to init SDL thread priority manager: SDL not found OK. Connecting anonymously to Steam Public...Logged in OK Waiting for user info...OK ---Update Server--- Redirecting stderr to '/serverdata/Steam/logs/stderr.txt' [ 0%] Checking for available updates... [----] Verifying installation... Steam Console Client (c) Valve Corporation -- type 'quit' to exit -- Loading Steam API...Warning: failed to init SDL thread priority manager: SDL not found Any idea? Cheers!
  6. Log posted in pastebin. https://pastebin.com/RAAu9huL Thanks so much for your help! If you need a copy of the game for testing, happy to gift it to you on steam as a small token of appreciation! Perhaps you could shed some light on the appdata path thing for me though? I've seen a few differing ideas on this. My understanding is /mnt/user/appdata with the share set to cache only is the "best" way to do this? But i've seen people suggest using /mnt/cache/appdata - this maps it directly to the drive without creating an exportable user share as far as I know? Wouldn't your suggestion of using /mnt/user/cache/ just create a new user share called cache with which I could set any of the same parameters as my current appdata share? Sorry, I know it's off topic but I'm interested in peoples different ideas on the best way to do things.
  7. Hey, I seem to be having the same issue with the 7 Days to Die container. Was working great, I moved my appdata share onto my cache drive and now i'm getting the same error. Loading Steam API...Failed to init SDL priority manager: SDL not found Failed to set thread priority: per-thread setup failed Failed to set thread priority: per-thread setup failed Hopefully I haven't killed it! Any ideas? Cheers.
  8. I’m in! Cheers! Now to figure out how to use it! Thanks for your advice, much appreciated. Hope you have a pleasant weekend away from home. 👍🏻
  9. But if i redirect to https://<mydomain> the web ui fails to load as it's internal address is http://192.168.X.X:1337, so it will not load as a secure page... As I said, I'm probably just being dumb here, and I am a complete noob to NGINX, but all of my testing has been unsuccessful...
  10. Hey, sorry if i'm just being super dumb... I've got the csmm installed and I can launch it, configured nginx with the domain and stuff, the trouble is, when I try and authenticate using steam, the redirect when clicking login is taking me to https://<mydomain> rather than http://<mydomain> Is there anyway to get the web UI to launch with https rather than http? I may well be wrong about this, but I think this will make the redirect work... There may be something I can do using NGINX, but I'm not yet familiar enough with it to figure it out... Any help is greatly appreciated! Cheers!
  11. Seems to be sorted! Thank you so so much! =D
  12. I'm installing from CA... So the behaviour has changed slightly. I remove the container and delete the appdata folder, re-install the container from CA, whilst the container is downloading the server files, the appdata folder is accessible, then once the server has actually started initialising itself, that's when the appdata folder seems to lock itself. I'm using UID - 99 and GID - 100, so just the defaults...
  13. Seems to still be happening for me on 7DtD. I removed the container and deleted the 7dtd appdata again, the re installed it, same symptoms. =(
  14. So i removed the container, deleted the 7dtd appdata folder (and the others I'd generated trying to fix this.) re-installed and upon first boot, I still had no access to the appdata folder. I also tried the folders for my other containers, and I could access them all bar 7dtd and steamcmd. I don't think I have any funky configuration relating to my appdata share, though I do run my main storage share using permissions from active directory; so my un-raid box is on my domain. The issue seems to have only cropped up after joining the domain though, so I'm not sure if it's related? Edit: I tried chmod -R 777 on the 7dtd appdata folder; I was able to access it and edit the serverconfig.xml. After saving and restarting the container, I once again lost access.
  15. I’m unable to delete the appdata folders as I don’t have permissions for them, I’m able to point the container to a different path and that works initially, so I start the container, can edit the server config file, restart the container, the permissions change again and I can no longer access the folder.