Jump to content

How to diagnose what maxed out my RAM and CPU

Recommended Posts

I had a Windows VM running on 6 out of 12 cores and Plex Docker (along with a Calibre and Kitana Docker) running. When I tried to load Plex on my TV and phone today it didn't work, going into Unraid the Docker and VM page wouldn't load any images and I could see my CPU and RAM were both at 100%.


They've since declined from 100% but are still high. The VM stopped, Plex is still running but not accessible.


I've attached the log but not sure how to read it. Likewise reading the log from the dashboard did not help. I saw messages about broken pipes and  missing csrf_token but am unclear what that means.


Should I dedicate cores to Plex to prevent this as it looks like the problem may have started when I tried to load Plex.


Link to comment

Your system share is on the array. You want appdata, domains, system shares all on cache and set to stay on cache so your dockers / VMs won't be impacted by slower parity and so they won't keep array disks spunup since they will always have files open.


Is Plex your only docker? Do you have any VMs?

Link to comment

Thanks Trurl, I'll look into that, my 500GB SSD arrived today so I will set that up as a cache drive, I'll look into the Unraid docs to make sure I do it right. By shares need to be set on cache, does that mean selecting "Yes" for using the cache pool?


Yes I have multiple dockers and a VM. 

Edited by phoebus
Link to comment

There is a Help (?) toggle on the main bar to toggle Help for the whole webUI. You can also toggle help for a specific setting by clicking on its label.


Cache-yes means write to cache if there is room then move to array.

Cache-prefer means write to cache if there is room and prefer to keep on cache. Move from array to cache if there is room. Prefer is what you want for those shares.


Mover cannot move open files and it will not move duplicates. You have to go to Settings and disable Docker and VM Manager so Mover can move these to cache.


Link to comment

Thanks Trurl, even with the "?" button I was struggling to get my head around Cache pool and what it does or does not do, the terms aren't that obvious to me as a newbie.But  I'm going through the Replacing a cache drive FAQ and that is making things a bit clearer to me. 


I found Fix Common Problems helped me understand what I needed to set to Yes cache and Only cache.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...