VMWare tools for unRAID

Recommended Posts

  • Replies 331
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

All good here:


I'm running ESXi 5.1, and unRAID 5.0-rc10.  With open_vm_tools-2012.10.14.874563_unRaid5.0rc10-i686-8Zeron.plg installed I used the vSphere Client to Shut Down the unRAID guest.  Powering the machine back on was as expected (no parity check).  Following the same procedure on previous versions always resulted in a parity check. 


I have also run restart guest from the vSphere Client software, and the array also came up clean.



Thanks Zeron!!

Worked for me on ESXi 5.0 and open_vm_tools-2012.10.14.874563_unRaid5.0rc10-i686-8Zeron.tgz.  Restarted from vSphere Client while array was running.  When the VM restarted and when I started the array (I have mine set to not auto start the array) it started up withOUT a parity check.


Sorry - after coming back to this post I left out a VITAL part of a word above.

Link to comment

Is there an issue with the download site?


I was able to download the files for my 4.7 server, but I was working on standing up a new 5.0rc10 box and today I can not download the files.


Just wanted to verify it was not something on my end.






The server hosting the files is in the process of being moved from a data center in San Fransisco to Las Vegas.  Should be back in a few hours.

Link to comment

have a question about this..


How does 'VMWare tools' benefit unRAID?


I have a separate NIC that is getting pass through unRAID VM.. and all my hdd's are connected to the MV8 card which is also using hardware pass through.


So those main things aren't virtualized so im wondering what would be the benefit of installing VMWare tools for the situation I am in.



Link to comment

have a question about this..


How does 'VMWare tools' benefit unRAID?


Aside from the already mentioned; it also includes time syncing to the esxi host.  The virtual machine clock has a tendency to drift.  This will allows it to stay in sync with the host and other VM's.


It will work better than using ntp within the guest.


It will also fill in the IP address on the Summary page in vShpere.


Link to comment
  • 3 weeks later...

Just upgraded to rc11. I'm getting this message at bootup:  unable to resolve host address unraid.zeron.ca

Pings to that address are resolved.

I'm thinking that unraid networking isn't up and running before that connection is attempted. Any workarounds?



Update:  It was the NIC. Was slow to take up the DHCP.  Set the IP to static and it's all good now.

Link to comment
  • 1 month later...

OK...here is my experience...


ESXi 5.1.799733

unRAID b5RC11


I installed open_vm_tools-2012.10.14.874563_unRaid5.0rc11-i686-8Zeron.tgz manually to the /extra/ folder and rebooted.  OpenTools installed fine:










I then tried to shutdown the unRAID guest via the "Shutdown Guest" button in Vsphere client and it shut down instantly.  I received the same error in teh Events that other had posted earlier about the script failing to run.


I powered the unRAID VM and it initiated a parity check (as expected).  I decided to try the RC10 version and see if I had better success with that.  Installed it the same way, stopped the parity check, stopped the array and rebooted via the webgui.


This time the script failed to install the modules (FATAL errors).  I'm guessing tha this may have been expected since I am mixing unraid versions and opentools plgin versions.  Oh well...it was worth a shot.  :)


So, I removed the RC10 plugin and tried one more time to install the RC11 plugin (same method).  This time when I initiated a shutdown via the Vsphere client, the array was stopped and unraid shutdown cleanly...no parity check at next start.


So, the moral of the story...I have absolutely no idea what made it work but it does!  :)


Thank you for your efforts!



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.