access denied / Printer / Unraid Share

Recommended Posts



since a few weeks now, I've have the problem that I can no longer access files that my scanner/Printer creates. I hope someone can give me an Advice on how to solve that Problem.


How I proceed:

- I set up my Networkprinter with the Networkshare + Username

- i scan a File

- the file gets successfully transfaired to the network share

- i nagivate with my Windows10 Client to the Network share and try to open the File

- i get a error massage "access deniend"


I had the exact same Setup since over a Year now and everything worked fine. But since 1 or 2 month i get the access denied massage. Also when i right click the file it shows me that i dont have any reading rights to see the security settings on that file.


When i override the Userrights with the Tool "New Permission" i can access the File and everything is fine.


What i tryed:

- Delet the share on the Printer and set up everything new --> no success

- Use different User Account to write and read the file from the printer --> no success

- Use a different Network share -- no success



My Setup


- I have a Network Printer (Canon MF 446x)

- i have a unraid share: SMB Public

- I have a user Account with Read/Write Access to that share

- I have a few Windows 10 Clients


Anyone know the Problem or can help me with my Setup?




The same Probelm seems to appear when i try to make an Backup with Acronis. After i did that i also did not had Access to the backup file. "New Permission" was here also the solution.


Thanks for Helping!

Kind Regards



Edited by Thief_of_Time
Link to comment

It may be perfectly clear to you where all of these devices and files are BUT I find it very confusing.


Is the printer/scanner an actual network device?  (That is; connected with a cat5 type cable or a wireless connection.)  Or is this printer connected to a Win10 computer and that you are sharing on a peer-to-peer basis?


14 hours ago, Thief_of_Time said:

- the file gets successfully transfaired to the network share


Where is this network share?  On your Unraid server?  Or on a Win10 Computer?   If it is on a Unraid server, how does the file end up there.


14 hours ago, Thief_of_Time said:

Use different User Account to write and read the file from the printer --> no success


How is this even possible?  Does this printer have user-accessible storage?  If it does, how is this even an Unraid problem?


I could go on but I think you can see where I am coming from.  Please rewrite things and use names of devices.  Tell where ---- to-and-from-- (with names again) that these files are being transferred.  And the problems associated with these locations.  Are you creating with one Windows 10 client and attempting to access from a second client?


Having said all of this, Windows is having printing issues using networked printers.  See here for an introduction to those issues:

                (This link will not have Susan Bradley's post from Nov 11, 2021,  at the top after a couple of days.)


These printing problems are cropping up mostly on peer-to-peer setups so this may not be any part of the problem that you are seeing.

Link to comment

Thanks for the quick reply. I try to answer the open questions as good as I can


- The printer is a acuall network printer connected via a cat7 network cable. 

- The network Share is on my Unraid Server (Version: 6.9.2)

Base distro:

docker: version 20.10.5

fuse3: version 3.10.2

nginx: version 1.19.9

samba: verson 4.12.14 (CVE-2020-27840 CVE-2020-27840)


10 hours ago, Frank1940 said:

If it is on a Unraid server, how does the file end up there.


Since its a Networkprinter it has an option to transfair files direct to a network storage.

I can tell him the Protokoll (SMB), the Hostname of my NAS, the Folderpath and a Username + PW to store stuff on there.




10 hours ago, Frank1940 said:


How is this even possible?  Does this printer have user-accessible storage?  If it does, how is this even an Unraid problem?


The printer Stores the Files directly on my Unraid Server. I tryed to Store the Files directly to an USB Drive, that worked fine. Also i made a network Share on my Windows 10 PC. That also worked fine. It only has a Problem, when i try to safe the File on a Share of my Unraid Server.


The whole process is like:


I go to my Printer, scan and Scan a File. The printer itself has an "Adressbook" for Networkshares which you can see above. I choose that networkshare on my Unraid Server with a given Username + PW. The printer can successfully connect to my Unraid Server and can store the file on my share (if the PW for my Useraccount is wrong or the Server is offline the printer prints an error code). After the file is stored on the Server, i go to my Windows 10 PC and try to open the file. Then i get the access denied massage.





Edited by Thief_of_Time
Link to comment

From the GUI, open up the terminal and type the following command:


ls -al /mnt/user/02_Transfair


Capture the results of the output.  You can use the Windows Snip & Sketch tool  or  copy the text from the terminal window.  You should have something like this (I copied the text):

root@Rose:~# ls -al /mnt/user/Testing
total 9056
drwxrwxrwx 1 nobody  users      24 Nov  8 14:20 ./
drwxrwxrwx 1 nobody  users      90 Nov 24 10:53 ../
-rw-rw-rw- 1 smbuser users  617414 Nov  4 08:49 2021\ 11\ News\ RM.pdf
-rw-rw-rw- 1 smbuser users  155592 Oct 21 19:07 315911750.pdf
drwxrwxrwx 1 smbuser users       6 Nov  8 14:20 New\ folder/
-rw-rw-rw- 1 smbuser users  403972 Oct  1 12:00 October\ 2021\ NEWSLETTER.pdf
-rw-rw-rw- 1 smbuser users   33072 Sep 11 11:07 Upgrading_from_Version_5_to_Version_6_of_unRAID-rev2.pdf
-rw-rw-rw- 1 smbuser users  641515 Aug 30 10:12 cmoc\ news\ letter.pdf
-rw-rw-rw- 1 smbuser users  105445 Nov  3 18:49 cpd56384.pdf
-rw-rw-rw- 1 smbuser users 7303393 Sep 30 17:27 cpd56386.pdf


Please see that I formatted the text as 'Code'  (    </>   icon)  so that it lines up for easy reading!


Link to comment
root@OnePiece:~# ls -al /mnt/user/02_Transfair/
total 6160
drwxrwxrwx+ 1 nobody    users     166 Nov 25 11:48 ./
drwxrwxrwx  1 nobody    users     214 Nov 13 02:09 ../
drwxrwxrwx+ 1 nobody    users     378 Nov 25 11:42 .Recycle.Bin/
-rw-rw----+ 1 transfair users  542303 Nov 25 11:44 0141_211125204145_001.pdf
-rw-rw----+ 1 nobody    users 2582906 Nov 25 11:48 IMG_20211125_144215.jpg
-rw-rw----+ 1 user2     users 3177905 Nov 25 11:47 IMG_20211125_144329.jpg



The File "0141_211125204145_001.pdf" is created by my Printer(Scanner) with the Unraid Account "transfair"

The File "IMG_20211125_144329" is copyied from my Phone with my Unraid Account "user2"

The File "IMG_20211125_144215" is copyied from my Phone without any given any credentials/Account


From my PC I use the Unraid Account "user2" to Access the Files. The Access only works for the File "IMG_20211125_144329". The Share itself is "Public".



Link to comment



Notice the  "+" at the end of the permissions on the current directory.  This means that there are additional permissions assigned to this folder which 'fine-tune' the old Linux permissions.  (Observe that this "+" also appears on each on the files. 


This has cropped up before (and I can't remember how the issue was resolved) but I did do a bit of research into it at that time.  I will point you to the link that I saved at the time:


(Be sure to follow the link in the last post as it has some insights in it!  Note that the date on that article was back in 2003 and it talks about implementing features into various OS.  I think that would have happened by now...)


You might want to consider how this Share was generated.  Something 'told' SMB that additional permissions were to be associated with this share.  I tend to suspect it it was somehow involved that that printer/scanner.  (Is this printer intended more for the business/corporate world rather than a home environment?) 


I basically have no other insights into finding a solution to the problem at this point. 

  • Like 1
Link to comment



thanks for the help. The "+" seems to be really the cause of the Problem. I set up a new Share with default permissions. I tryed to save some stuff from my Printer/Scanner and it worked perfectly. I went back to save the Files to the old share and it did not work.


Then i used following command:


root@OnePiece:~# setfacl -Rbn /mnt/user/02_Transfair/


That removed the "+" from that directory. After that was done I had no Problems saveing my scan files on that share again.

Thanks for the help!


I also  found the "+" on another share. Some tests then showed that the same errors occur here as well. I used the same command as above and that also fixed the problems.

I do not assume that the printer has set the "+" to the dictionary and thus caused the problem, because it now works without problems.


Anyway, the Problem is solved now.

Thanks for the help!




  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.