[PhAzE] Plugins for Unraid 5/6


3606 posts in this topic Last Reply

Recommended Posts

  • Replies 3.6k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Just a quick update, unRaid 6.4 looks like it will be using nginx for the web front end over emhttp (which is a good switch IMO) but that means there is a good chance all of my plugins will not work o

Important info regarding unRAID 6.2 and beyond.          ***unRAID 6.2 Compatible*** Hello again!   I've done another overhaul of the plugins

Unfortunately, @PhAzE no longer seems to be active at all within these forums.  His last time online was March 23, and his last posting was on February 22.  I'm sure I speak for all of us in hoping th

Posted Images

trying to update the Emby Server from Installed Version: 3.0.5724.4 to New Version: 3.0.5724.5.    But I am getting the following error.

 

Install failed: Failed MD5 checksum

 

I am using UnRaid v5.    I'm using Plugin Version: 2015.09.06.1

 

I'm having similar issues trying to upgrade Emby. Trying to upgrade manually produces this:

 

root@Tower:~# /usr/local/emhttp/plugins/Embyserver/scripts/rc.Embyserver update
Stopping Emby Server...
Stop OK!
Installing Emby Server...
--2015-09-26 07:06:42--  https://github.com/MediaBrowser/Emby.Releases/raw/master/Server/Emby.Mono-3.0.5724.5.zip%0A.Releases/blob/master/Server/MediaBrowser-3.0.5724.5.zip
Resolving github.com (github.com)... 192.30.252.129
Connecting to github.com (github.com)|192.30.252.129|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2015-09-26 07:06:42 ERROR 404: Not Found.

Install failed: Failed MD5 checksum

Link to post

trying to update the Emby Server from Installed Version: 3.0.5724.4 to New Version: 3.0.5724.5.    But I am getting the following error.

 

Install failed: Failed MD5 checksum

 

I am using UnRaid v5.    I'm using Plugin Version: 2015.09.06.1

 

I'm having similar issues trying to upgrade Emby. Trying to upgrade manually produces this:

 

 

Same here on a new install.  I'm on unRaid 5.0.6 with plugin 2015.09.06.1

 

Installing Emby Server...
--2015-09-26 18:01:51--  https://github.com/MediaBrowser/Emby.Releases/raw/master/Server/Emby.Mono-3.0.5724.5.zip%0A.Releases/blob/master/Server/MediaBrowser-3.0.5724.5.zip
Resolving github.com (github.com)... 192.30.252.130
Connecting to github.com (github.com)|192.30.252.130|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2015-09-26 18:01:52 ERROR 404: Not Found.

Install failed: Failed MD5 checksum

 

Link to post

Updates live:

 

Emby - Fixed install, they added a MONO file with a similar name that was causing confusion in the install function

SickRage - Added --recursive option, and perl for unraid 6 which the recursive option requires

Plex - Fixed password problem where it saved it with single quotes around it.  Please reenter your password and press "apply" so it fixes

BTSync - Fixed webui link to use DNS name like all the other plugins, as the IP comes up blank when bonded link is used

 

-=PhAzE=-

 

Link to post

Well... one step further.  The regex fix worked on the 404 but the checksum still fails.

 

root@Tower:~# /usr/local/emhttp/plugins/Embyserver/scripts/rc.Embyserver install
Installing Emby Server...
--2015-09-26 23:06:33--  https://github.com/MediaBrowser/Emby.Releases/raw/master/Server/MediaBrowser-3.0.5724.5.zip
Resolving github.com (github.com)... 192.30.252.129
Connecting to github.com (github.com)|192.30.252.129|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://raw.githubusercontent.com/MediaBrowser/Emby.Releases/master/Server/MediaBrowser-3.0.5724.5.zip [following]
--2015-09-26 23:06:34--  https://raw.githubusercontent.com/MediaBrowser/Emby.Releases/master/Server/MediaBrowser-3.0.5724.5.zip
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 23.235.46.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|23.235.46.133|:443... connected.
WARNING: certificate common name `www.github.com' doesn't match requested host name `raw.githubusercontent.com'.
HTTP request sent, awaiting response... 200 OK
Length: 17575087 (17M) [application/octet-stream]
Saving to: `/boot/config/plugins/Embyserver/Embyserver-PhAzE-3.0.5724.5-src.zip'

100%[====================================================================================================================>] 17,575,087  6.71M/s   in 2.5s    

2015-09-26 23:06:37 (6.71 MB/s) - `/boot/config/plugins/Embyserver/Embyserver-PhAzE-3.0.5724.5-src.zip' saved [17575087/17575087]

Install failed: Failed MD5 checksum 

Link to post

Just a headsup for anyone else who wanted the beta version of SABnzbd and wondered why the plugin doesn't grab it..  The plugin relies on reading

http://sabnzbdplus.sourceforge.net/version/latest and that file is out of date and still lists alpha2 (and the plugin ignores alpha's anyway!)

 

I've sent a mail to shypike on the SB forums to see if he can update it for us - at which point it should start working again..

Link to post

 

Yep - and the plugin gets that to check the MD5 - however it checks the URL I mentioned first (in app_newver() ) to find out what the latest version is in the first place...

 

The URL you linked to shows all versions of the application but gives no indication as to what the most recent one is, which is why phaze sensibly relies on the 'latest' url to actually give the correct answer :-)

Link to post

Hi

 

reply from Shypike on the SAB boards..

 

---

Done.

We're moving this file to github, so when 0.8.0 comes out,

the SF file will be stuck pointing at an 0.8.0 upgrade.

---

 

So it should make it work for now (and indeed I have just updated through the plugin!!) - but we'll need to ask PhAzE nicely for a different approach in the future ;-)

 

 

Link to post

Hi

 

reply from Shypike on the SAB boards..

 

---

Done.

We're moving this file to github, so when 0.8.0 comes out,

the SF file will be stuck pointing at an 0.8.0 upgrade.

---

 

Meh - upgrade now works, but we're back to the problem of the root certificates being invalid again (and the previous patch no longer appears to work in 0.8.0)

 

PhAzE - sorry to be a pain - but what do we have to do to figure out why the root certs aren't correct on 5.x

 

So it should make it work for now (and indeed I have just updated through the plugin!!) - but we'll need to ask PhAzE nicely for a different approach in the future ;-)

 

EDIT:

And fixed it myself (at least temporarily)

 

wget http://slackware.cs.utah.edu/pub/slackware/slackware-current/slackware/n/ca-certificates-20150426-noarch-2.txz
installpkg ca-certificates-20150426-noarch-2.txz

 

And I'm back to downloading again...

Link to post

Hi

 

reply from Shypike on the SAB boards..

 

---

Done.

We're moving this file to github, so when 0.8.0 comes out,

the SF file will be stuck pointing at an 0.8.0 upgrade.

---

 

Meh - upgrade now works, but we're back to the problem of the root certificates being invalid again (and the previous patch no longer appears to work in 0.8.0)

 

PhAzE - sorry to be a pain - but what do we have to do to figure out why the root certs aren't correct on 5.x

 

So it should make it work for now (and indeed I have just updated through the plugin!!) - but we'll need to ask PhAzE nicely for a different approach in the future ;-)

 

EDIT:

And fixed it myself (at least temporarily)

 

wget http://slackware.cs.utah.edu/pub/slackware/slackware-current/slackware/n/ca-certificates-20150426-noarch-2.txz
installpkg ca-certificates-20150426-noarch-2.txz

 

And I'm back to downloading again...

The strange part is that my plugins do exactly this. Not sure why it doesn't work right off the bat :S  Maybe there is a slight difference in the package I used. I'll update all the plugins for this package if you have confirmed it works.

Link to post

I just skimmed over the conversation here about SAB, can someone point me to the file that 'will' hold the future versions?

 

Not yet :)

 

When SAB moves to github rather than sourceforge there will be a 'new' file to track the latest versions - but until they do we won't know where it is. :-)

 

As for the root certs - that's strange - i'm assuming when the plugin imports them it also does the equivalent of the 'update-ca-certificates'?  Certainly as soon as I'd done a installpkg on that file that I linked to everything started working perfectly..

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.