[Support] Linuxserver.io - Quassel-Core


45 posts in this topic Last Reply

Recommended Posts

linuxserver_medium.png

 

Application Name: Quassel-Core

Application Site: http://quassel-irc.org/

Docker Hub: https://hub.docker.com/r/linuxserver/quassel-core/

Github: https://github.com/linuxserver/docker-quassel-core

 

Please post any questions/issues relating to this docker you have in this thread.

 

If you are not using Unraid (and you should be!) then please do not post here, instead head to linuxserver.io to see how to get support.

Edited by linuxserver.io
Link to post
  • 2 weeks later...

This works great, however..

 

I use /setkey in quassel client to set the blowfish key for an encrypted channel.. which works fine to start with.

 

But after the container is restarted, all of the keys that were set are gone and have to be set again.  /showkey #channel returns "No key has been set".

Link to post

 

This works great, however..

 

I use /setkey in quassel client to set the blowfish key for an encrypted channel.. which works fine to start with.

 

But after the container is restarted, all of the keys that were set are gone and have to be set again.  /showkey #channel returns "No key has been set".

 

I will look into this

Link to post
  • 3 weeks later...

 

The webserver has stopped working properly.  It loads, and for a brief moment I see the user/password boxes, but then they vanish and all I see at the top is the word "Quassel" with a blue background..

unfortunatly the webui is under heavy development and we can't do much about it.
Link to post
  • 6 months later...

You don't access the port with a web browser.  You need to download the Quassel client to use on your machine and configure the Unraid server component.

 

Ah got it, I downloaded the windows client and installed only the -client, but I'm not sure what to enter for the Add Core Account. It is asking for Account Name, hostname, port, User, Password. Any idea what I should be entering into the fields? It won't let me in with just the hostname:port

 

edit: nvm I entered admin for the username and it let me through

 

edit2: I looked at the ip supplied, 64443, and it seems like it's for quasselweb, which they removed because it was unstabled. The description should be updated.

Link to post
  • 3 months later...

I point my clients to my domain name and a random port that is open for Quassel.  You can't route it over 80 or 443 like a regular reverse proxy I don't think.

 

Sent from my LG-H815 using Tapatalk

 

 

Link to post

Yeah that's what I wanted to do, route it over 443. Currently thanks to having a reverse proxy setup I don't have any other ports open which is what I was trying to maintain.

 

It didn't look like Quassel gave any options to configure it for a reverse proxy.

 

Maybe I'll have to try and setup a webserver. This one supports reverse proxy. https://github.com/magne4000/quassel-webserver

But then you can't use the clients and everything will have to be done through the webui.

 

I assume the included webui doesn't work? I tried it but I didn't get anything. (after configuring the core with the desktop app)

Link to post

Yeah that's what I wanted to do, route it over 443. Currently thanks to having a reverse proxy setup I don't have any other ports open which is what I was trying to maintain.

 

It didn't look like Quassel gave any options to configure it for a reverse proxy.

 

Maybe I'll have to try and setup a webserver. This one supports reverse proxy. https://github.com/magne4000/quassel-webserver

But then you can't use the clients and everything will have to be done through the webui.

 

I assume the included webui doesn't work? I tried it but I didn't get anything. (after configuring the core with the desktop app)

 

The webui was removed as it's broken at source.

Link to post
  • 2 weeks later...
  • 3 months later...
  • 4 weeks later...

Since Crashplan uses  4242 port I changed it to 4545 in Quassel. It worked fine for a while until I have to update it. I pretty much do it like everyone else. I stop the container and click update. Says successful. When I run the client I'll get  (attached picture) or something about Quassel can't run, check setup. Now, I've done this before a couple of times. I can usually fix it by deleting the  local client and reinstall. Bring me to the setup network screen which is where I'll put down the 4545 put, name and password. I'll eventually select "connect to core" and get the attached. I'll leave it UNfixed for a while until maybe I'll come up with and idea besides just wiping out and reinstalling. Thanks.

 

Link to post

Since Crashplan uses  4242 port I changed it to 4545 in Quassel. It worked fine for a while until I have to update it. I pretty much do it like everyone else. I stop the container and click update. Says successful. When I run the client I'll get  (attached picture) or something about Quassel can't run, check setup. Now, I've done this before a couple of times. I can usually fix it by deleting the  local client and reinstall. Bring me to the setup network screen which is where I'll put down the 4545 put, name and password. I'll eventually select "connect to core" and get the attached. I'll leave it UNfixed for a while until maybe I'll come up with and idea besides just wiping out and reinstalling. Thanks.

 

I've been running Quassel on 4244 since I installed it and not had any problems at all....

Link to post

Since Crashplan uses  4242 port I changed it to 4545 in Quassel. It worked fine for a while until I have to update it. I pretty much do it like everyone else. I stop the container and click update. Says successful. When I run the client I'll get  (attached picture) or something about Quassel can't run, check setup. Now, I've done this before a couple of times. I can usually fix it by deleting the  local client and reinstall. Bring me to the setup network screen which is where I'll put down the 4545 put, name and password. I'll eventually select "connect to core" and get the attached. I'll leave it UNfixed for a while until maybe I'll come up with and idea besides just wiping out and reinstalling. Thanks.

 

I've been running Quassel on 4244 since I installed it and not had any problems at all....

 

I did get it working. I just made the ports different in Crashplan and Quassel client connected fine with the core. Good enough for me!

 

Link to post
  • 2 weeks later...

Since Crashplan uses  4242 port I changed it to 4545 in Quassel. It worked fine for a while until I have to update it. I pretty much do it like everyone else. I stop the container and click update. Says successful. When I run the client I'll get  (attached picture) or something about Quassel can't run, check setup. Now, I've done this before a couple of times. I can usually fix it by deleting the  local client and reinstall. Bring me to the setup network screen which is where I'll put down the 4545 put, name and password. I'll eventually select "connect to core" and get the attached. I'll leave it UNfixed for a while until maybe I'll come up with and idea besides just wiping out and reinstalling. Thanks.

 

I've been running Quassel on 4244 since I installed it and not had any problems at all....

 

I did get it working. I just made the ports different in Crashplan and Quassel client connected fine with the core. Good enough for me!

 

Wonder if my darn firewall is blocking ports, but that doesn't usually happen. If I uninstall he Crashplan docker then go ahead and install the Quassel-cure it works fine. (can't even get the docker installed, let alone the client running). Once I do get the quassel core up and running that where's the protocol error comes around. Only while Crashplan is present. To make sure, the quassel core can run on any port I want?

quasselcoreports.jpg.a3d2a22e87b4b66e274dcd3a19f03f21.jpg

Link to post

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="quassel-core" --net="bridge" -e TZ="America/Chicago" -e HOST_OS="unRAID" -e "PGID"="100" -e "PUID"="99" -p 4242:4242/tcp -v "/mnt/user/Docker/appdata/quassel-core":"/config":rw linuxserver/quassel-core

51fe60bd33740e57906862a55b0e52434c9f67efe569a8707ff714df14da4d4c

 

The command finished successfully!

 

 

 

It seems I've figured out my issue. I just kept using the defaults which was on the selection for postgreSQL. After removal of the docker and reinstall of the docker it seems the default changed to sqlite which works.

Link to post

Since Crashplan uses  4242 port I changed it to 4545 in Quassel. It worked fine for a while until I have to update it. I pretty much do it like everyone else. I stop the container and click update. Says successful. When I run the client I'll get  (attached picture) or something about Quassel can't run, check setup. Now, I've done this before a couple of times. I can usually fix it by deleting the  local client and reinstall. Bring me to the setup network screen which is where I'll put down the 4545 put, name and password. I'll eventually select "connect to core" and get the attached. I'll leave it UNfixed for a while until maybe I'll come up with and idea besides just wiping out and reinstalling. Thanks.

 

I've been running Quassel on 4244 since I installed it and not had any problems at all....

 

I did get it working. I just made the ports different in Crashplan and Quassel client connected fine with the core. Good enough for me!

 

Wonder if my darn firewall is blocking ports, but that doesn't usually happen. If I uninstall he Crashplan docker then go ahead and install the Quassel-cure it works fine. (can't even get the docker installed, let alone the client running). Once I do get the quassel core up and running that where's the protocol error comes around. Only while Crashplan is present. To make sure, the quassel core can run on any port I want?

 

My friendly little protocol error is back. There has to maybe be a fight between Crashplan and Quassel? Soon as CP gets dumped, Quassel gets back to normal. I tried about 10 different ports, including changing the CP ports (CP works) but the quassel likes that protocol error. By the way, hope everyone had a happy new year's!

Link to post
  • 7 months later...

I'd hate to revive a sleeper but have to ask. Reinstalled core, good. Installed the client on my desktop and core setup is asking for username and password. I don't remember configuring anything when I created the docker, nor see any username or pw field there. I tried the regulars like admin/admin, even tried my root login and password, that failed. Checked the syslog and there's nothing in it. Is there a default username/password?

 

Update: I just needed to remove the configuration files in the appdata for some reason. After that, was able to configure my core properly on the docker.

:)

 

Edited by opentoe
Link to post
  • 6 months later...

Hi,

 

I'm new to unraid and dockers.  I'm coming from the world of windows and mirc.  I installed community apps and searched for irc and found 2 versions of quassel core.

 

quassel core
linuxserver
Network:Messenger

 

 

Quassel core
xamindar
Network:Messenger

 

I tried both versions but don't see an option in how to run it under the docker tab.   See attached for what I see.  How do I run this?

quassel-core2.thumb.JPG.b430e8cb8a71b427516898cff92df4f2.JPGquassel-core1.JPG.730bf591089516cc9f334b638816bf9e.JPG

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.