Jump to content
binhex

[Support] binhex - DelugeVPN

4959 posts in this topic Last Reply

Recommended Posts

Each time I stop and start, I need to go in, reapply the download directory, my seeding preferences, if I want to allow remote connections, labels, etc.  Any thoughts on what I could be doing wrong? 

 

This sounds like a classic case of the share your using not being marked a "cache only", what this means if you dont do this is the internal unraid process called mover comes along and moves all your files in that share to the array, then when you restart the docker you have no config again, and so the cycle repeats. The way to solve this is to mark the share as "cache only", this tells the mover not to touch any files/folders contained within this share, go to unraid ui/shares/click on share/select from dopdown "use cache disk" the value "only", save and your done.

 

fyi, in Couch I have tried to connect to "localIP:58846", "127.0.0.1:58846" and "localhost:58846".  I also tried changing the port number in deluge and in couch but no luck.  In the beginning of this thread in the FAQ Binhex says to "enable remote connections, then restart".  In my case, every restart resets to unchecked and I have to check again - so now I"m thinking whatever is keeping my preferences from staying might be a contributing factor.

 

ok this will depend on where couchpotato is installed and how its installed, for now im going to assume couchpotato is installed as another docker on the unraid host, if this is the case then read FAQ Q1 in post #2 of this thread and follow it carefully.

Just to add to this a little, once mover has messed with it, it seems like you need to remove the delugevpn config folder and let the container recreate it. Also, I'd set the mapping to /mnt/cache/appdata/delugevpn instead of /mnt/user/appdata/delugevpn if that's what you used.

Share this post


Link to post

Each time I stop and start, I need to go in, reapply the download directory, my seeding preferences, if I want to allow remote connections, labels, etc.  Any thoughts on what I could be doing wrong? 

 

This sounds like a classic case of the share your using not being marked a "cache only", what this means if you dont do this is the internal unraid process called mover comes along and moves all your files in that share to the array, then when you restart the docker you have no config again, and so the cycle repeats. The way to solve this is to mark the share as "cache only", this tells the mover not to touch any files/folders contained within this share, go to unraid ui/shares/click on share/select from dopdown "use cache disk" the value "only", save and your done.

 

fyi, in Couch I have tried to connect to "localIP:58846", "127.0.0.1:58846" and "localhost:58846".  I also tried changing the port number in deluge and in couch but no luck.  In the beginning of this thread in the FAQ Binhex says to "enable remote connections, then restart".  In my case, every restart resets to unchecked and I have to check again - so now I"m thinking whatever is keeping my preferences from staying might be a contributing factor.

 

ok this will depend on where couchpotato is installed and how its installed, for now im going to assume couchpotato is installed as another docker on the unraid host, if this is the case then read FAQ Q1 in post #2 of this thread and follow it carefully.

Just to add to this a little, once mover has messed with it, it seems like you need to remove the delugevpn config folder and let the container recreate it. Also, I'd set the mapping to /mnt/cache/appdata/delugevpn instead of /mnt/user/appdata/delugevpn if that's what you used.

 

Thanks for the info guys:

I have my /config folder mapped to a cache "only" share.  I have my /data folder mapped to a /download directory on my "yes" cache share.  Do I need both mapped to the cache "only"?  The reason I did this was I thought I should have the downloads actually go to the large array for space needs...not to the limited cache - but that may be my mistake. BOTH are mapped to "/mnt/user" and not /mnt/cache".

 

Couch is installed as another docker on the unraid host. I followed the instructions in the post cited above but have had no luck.  I'll work on the getting the preferences to stay first, then tackle this issue separately. Still not sure they aren't related.

 

Thanks!!

Share this post


Link to post

For couchpotato, you have to edit your auth file located in the deluge config folder.

 

make a second line read as follows

 

admin:password:10

 

then put those credentials (admin/password) into the CP Deluge settings. You want to connect to the daemon @ my.unraid.ip.address:58846

Share this post


Link to post

For couchpotato, you have to edit your auth file located in the deluge config folder.

 

make a second line read as follows

 

admin:password:10

 

then put those credentials (admin/password) into the CP Deluge settings. You want to connect to the daemon @ my.unraid.ip.address:58846

 

I do have the above information in the "auth" file in the config folder.  There are two lines, the first is "admin:password:10" but with my specific details, the second is "localclient:somenlettersandumbers:10"

 

I do have that setup as you have suggested.

 

Thanks.

Share this post


Link to post

CP set to bridge?

 

How do you have it setup within CP's settings?

 

Yes the CP docker is set to bridge.

 

In CP, in settings - I enabled deluge with the following settings:

 

Label: movies

Username: deluge webgui username

Password: deluge webgui password

Directory: left blank

Host: my.host.ip.address:58846

 

Test Deluge: Connection failed. Check logs for details.

I've looked in the CP logs but I didn't see anything that stood out as related to this problem.

If I test nzbget I get connection successful and the log shows that.  If I test Deluge I get Connection failed, but there is nothing in the CP log to show that.  I cleared logs and tested a couple times to confirm no info is being sent to all logs or error or info.....

 

I should note that I am able to connect to Deluge with Sonarr and it works as it should.  So Deluge is working with Sonarr, just not with CP for me.

 

Thanks for your continued suggestions...

Share this post


Link to post

try this, i just looked at my auth file and this is how mine is...

 

shutdown deluge.

open the auth file for editting

change it so the user:pass:10 are all on one line with no spaces between.

 

user1:pass1:10user2:pass2:10

 

Mine is like that when I open it in notepad under win7.

 

Share this post


Link to post

and make sure deluge is set to receive remote connections. It's under the Daemon options in preferences.

Share this post


Link to post

try this, i just looked at my auth file and this is how mine is...

 

shutdown deluge.

open the auth file for editting

change it so the user:pass:10 are all on one line with no spaces between.

 

user1:pass1:10user2:pass2:10

 

Mine is like that when I open it in notepad under win7.

 

Yes, mine was the same way when I used notepad as well.  I also make sure I enable remote connections for the daemon.

 

What's odd is that my password works, but the settings for download directory, bandwidth,remote connections, label all reset to default whenever I restart....

 

Like I said, my Sonarr/Deluge is working great, just can't get CP/Deluge to work together (or get my settings to stay once in Deluge).

For the record I did delete the container and image file about 30 minutes ago and started over.  Same behavior as before.

 

Thanks.

Share this post


Link to post

my gut feeling is that they dont support incoming ports, in which case they are pretty useless for torrents.

 

You were right.  I asked and this is what they respond :

 

Hello,

Anything that will require port forwarding will not be fully supported using our VPN service.

Thanks again,

Chris
Newshosting Support

 

I found out they are using the VPNZoom as the provider for their VPN service (nothing on Incoming ports or Port forward either).

 

What is the best deal currently ?  AirVPN or PIA ?  that is pretty much expensive compare to justseed.it at 3.99E/4TB of Torrents for 120 days...

Share this post


Link to post

Hey just having an issue with this atm where by i cant connect to the webui after assigning a new VPN host server.

 

Logs show this

 

CRIT Set uid to user 0

Warn Included extra file "/etc/supervisor/conf.d/delugevpn.conf" during parsing

 

Any ideas what my issue could be?

I tried changing back to my original host but still this problem persists.

 

Share this post


Link to post
For the record I did delete the container and image file about 30 minutes ago and started over.  Same behavior as before.
When you did that, did you also delete the config folder in your appdata? The container and image don't contain your settings.

Share this post


Link to post

Hey just having an issue with this atm where by i cant connect to the webui after assigning a new VPN host server.

 

Logs show this

 

CRIT Set uid to user 0

Warn Included extra file "/etc/supervisor/conf.d/delugevpn.conf" during parsing

 

Any ideas what my issue could be?

I tried changing back to my original host but still this problem persists.

 

this is not your issue, please can you post the entire supervisord.log file, minus username and password

Share this post


Link to post

What is the best deal currently ?  AirVPN or PIA ?  that is pretty much expensive compare to justseed.it at 3.99E/4TB of Torrents for 120 days...

 

im not sure which is cheaper but i can tell you PIA are pretty darn cheap if you go for a year, i think im paying around £3 per month for unlimited usage, speeds are ok, not lightning fast but adequate for me (approx 800 KB/s to 1.3MB/s DL on a 20Mb/s line)

Share this post


Link to post

I'm having issues uploading attachments for some reason. Its just telling me im not allowed to post so i have pmed you. Thanks

Share this post


Link to post

What is the best deal currently ?  AirVPN or PIA ?  that is pretty much expensive compare to justseed.it at 3.99E/4TB of Torrents for 120 days...

 

im not sure which is cheaper but i can tell you PIA are pretty darn cheap if you go for a year, i think im paying around £3 per month for unlimited usage, speeds are ok, not lightning fast but adequate for me (approx 800 KB/s to 1.3MB/s DL on a 20Mb/s line)

 

I'm getting the same speeds on 100mbps/10mbps. I used to get 2-3MB/s but that changed about a month ago.

Share this post


Link to post

What is the best deal currently ?  AirVPN or PIA ?  that is pretty much expensive compare to justseed.it at 3.99E/4TB of Torrents for 120 days...

 

im not sure which is cheaper but i can tell you PIA are pretty darn cheap if you go for a year, i think im paying around £3 per month for unlimited usage, speeds are ok, not lightning fast but adequate for me (approx 800 KB/s to 1.3MB/s DL on a 20Mb/s line)

 

 

+1 for PIA, I am in Canada and pay $6.96 USD / month for PIA. Speeds are great, my current PIA endpoint for Deluge is in the Netherlands and I still reach 2-4 MB/s (Bytes NOT bits!!) on well seeded torrents. I also create a separate tunnel to the US on my Tomato Router for Netfilx using sourced based routing and openVPN -also fast and reliable!

 

Downloads caps (800 GB/mo) are set by my ISP - PIA doesn't care...

 

My 2c

 

BR

Share this post


Link to post

I think i'll just use justseed.it.  It allows private tracker, it's like 4-5$ for 10TB transfer that can last up to 120 days.  The speed is like 20-30-40-50MB/sec (more when getting more than 1 torrent well seeded -- one time, I got around 90MB/sec incoming when I added the speed of all torrents that was downloading).  The only 'pain" is I have to download from them after (https) and even with jdownloader2 that creates 8 threads per files, I still can't max my 25/25Mbps connexion.  I do only torrent very rarely, when I can't find on usenet.

Share this post


Link to post

3 quick questions:

 

1) Can you expand on what the Privoxy portion of this docker does? I understand what a proxy is, but I don't understand why you would (or would not) enable it for this docker. You mention unfiltered browsing of indexes, but I don't understand why that access would be filtered just from using a VPN in the first place.

 

2) If I use 2 VPN containers (Deluge & SABnbzd) does each container count against my PIA device limit? I believe PIA has a 5 device limit.

 

3) Will Privoxy running on both DelugeVPN and SABnbzdVPN on the same port cause a conflict? (Also on your github pages I see "Access Privoxy" showing port 8118 and in other places you mention port 8181, not sure if that is a typo or again showing my ignorance of the purpose/usage of Privoxy)

 

Thanks!

Share this post


Link to post

3 quick questions:

 

1) Can you expand on what the Privoxy portion of this docker does? I understand what a proxy is, but I don't understand why you would (or would not) enable it for this docker. You mention unfiltered browsing of indexes, but I don't understand why that access would be filtered just from using a VPN in the first place.

 

ive just had a bash at explaining this, see post #2 FAQ Q4, i hope i have been clear enough, its quite a tricky thing to explain in a concise way but ive had a go :-), its a VERY useful feature, esp for those of us that have to suffer ISP filtering.

 

2) If I use 2 VPN containers (Deluge & SABnbzd) does each container count against my PIA device limit? I believe PIA has a 5 device limit.

 

im not 100% sure, but i would think yes, they would count as two seperate connections.

 

3) Will Privoxy running on both DelugeVPN and SABnbzdVPN on the same port cause a conflict? (Also on your github pages I see "Access Privoxy" showing port 8118 and in other places you mention port 8181, not sure if that is a typo or again showing my ignorance of the purpose/usage of Privoxy)

 

they would only conflict is the port on the host side was left unmodified, but to be honest there would be no benefit having two instances of privoxy running, so i would recommend just set enable_privoxy to no.

 

ahh right it should be 8118, can you tell me exactly where you see 8181?.

Share this post


Link to post

Thanks that explanation makes perfect sense. I have not had to deal with such ISPs thus far so I couldn't understand the reasoning before. Now that I understand, my third question seems silly, there would be no reason to run 2 instances of privoxy to tunnel over the same VPN.

 

I saw a reference to 8181 in the description on this github page: https://github.com/binhex/arch-delugevpn and i believe in the same location for SABnbzd github page.

 

Thanks again

Share this post


Link to post

Hmm. this privoxy stuff looks interesting. What is involved in getting it running? Just enabling it by changing the environment variable from no to yes?

 

And I don't quite understand what to do if I am running both sabnzbdvpn and delugevpn.

Share this post


Link to post

I believe you would just enable it for one or the other. No reason to enable it for both. Then you can use that proxy to browse sites over your VPN from any browser/computer on your LAN. binhex can correct me if I'm wrong.

 

binhex  - apologies if this is not the correct forum for the question -- getting off-topic a bit -- but have you considered creating a dedicated VPN/privoxy container and just using "vanilla" deluge and SABnbzd containers with configuration to enable usage of the VPN/privoxy container? I'm not sure it is even possible, but it would mean the entire unRaid box could run as a single device in the eyes of PIA. For most I'm sure a 5 device limit is not an issue, but I have 4 active devices currently so adding 2 more for both deluge and SABnbzd would put me over. It's not *really* a problem since my Usenet provider includes VPN access anyway.... just more or less something I thought about while I am considering the architecture for my server.

 

edit: looks like SABnzbd doesn't support SOCKS5 proxying, but deluge does. I may experiment with creating a privoxy/squid/openvpn container just for the fun of it.

Share this post


Link to post

For the latest update,  under Environment Variables

 

Make sure you change

 

LAN_RANGE to LAN_NETWORK

 

 

Share this post


Link to post

I believe you would just enable it for one or the other. No reason to enable it for both. Then you can use that proxy to browse sites over your VPN from any browser/computer on your LAN. binhex can correct me if I'm wrong.

that's exactly right.

 

binhex  - apologies if this is not the correct forum for the question -- getting off-topic a bit -- but have you considered creating a dedicated VPN/privoxy container and just using "vanilla" deluge and SABnbzd containers with configuration to enable usage of the VPN/privoxy container? I'm not sure it is even possible, but it would mean the entire unRaid box could run as a single device in the eyes of PIA. For most I'm sure a 5 device limit is not an issue, but I have 4 active devices currently so adding 2 more for both deluge and SABnbzd would put me over. It's not *really* a problem since my Usenet provider includes VPN access anyway.... just more or less something I thought about while I am considering the architecture for my server.

 

i wouldnt waste your time to be honest, i played with deluge and socks proxy5 in the early days, in short it doesnt work as you expect, if the proxy drops then all your traffic gets routed over your internet connection, NOT good!, this is what lead me down the path of using a vpn tunnel.

 

What i would like to do is to separate openvpn into its own container, have that running and then have another container running application X that you want to have tunnelled and simply link the two containers together, this has the really nice advantage that its only a single vpn tunnel, and means with a bit of scripting for each container you could pick and choose which apps you want tunnelled. OK so here is the kicker, unraid webui doesnt support this configuration, so there is no way of linking the containers together other than getting down and dirty with the CLI, so until thats possible we are where we are right now, maybe if i get time i will put in a feature request for this.

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.