Jump to content
binhex

[Support] binhex - DelugeVPN

5333 posts in this topic Last Reply

Recommended Posts

 

What i would like to do is to separate openvpn into its own container, have that running and then have another container running application X that you want to have tunnelled and simply link the two containers together, this has the really nice advantage that its only a single vpn tunnel, and means with a bit of scripting for each container you could pick and choose which apps you want tunnelled. OK so here is the kicker, unraid webui doesnt support this configuration, so there is no way of linking the containers together other than getting down and dirty with the CLI, so until thats possible we are where we are right now, maybe if i get time i will put in a feature request for this.

 

+1 This type of solution is very much needed. Having the ability to choose which application uses the VPN provides a great amount of control and flexibility. As an example VPNing docker applications like Sickbeard, Sickrage, Sonarr, Couchpotato, Sabnzbd, to name a few, but not VPNing Plex Server since it has an issue with losing it's connection once a VPN connection is established. Hope to see this type of solution come to fruition in the future.

Share this post


Link to post

 

What i would like to do is to separate openvpn into its own container, have that running and then have another container running application X that you want to have tunnelled and simply link the two containers together, this has the really nice advantage that its only a single vpn tunnel, and means with a bit of scripting for each container you could pick and choose which apps you want tunnelled. OK so here is the kicker, unraid webui doesnt support this configuration, so there is no way of linking the containers together other than getting down and dirty with the CLI, so until thats possible we are where we are right now, maybe if i get time i will put in a feature request for this.

 

+1 This type of solution is very much needed. Having the ability to choose which application uses the VPN provides a great amount of control and flexibility. As an example VPNing docker applications like Sickbeard, Sickrage, Sonarr, Couchpotato, Sabnzbd, to name a few, but not VPNing Plex Server since it has an issue with losing it's connection once a VPN connection is established. Hope to see this type of solution come to fruition in the future.

 

OR... You can use your external firewall / router. Load a DD-WRT or Tomato firmware on your router and using the OpenVPN client & the active routing policies - you can "route" any number of specific internal source IP's out through the VPN. Keeps the networking on the edge and it is actully quite easy to set up (If I can do it! ;-))

 

My 2c,

Share this post


Link to post

OR... You can use your external firewall / router. Load a DD-WRT or Tomato firmware on your router and using the OpenVPN client & the active routing policies - you can "route" any number of specific internal source IP's out through the VPN. Keeps the networking on the edge and it is actully quite easy to set up (If I can do it! ;-))

Easy to set up and use for all services on unraid, yes. Easy to only use for torrents and leave others (like plex) alone, no.

Share this post


Link to post

Yes that's potentially a limited solution. I've deployed several remote wifi routers with DD-WRT / OpenVPN to be able to access remote media servers, but I think the simplicity of deploying the solution binhex is suggesting would be more practical and less limiting since one wouldn't need to have additional hardware, cabling etc, and to be able to pick and choose which applications need to use a VPN. From my recollection Plex does not work with any VPN and the network connection will be lost on the LAN and WAN so things like (local and remote) Roku's and Plex Home Theater won't connect to the server (unless you use something like openelec-kodi to access the smb share on the LAN).

 

 

Share this post


Link to post

WebUI for DelugeVPN has been inaccessible after the last two updates.

 

Logs don't seem to show anything suspicious. For what it's worth, I've tried changing the environment variable LAN_RANGE to LAN_NETWORK as suggested by femin above--but that didn't fix it.

 

Is this happening for anyone else or is it just me?

 

Share this post


Link to post

 

What i would like to do is to separate openvpn into its own container, have that running and then have another container running application X that you want to have tunnelled and simply link the two containers together, this has the really nice advantage that its only a single vpn tunnel, and means with a bit of scripting for each container you could pick and choose which apps you want tunnelled. OK so here is the kicker, unraid webui doesnt support this configuration, so there is no way of linking the containers together other than getting down and dirty with the CLI, so until thats possible we are where we are right now, maybe if i get time i will put in a feature request for this.

 

+1 This type of solution is very much needed. Having the ability to choose which application uses the VPN provides a great amount of control and flexibility. As an example VPNing docker applications like Sickbeard, Sickrage, Sonarr, Couchpotato, Sabnzbd, to name a few, but not VPNing Plex Server since it has an issue with losing it's connection once a VPN connection is established. Hope to see this type of solution come to fruition in the future.

 

OR... You can use your external firewall / router. Load a DD-WRT or Tomato firmware on your router and using the OpenVPN client & the active routing policies - you can "route" any number of specific internal source IP's out through the VPN. Keeps the networking on the edge and it is actully quite easy to set up (If I can do it! ;-))

 

My 2c,

 

Did it.  WAAAYYYY too slow.  routers don't have enough CPU power for real-time encryption.  I slowed my speeds by about 75%.  The VPN really needs to run on a modern CPU, so inside a separate docker is the better solution.  I'm looking at setting up a pfSense install for this very purpose, but an openVPN docker would probably work just as well.

Share this post


Link to post

I setup openVPN on my pfsense router and it worked just fine.  However, it got annoying that the bank requires additional authentication when coming from a VPN, many store fronts don't work because they block known VPN IP ranges, craigslist etc.

 

Took a bit of work to get Plex to work because PIA didn't support a valid port forwarding model.

 

So I went with delugeVPN to avoid the full VPN hassle.  Not an openVPN or pfsense issue, just the fallout when people do stupid things via VPN.

 

david

 

 

What i would like to do is to separate openvpn into its own container, have that running and then have another container running application X that you want to have tunnelled and simply link the two containers together, this has the really nice advantage that its only a single vpn tunnel, and means with a bit of scripting for each container you could pick and choose which apps you want tunnelled. OK so here is the kicker, unraid webui doesnt support this configuration, so there is no way of linking the containers together other than getting down and dirty with the CLI, so until thats possible we are where we are right now, maybe if i get time i will put in a feature request for this.

 

+1 This type of solution is very much needed. Having the ability to choose which application uses the VPN provides a great amount of control and flexibility. As an example VPNing docker applications like Sickbeard, Sickrage, Sonarr, Couchpotato, Sabnzbd, to name a few, but not VPNing Plex Server since it has an issue with losing it's connection once a VPN connection is established. Hope to see this type of solution come to fruition in the future.

 

OR... You can use your external firewall / router. Load a DD-WRT or Tomato firmware on your router and using the OpenVPN client & the active routing policies - you can "route" any number of specific internal source IP's out through the VPN. Keeps the networking on the edge and it is actully quite easy to set up (If I can do it! ;-))

 

My 2c,

 

Did it.  WAAAYYYY too slow.  routers don't have enough CPU power for real-time encryption.  I slowed my speeds by about 75%.  The VPN really needs to run on a modern CPU, so inside a separate docker is the better solution.  I'm looking at setting up a pfSense install for this very purpose, but an openVPN docker would probably work just as well.

Share this post


Link to post

I setup openVPN on my pfsense router and it worked just fine.

 

I assume by pfSense router you mean a computer with pfSense running on it.  If so, then yes, it would work fine because it's not a limited router hardware CPU.  If you tried to run PIA on an ASUS RT-N66 router, which is highly regarded as a good, fast router, you'd discover how slow everything gets.  It just doesn't have enough power for real-time, high security encryption.

 

Hopefully LimeTech allows the hooks needed for binhex to get his PIA docker solution working for us someday.

Share this post


Link to post

WebUI for DelugeVPN has been inaccessible after the last two updates.

 

Logs don't seem to show anything suspicious. For what it's worth, I've tried changing the environment variable LAN_RANGE to LAN_NETWORK as suggested by femin above--but that didn't fix it.

 

Is this happening for anyone else or is it just me?

 

I'm having the same issue....

Share this post


Link to post

I got mine working again after the last update but i now have a new issue... logs show this.

 

2016-02-05 20:29:53,366 DEBG 'start' stderr output:

RwRwrWRwRwRwRwrWR

2016-02-05 20:29:53,367 DEBG 'start' stderr output:

wRwRwRwRwRwRwrWrWr

2016-02-05 20:29:53,368 DEBG 'start' stderr output:

WrWrWrWrW

2016-02-05 20:29:53,386 DEBG 'start' stderr output:

R

2016-02-05 20:29:53,386 DEBG 'start' stderr output:

wRwrW

2016-02-05 20:29:53,387 DEBG 'start' stderr output:

RwRwRwRwrWR

2016-02-05 20:29:53,388 DEBG 'start' stderr output:

wRwrWRwrWRwR

2016-02-05 20:29:53,388 DEBG 'start' stderr output:

wrWRwRwrWRw

2016-02-05 20:29:53,389 DEBG 'start' stderr output:

RwRwrWrW

2016-02-05 20:29:53,390 DEBG 'start' stderr output:

RwR

2016-02-05 20:29:53,390 DEBG 'start' stderr output:

wrW

2016-02-05 20:29:53,397 DEBG 'start' stderr output:

Rw

2016-02-05 20:29:53,398 DEBG 'start' stderr output:

rWrW

2016-02-05 20:29:53,399 DEBG 'start' stderr output:

RwrW

2016-02-05 20:29:53,403 DEBG 'start' stderr output:

Rw

2016-02-05 20:29:53,404 DEBG 'start' stderr output:

Rw

2016-02-05 20:29:53,405 DEBG 'start' stderr output:

RwRwrWrWrWRw

2016-02-05 20:29:53,406 DEBG 'start' stderr output:

rW

2016-02-05 20:29:53,412 DEBG 'start' stderr output:

Rw

2016-02-05 20:29:53,415 DEBG 'start' stderr output:

Rw

2016-02-05 20:29:53,416 DEBG 'start' stderr output:

rWRwrW

2016-02-05 20:29:53,416 DEBG 'start' stderr output:

rWrWrWrW

2016-02-05 20:29:53,417 DEBG 'start' stderr output:

Rw

2016-02-05 20:29:53,417 DEBG 'start' stderr output:

RwrW

2016-02-05 20:29:53,418 DEBG 'start' stderr output:

RwrW

2016-02-05 20:29:53,419 DEBG 'start' stderr output:

R

2016-02-05 20:29:53,419 DEBG 'start' stderr output:

w

2016-02-05 20:29:53,422 DEBG 'start' stderr output:

Rwr

2016-02-05 20:29:53,423 DEBG 'start' stderr output:

WRw

2016-02-05 20:29:53,425 DEBG 'start' stderr output:

RwR

2016-02-05 20:29:53,426 DEBG 'start' stderr output:

wRwrWRwr

2016-02-05 20:29:53,427 DEBG 'start' stderr output:

W

2016-02-05 20:29:53,427 DEBG 'start' stderr output:

R

2016-02-05 20:29:53,428 DEBG 'start' stderr output:

wRwrWRwrW

2016-02-05 20:29:53,428 DEBG 'start' stderr output:

RwRwrWRwrWrW

2016-02-05 20:29:53,430 DEBG 'start' stderr output:

Rw

2016-02-05 20:29:53,430 DEBG 'start' stderr output:

rW

2016-02-05 20:29:53,432 DEBG 'start' stderr output:

Rw

2016-02-05 20:29:53,432 DEBG 'start' stderr output:

rW

2016-02-05 20:29:53,433 DEBG 'start' stderr output:

RwrW

2016-02-05 20:29:53,434 DEBG 'start' stderr output:

Rw

2016-02-05 20:29:53,441 DEBG 'start' stderr output:

Rw

2016-02-05 20:29:53,442 DEBG 'start' stderr output:

RwrWrW

2016-02-05 20:29:53,443 DEBG 'start' stderr output:

Rw

2016-02-05 20:29:53,444 DEBG 'start' stderr output:

RwrWrW

2016-02-05 20:29:53,445 DEBG 'start' stderr output:

RwR

2016-02-05 20:29:53,446 DEBG 'start' stderr output:

wRwrWRwrWrWrW

2016-02-05 20:29:53,456 DEBG 'start' stderr output:

Rw

2016-02-05 20:29:53,457 DEBG 'start' stderr output:

RwRwRwRwRw

2016-02-05 20:29:53,457 DEBG 'start' stderr output:

RwR

 

This repeats over and over.

 

Cashe drive has only 2gb free could this be the issue?

Sry for length of post but forum doesnt seem to let me upload the file.

Share this post


Link to post

WebUI for DelugeVPN has been inaccessible after the last two updates.

 

Logs don't seem to show anything suspicious. For what it's worth, I've tried changing the environment variable LAN_RANGE to LAN_NETWORK as suggested by femin above--but that didn't fix it.

 

Is this happening for anyone else or is it just me?

 

See post #3 if it's still not working then attach supervisord.log

Share this post


Link to post

WebUI for DelugeVPN has been inaccessible after the last two updates.

 

Logs don't seem to show anything suspicious. For what it's worth, I've tried changing the environment variable LAN_RANGE to LAN_NETWORK as suggested by femin above--but that didn't fix it.

 

Is this happening for anyone else or is it just me?

 

I'm having the same issue....

 

See post #3 if it's still not working then attach supervisord.log

Share this post


Link to post

WebUI for DelugeVPN has been inaccessible after the last two updates.

 

Logs don't seem to show anything suspicious. For what it's worth, I've tried changing the environment variable LAN_RANGE to LAN_NETWORK as suggested by femin above--but that didn't fix it.

 

Is this happening for anyone else or is it just me?

 

I'm having the same issue....

 

See post #3 if it's still not working then attach supervisord.log

 

That did it. Somehow I missed this. Thanks binhex!

Share this post


Link to post

WebUI for DelugeVPN has been inaccessible after the last two updates.

 

Logs don't seem to show anything suspicious. For what it's worth, I've tried changing the environment variable LAN_RANGE to LAN_NETWORK as suggested by femin above--but that didn't fix it.

 

Is this happening for anyone else or is it just me?

 

I'm having the same issue....

 

See post #3 if it's still not working then attach supervisord.log

 

That did it. Somehow I missed this. Thanks binhex!

 

The odd part is that i didn't even have the LAN_RANGE network variable in my config. I had to ADD LAN_NETWORK rather. It would not start properly without this added variable.

Share this post


Link to post

 

That did it. Somehow I missed this. Thanks binhex!

 

The odd part is that i didn't even have the LAN_RANGE network variable in my config. I had to ADD LAN_NETWORK rather. It would not start properly without this added variable.

 

Working for me too!

 

Is it not possible to update the container description (which still describes LAN_RANGE)? If not, Lime Tech really needs to fix that...

Share this post


Link to post

 

That did it. Somehow I missed this. Thanks binhex!

 

The odd part is that i didn't even have the LAN_RANGE network variable in my config. I had to ADD LAN_NETWORK rather. It would not start properly without this added variable.

 

Working for me too!

 

Is it not possible to update the container description (which still describes LAN_RANGE)? If not, Lime Tech really needs to fix that...

 

This has already been done, and here is the problem with the template system for unraid, it doesn't update if the author makes a change to the template, so once you have downloaded the template then thats it, you are stuck at thar point in time with that revision of the template, if i make a change you wont see it, unless you deleted any "user defined template" and (maybe) also deleted the template from your flash drive. It's quite a frustrating part of unraid for developers, i wish there could be some way of pushing changes out, but right now its just not possible :-(.

 

If not, Lime Tech really needs to fix that...

 

p.s.i have nothing to do with lime-tech directly, so any changes made would all come from myself, this isnt an official LT Docker image.

Share this post


Link to post

 

That did it. Somehow I missed this. Thanks binhex!

 

The odd part is that i didn't even have the LAN_RANGE network variable in my config. I had to ADD LAN_NETWORK rather. It would not start properly without this added variable.

 

Working for me too!

 

Is it not possible to update the container description (which still describes LAN_RANGE)? If not, Lime Tech really needs to fix that...

 

This has already been done, and here is the problem with the template system for unraid, it doesn't update if the author makes a change to the template, so once you have downloaded the template then thats it, you are stuck at thar point in time with that revision of the template, if i make a change you wont see it, unless you deleted any "user defined template" and (maybe) also deleted the template from your flash drive. It's quite a frustrating part of unraid for developers, i wish there could be some way of pushing changes out, but right now its just not possible :-(.

 

If not, Lime Tech really needs to fix that...

 

p.s.i have nothing to do with lime-tech directly, so any changes made would all come from myself, this isnt an official LT Docker image.

What someone (ie: a template author) needs to do is actually document this in a defect report and list the steps required to do it (and how to work around it) by using Repositories (IE: add the repository, add the container via add-container, then change and upload the template, etc).  Unfortunately, LT may not even be aware that this is an ongoing (albeit rare) issue.

Share this post


Link to post

I can't get Deluge to stop seeding when it reaches a share ratio, could someone help me?

 

I have set "Stop seeding when share ratio reaches" to 0 just to test, but it still seeds. I want to do this so sonarr can delete my torrents after a while.

Share this post


Link to post

I can't get Deluge to stop seeding when it reaches a share ratio, could someone help me?

 

I have set "Stop seeding when share ratio reaches" to 0 just to test, but it still seeds. I want to do this so sonarr can delete my torrents after a while.

Try 0.01 or something like that.

Share this post


Link to post

Very new to unRAID here and I can't for the life of me get DelugeVPN working with NordVPN. I've tried changing multiple setting after reading through this thread and nothing seems to work. Can't even get the webGUI to come up. Any help is much appreciated!

Share this post


Link to post

Very new to unRAID here and I can't for the life of me get DelugeVPN working with NordVPN. I've tried changing multiple setting after reading through this thread and nothing seems to work. Can't even get the webGUI to come up. Any help is much appreciated!

Please attach your supervisord.log file

Share this post


Link to post

Very new to unRAID here and I can't for the life of me get DelugeVPN working with NordVPN. I've tried changing multiple setting after reading through this thread and nothing seems to work. Can't even get the webGUI to come up. Any help is much appreciated!

Please attach your supervisord.log file

 

Attached. I have starred out my username and passwords.

supervisord.txt

Share this post


Link to post

Very new to unRAID here and I can't for the life of me get DelugeVPN working with NordVPN. I've tried changing multiple setting after reading through this thread and nothing seems to work. Can't even get the webGUI to come up. Any help is much appreciated!

Please attach your supervisord.log file

 

Attached. I have starred out my username and passwords.

This is your issue:-

 

[crit] Missing OpenVPN configuration file in /config/openvpn/ (no files with an ovpn extension exist) please create and restart delugevpn

 

So you need to have a openvpn config for from your vpn provider, see the FAQ section in post #2 Q2 for how to get this running with a custom provider.

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.