[Support] NodeLink

Recommended Posts

  • 2 months later...

Will this support the Sonos API?


NodeLink currently supports the following devices:

- Venstar ColorTouch Thermostats

- Brultech GEM

- Ecobee Thermostats

- Generic Data (formerly ISYLink)

- DSC PowerSeries Alarms

- Honeywell (Total Connect Comfort) Thermostats

- RainMachine Irrigation Controllers

- ISY Variable/Program Logger

- CAI WebControl 8

- OWFS (1-Wire)

- Modbus TCP

- MiLight RGBW Light WiFi Bridge

- Honeywell Alarm Systems

Link to comment
  • 1 month later...

Hi, just tried to install this docker and get an error as follows:


"root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="HADashboard" --net="" -e TZ="Europe/Berlin" -e HOST_OS="unRAID" -v "/mnt/cache/apps/Docker/apps/hadashboard/lib":"/lib":rw -v "/mnt/cache/apps/Docker/apps/hadashboard/dashboards":"/dashboards":rw -v "/mnt/cache/apps/Docker/apps/hadashboard/hapush":"/hapush/":rw -v "/mnt/cache/apps/Docker/apps/hadashboard/widgets":"/widgets":rw jcreynolds/docker-hadashboard


docker: Error response from daemon: Container command not found or does not exist.."


Am I missing something? The subdirectories have been created but they are all empty!


Link to comment
  • 1 month later...
  • 10 months later...
  • 3 weeks later...
  • 3 weeks later...
  • 2 months later...
  • 1 month later...

Thanks @Squid, I just realized this was for NodeLink. I was actually trying to get Phlex working. Just FYI; this thread is linked from the Support Thread link for Phlex in CA. 


Changing network mode didn't help Phlex :) but it was worth a try.


Anyone else looking for Phlex support, haven't gotten a working docker for it. But, I've gotten Phlex to work by installing an instance of nginx and extracting a copy of the Phlex zip into the www folder. 

Edited by keithwlandry
Link to comment
  • 4 months later...
  • 1 month later...
  • 4 weeks later...
On ‎11‎/‎3‎/‎2018 at 6:13 PM, Tibbar said:

Anyone knows how to update Mono in this docker?

I was not able to find a way to do it and went down the path of finding another docker. There are a couple out there direct from Docker hub. I found one that was a few version behind and it for most features. Educating myself on dockers now as finding help on some of these can be....difficult.

Link to comment
  • 5 months later...
On 4/21/2018 at 12:57 PM, Squid said:

Looks like the template was made with an ancient and buggy version of dockerMan.  The solution is this

  1. Change the network mode from Bridge to Host


I'm going to pop a mod comment onto the app until such time as this gets worked out.

@Squid I have updated the dockerfile so that uses the latest version of mono, and I also have updated the template to fix those issues.

  • Like 1
Link to comment
  • 7 months later...
On 5/16/2019 at 11:01 AM, jcreynoldsii said:

@ShovelHead @Tibbar The dockerfile has been updated to so that it runs the latest version of mono.  Can someone who uses this docker please report back to make sure all is well?

I had another version working but it recently failed after some changes to my unraid server. Saw you had an updated version in CA and came back by here to see you wanted some feedback. I loaded it up and replaced my old docker. Installed fine and connected instantly to my devices. Old ISY node was recognized and matched to the new Nodelink device. No need to re-add the node.
I will run it a few days and let you know my experience. The other build I was using would periodically lose thermostat heartbeat and need a reboot. I am hopeful this one will be a bit more stable.
I appreciate your updates.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.